<!DOCTYPE html>
<!--[if lt IE 7]> <html lang="en-US" class="no-js ie6"> <![endif]-->
<!--[if IE 7]>    <html lang="en-US" class="no-js ie7"> <![endif]-->
<!--[if IE 8]>    <html lang="en-US" class="no-js ie8"> <![endif]-->
<!--[if IE 9]>    <html lang="en-US" class="no-js ie9"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--> <html lang="en-US" class="no-js"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://highlandscurrent.org/xmlrpc.php" />
<title>Beacon Obituaries | The Highlands Current</title>
<script>
			function whichHeader() {
				var screenWidth = document.documentElement.clientWidth,
				header_img;
				if (screenWidth <= 767) {
					header_img = 'https://highlandscurrent.org/wp-content/uploads/2021/08/currentslogo-pantone3145U-768-240.png';
				} else if (screenWidth > 767 && screenWidth <= 979) {
					header_img = 'https://highlandscurrent.org/wp-content/uploads/2021/08/currentslogo-pantone3145U-980-180-771x142-1.png';
				} else {
					header_img = 'https://highlandscurrent.org/wp-content/uploads/2021/08/currentslogo-pantone3145U-500a-1.png';
				}
				return header_img;
			}
			var banner_img_src = whichHeader();
		</script>

<style type="text/css">
					.heateor_sss_button_instagram span.heateor_sss_svg,a.heateor_sss_instagram span.heateor_sss_svg{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sss_horizontal_sharing .heateor_sss_svg,.heateor_sss_standard_follow_icons_container .heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
					.heateor_sss_horizontal_sharing .heateorSssTCBackground{
				color:#666;
			}
					.heateor_sss_horizontal_sharing span.heateor_sss_svg:hover,.heateor_sss_standard_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing span.heateor_sss_svg,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
						.heateor_sss_vertical_sharing span.heateor_sss_svg:hover,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}		</style>
<meta name='robots' content='max-image-preview:large' />
<script type="text/javascript">                function apbct_attach_event_handler__backend(elem, event, callback){                    if(typeof window.addEventListener === "function") elem.addEventListener(event, callback);                    else                                              elem.attachEvent(event, callback);                }                apbct_attach_event_handler__backend(window, 'load', function(){                    if (typeof ctSetCookie === "function")                        ctSetCookie('ct_checkjs', '1361632994' );                    else                         console.log('APBCT ERROR: apbct-public--functions is not loaded.');                });    </script><link rel="manifest" href="https://highlandscurrent.org/pwa-manifest.json">
<link rel="apple-touch-screenshots-precomposed" sizes="512x512" href="https://highlandscurrent.org/wp-content/plugins/pwa-for-wp/images/logo-512x512.png">
<link rel="apple-touch-icon-precomposed" sizes="192x192" href="https://highlandscurrent.org/wp-content/uploads/2020/12/HC-circle-192.jpg">
<link rel='dns-prefetch' href='//maps.googleapis.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='preconnect' href='//www.google-analytics.com' />
<link rel="alternate" type="application/rss+xml" title="The Highlands Current &raquo; Feed" href="https://highlandscurrent.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Highlands Current &raquo; Comments Feed" href="https://highlandscurrent.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Highlands Current &raquo; Beacon Obituaries Comments Feed" href="https://highlandscurrent.org/2022/05/01/beacon-obituaries-288/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/highlandscurrent.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<style>
		.wc_apbct_email_id {
			display: none !important;
		}
		</style><link rel='stylesheet' id='wp-block-library-css' href='https://highlandscurrent.org/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='amazonpolly-css' href='https://highlandscurrent.org/wp-content/plugins/amazon-polly/public/css/amazonpolly-public.css' type='text/css' media='all' />
<link rel='stylesheet' id='better-recent-comments-css' href='https://highlandscurrent.org/wp-content/plugins/better-recent-comments/assets/css/better-recent-comments.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='document-gallery-css' href='https://highlandscurrent.org/wp-content/plugins/document-gallery/assets/css/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='nws-alerts-css-css' href='https://highlandscurrent.org/wp-content/plugins/national-weather-service-alerts/css/nws-alerts.css' type='text/css' media='all' />
<link rel='stylesheet' id='secondline-psb-subscribe-button-styles-css' href='https://highlandscurrent.org/wp-content/plugins/podcast-subscribe-buttons/assets/css/secondline-psb-styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='twenty20-style-css' href='https://highlandscurrent.org/wp-content/plugins/twenty20/assets/css/twenty20.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpb-google-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans' type='text/css' media='all' />
<link rel='stylesheet' id='weather-atlas-css' href='https://highlandscurrent.org/wp-content/plugins/weather-atlas/public/css/weather-atlas-public.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-css' href='https://highlandscurrent.org/wp-content/plugins/weather-atlas/public/font/weather-icons/weather-icons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='crossword-custom-css' href='https://highlandscurrent.org/wp-content/plugins/wp-crossword/modules/css/custom.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpel-style-css' href='https://highlandscurrent.org/wp-content/plugins/wp-external-links/public/css/wpel.css' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://highlandscurrent.org/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css' type='text/css' media='all' />
<link rel='stylesheet' id='largo-stylesheet-css' href='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/css/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slick-css' href='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/lib/navis-slideshows/vendor/slick/slick.css' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slides-css' href='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/lib/navis-slideshows/css/slides.css' type='text/css' media='all' />
<link rel='stylesheet' id='largo-stylesheet-gutenberg-css' href='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/css/gutenberg.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpbdp-widgets-css' href='https://highlandscurrent.org/wp-content/plugins/business-directory-plugin/assets/css/widgets.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-font-awesome-css' href='https://use.fontawesome.com/releases/v5.2.0/css/all.css' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-frontend-style-css' href='https://highlandscurrent.org/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-featured-ads-css' href='https://highlandscurrent.org/wp-content/plugins/awpcp-featured-ads/resources/css/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_frontend_css-css' href='https://highlandscurrent.org/wp-content/plugins/sassy-social-share/public/css/sassy-social-share-public.css' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-qtip-css' href='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/css/vendor/jquery.qtip.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-grid-css' href='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/css/default-calendar-grid.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-list-css' href='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/css/default-calendar-list.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='popup-maker-site-css' href='//highlandscurrent.org/wp-content/uploads/338ed686b1e9dfa245583e66e19435b4.css?generated=1650734278' type='text/css' media='all' />
<link rel='stylesheet' id='pwaforwp-style-css' href='https://highlandscurrent.org/wp-content/plugins/pwa-for-wp/assets/css/pwaforwp-main.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='default-styles-css' href='https://highlandscurrent.org/wp-content/plugins/business-directory-plugin/themes/default/assets/styles.css' type='text/css' media='all' />
<!--[if lte IE 6]>
<link rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='https://highlandscurrent.org/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css' type='text/css' media='all' />
<![endif]-->
<!--[if lte IE 7]>
<link rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='https://highlandscurrent.org/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='awpcp-custom-css-css' href='https://highlandscurrent.org/wp-content/plugins/awpcp_custom_stylesheet.css' type='text/css' media='all' />
<script type="text/javascript">
			ajaxurl = typeof(ajaxurl) !== 'string' ? 'https://highlandscurrent.org/wp-admin/admin-ajax.php' : ajaxurl;
		</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/shortcode-for-current-date/dist/script.js' id='shortcode-for-current-date-script-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/amazon-polly/public/js/amazonpolly-public.js' id='amazonpolly-js'></script>
<script type='text/javascript' id='ct_public_functions-js-extra'>
/* <![CDATA[ */
var ctPublicFunctions = {"_ajax_nonce":"11577f8970","_rest_nonce":"471ac52244","_ajax_url":"\/wp-admin\/admin-ajax.php","_rest_url":"https:\/\/highlandscurrent.org\/index.php?rest_route=\/","_apbct_ajax_url":"https:\/\/highlandscurrent.org\/wp-content\/plugins\/cleantalk-spam-protect\/lib\/Cleantalk\/ApbctWP\/Ajax.php","data__cookies_type":"native","data__ajax_type":"admin_ajax"};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/cleantalk-spam-protect/js/apbct-public--functions.min.js' id='ct_public_functions-js'></script>
<script type='text/javascript' id='ct_public-js-extra'>
/* <![CDATA[ */
var ctPublic = {"pixel__setting":"0","pixel__enabled":"","pixel__url":null,"data__email_check_before_post":"1","data__cookies_type":"native","data__visible_fields_required":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.min.js' id='ct_public-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/cleantalk-spam-protect/js/cleantalk-modal.min.js' id='cleantalk-modal-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/cleantalk-spam-protect/js/cleantalk_external.min.js' id='ct_external-js'></script>
<script type='text/javascript' src='https://maps.googleapis.com/maps/api/js?key=AIzaSyAQcz2jN2R2VpArHbuwahU2h3jsTNrNm8A&#038;v=3.exp&#038;libraries=weather' id='google-map-api-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/weather-atlas/public/js/weather-atlas-public.min.js' id='weather-atlas-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/weather-atlas/public/js/jquery-cookie.min.js' id='jquery-cookie-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/wp-crossword/modules/js/custom.js' id='crossword-custom-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":75,"ajax_url":"https:\/\/highlandscurrent.org\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/highlandscurrent.org\/wp-json\/wordpress-popular-posts","ID":4910512,"token":"471ac52244","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js' id='wpp-js-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/js/load-more-posts.min.js' id='load-more-posts-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/js/modernizr.custom.js' id='largo-modernizr-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/wp-content/cache/caos-analytics/19c916a8.js?id=UA-45190490-1' id='caos-gtag-js'></script>
<script type='text/javascript' id='caos-gtag-js-after'>
    

    window.dataLayer = window.dataLayer || [];

    function gtag() {
    dataLayer.push(arguments);
    }
    gtag('js', new Date());
    gtag('config', 'UA-45190490-1', {"cookie_prefix":"CaosGtag","cookie_domain":"highlandscurrent.org","cookie_expires":2592000,"cookie_flags":"samesite=none;secure","allow_google_signals":true,"site_speed_sample_rate":""});
                
</script>
<script type='text/javascript' id='whp6856front.js5441-js-extra'>
/* <![CDATA[ */
var whp_local_data = {"add_url":"https:\/\/highlandscurrent.org\/wp-admin\/post-new.php?post_type=event","ajaxurl":"https:\/\/highlandscurrent.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/wp-security-hardening/modules/js/front.js' id='whp6856front.js5441-js'></script>
<link rel="https://api.w.org/" href="https://highlandscurrent.org/wp-json/" /><link rel="alternate" type="application/json" href="https://highlandscurrent.org/wp-json/wp/v2/posts/4910512" /><link rel='shortlink' href='https://highlandscurrent.org/?p=4910512' />
<link rel="alternate" type="application/json+oembed" href="https://highlandscurrent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fhighlandscurrent.org%2F2022%2F05%2F01%2Fbeacon-obituaries-288%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://highlandscurrent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fhighlandscurrent.org%2F2022%2F05%2F01%2Fbeacon-obituaries-288%2F&#038;format=xml" />

<script src='https://highlandscurrent.org/wp-content/cache/caos-analytics/20e7ade3.js'></script>
<script>
    window.ga = window.ga || function() {
        (ga.q = ga.q || []).push(arguments);
    };
    ga.l = +new Date;

        ga('create', 'UA-45190490-1', {"cookieName":"caosLocalGa","cookieDomain":"highlandscurrent.org","cookieExpires":2592000,"cookieFlags":"samesite=none;secure"});
            ga('send', 'pageview');
                    setTimeout("ga('send', 'event', 'Adjusted Bounce Rate', '45 seconds')", 45000);
        </script>
<meta property="fb:pages" content="130747183632721" />
<script type="text/javascript">
            var ajaxurl = 'https://highlandscurrent.org/wp-admin/admin-ajax.php';
        </script>
<script>/* <![CDATA[ */ portfolio_slideshow = { options : {"psHash":"false","psLoader":"false"}, slideshows : new Array() }; /* ]]> */</script> <style id="wpp-loading-animation-styles">@-webkit-keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}@keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}.wpp-widget-placeholder,.wpp-widget-block-placeholder{margin:0 auto;width:60px;height:3px;background:#dd3737;background:linear-gradient(90deg,#dd3737 0%,#571313 10%,#dd3737 100%);background-size:200% auto;border-radius:3px;-webkit-animation:bgslide 1s infinite linear;animation:bgslide 1s infinite linear}</style>
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@highlandcurrent">
<meta property="og:title" content="Beacon Obituaries" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://highlandscurrent.org/2022/05/01/beacon-obituaries-288/" />
<meta property="og:description" content="Betty Baldwin, Israel Beltran Sr., Gloria Marchie" />
<meta name="description" content="Betty Baldwin, Israel Beltran Sr., Gloria Marchie" />
<meta property="og:site_name" content="The Highlands Current" /><meta property="og:image" content="https://highlandscurrent.org/wp-content/uploads/2021/10/candles.jpg" /><meta property="fb:admins" content="130747183632721" /><meta property="fb:app_id" content="448227681904822" /><link rel="apple-touch-icon" href="https://highlandscurrent.org/wp-content/uploads/2019/09/HC-circle-200.jpg" /><link rel="shortcut icon" href="https://highlandscurrent.org/wp-content/uploads/2019/09/HC-circle-16.jpg" /><meta name="news_keywords" content="Obituaries"><meta name="original-source" content="https://highlandscurrent.org/2022/05/01/beacon-obituaries-288/" /><meta name="syndication-source" content="https://highlandscurrent.org/2022/05/01/beacon-obituaries-288/" /><script type="application/ld+json">
{
    "@context": "http:\/\/schema.org",
    "@type": [
        "ReportageNewsArticle",
        "ObituaryNewsArticle"
    ],
    "publishingPrinciples": "https:\/\/highlandscurrent.org\/editorial-standards\/",
    "image": "https:\/\/highlandscurrent.org\/wp-content\/uploads\/2021\/10\/candles-140x140.jpg",
    "headline": "Beacon Obituaries",
    "datePublished": "2022-05-01 22:26:31",
    "author": {
        "@type": "Person",
        "workLocation": {
            "@type": "Place"
        },
        "contactPoint": {
            "@type": "ContactPoint",
            "contactType": "Journalist",
            "telephone": "845-809-5584",
            "email": "editor@highlandscurrent.org"
        },
        "sameAs": [
            "https:\/\/highlandscurrent.org\/author\/site-editor\/"
        ],
        "name": "Staff",
        "description": "Articles attributed to \"staff\" are written by the editor or a senior editor. This is typically because they are brief items based on a single source, such as a press release, or there are multiple contributors, such as a collection of photos."
    }
}
</script>
<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="canonical" href="https://highlandscurrent.org/2022/05/01/beacon-obituaries-288/" />
<link rel="icon" href="https://highlandscurrent.org/wp-content/uploads/2018/04/cropped-HC-circle-new-32x32.png" sizes="32x32" />
<link rel="icon" href="https://highlandscurrent.org/wp-content/uploads/2018/04/cropped-HC-circle-new-192x192.png" sizes="192x192" />
<meta name="msapplication-TileImage" content="https://highlandscurrent.org/wp-content/uploads/2018/04/cropped-HC-circle-new-270x270.png" />
<meta name="pwaforwp" content="wordpress-plugin" />
<meta name="theme-color" content="#D5E0EB">
<meta name="apple-mobile-web-app-title" content="The Highlands Current">
<meta name="application-name" content="The Highlands Current">
<meta name="apple-mobile-web-app-capable" content="yes">
<meta name="apple-mobile-web-app-status-bar-style" content="default">
<meta name="mobile-web-app-capable" content="yes">
<meta name="apple-touch-fullscreen" content="YES">
<link rel="apple-touch-startup-image" href="https://highlandscurrent.org/wp-content/uploads/2020/12/HC-circle-192.jpg">
<link rel="apple-touch-icon" sizes="192x192" href="https://highlandscurrent.org/wp-content/uploads/2020/12/HC-circle-192.jpg">
<link rel="apple-touch-icon" sizes="512x512" href="https://highlandscurrent.org/wp-content/uploads/2018/04/cropped-HC-circle-new.png">
<link rel="apple-touch-startup-image" href="https://highlandscurrent.org/wp-content/plugins/pwa-for-wp/images/logo-512x512.png">
<link rel="apple-touch-icon" sizes="512x512" href="https://highlandscurrent.org/wp-content/plugins/pwa-for-wp/images/logo-512x512.png">
<link rel="apple-touch-startup-image" href="https://highlandscurrent.org/wp-content/plugins/pwa-for-wp/images/logo-512x512.png" />
</head>
<body class="post-template-default single single-post postid-4910512 single-format-standard wp-embed-responsive nws-alerts-bar-enabled fpt-template-largo-0.6.3 wpbdp-with-button-styles classic">
<article class="nws-alerts nws-alerts-collapsible nws-alerts-bar  nws-alerts-no-entries" data-settings="{&quot;zip&quot;:&quot;10516&quot;,&quot;scope&quot;:&quot;county&quot;,&quot;limit&quot;:0,&quot;display&quot;:&quot;bar&quot;,&quot;classes&quot;:&quot;nws-alerts-bar  nws-alerts-no-entries&quot;,&quot;location_title&quot;:&quot;Highlands&quot;,&quot;refresh_rate&quot;:15}">

<section class="nws-alerts-heading nws-alerts-heading-no-graphic">



<span class="nws-alerts-heading-location">Highlands</span><span class="nws-alerts-heading-scope">Local Weather Alerts</span>
</section>

<section class="nws-alerts-details">

<section class="nws-alerts-entries">

There are currently no active weather alerts. </section>

</section>
</article>
<div id="top"></div>
<div class="global-nav-bg">
<div class="global-nav">
<nav id="top-nav" class="span12">
<span class="visuallyhidden">
<a href="#main" title="Skip to content">Skip to content</a>
</span>
<div class="nav-right">
<div class="donate-btn"><a href="https://highlandscurrent.org/membership/" data-wpel-link="internal"><i class="icon-heart"></i>Become a Member</a></div> <div id="header-search">
<form class="form-search" role="search" method="get" action="https://highlandscurrent.org/">
<div class="input-append">
<input type="text" placeholder="Search" class="input-medium appendedInputButton search-query" value="" name="s" /><button type="submit" class="search-submit btn">GO</button>
</div>
</form>
</div>

</div>
</nav>
</div> 
</div> 
<div id="page" class="hfeed clearfix">
<div class="sticky-nav-wrapper nocontent">
<div class="sticky-nav-holder">
<div class="sticky-nav-container">
<nav id="sticky-nav" class="sticky-navbar navbar clearfix">
<div class="container">
<div class="nav-right">
<ul id="header-extras">
<li class="donate">
<a class="donate-link" href="https://highlandscurrent.org/membership/" data-wpel-link="internal">
<span><i class="icon-heart"></i>Become a Member</span>
</a>
</li> <li id="sticky-nav-search">
<a href="#" class="toggle">
<i class="icon-search" title="Search" role="button"></i>
</a>
<form class="form-search" role="search" method="get" action="https://highlandscurrent.org/">
<div class="input-append">
<span class="text-input-wrapper">
<input type="text" placeholder="Search" class="input-medium appendedInputButton search-query" value="" name="s" />
</span>
<button type="submit" class="search-submit btn">Go</button>
</div>
</form>
</li>
<li>

<a class="btn btn-navbar toggle-nav-bar" title="More">
<div class="bars">
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</div>
</a>
</li>
</ul>
</div>

<div class="nav-left">
<ul>
<li class="home-icon"><a href="https://highlandscurrent.org/" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2021/08/currentslogo-pantone3145U-500a-1.png" class="attachment-home-logo" alt="logo"></a></li>
</ul>
</div>


<div class="nav-shelf">
<ul class="nav">
<li class="home-icon">
<a href="https://highlandscurrent.org/" data-wpel-link="internal">
<img src="https://highlandscurrent.org/wp-content/uploads/2021/08/currentslogo-pantone3145U-500a-1.png" class="attachment-home-logo" alt="logo"> </a>
</li>
<li id="menu-item-92601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92601"><a href="https://highlandscurrent.org/category/philipstown/" data-wpel-link="internal">Philipstown</a></li>
<li id="menu-item-92597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92597"><a href="https://highlandscurrent.org/category/beacon/" data-wpel-link="internal">Beacon</a></li>
<li id="menu-item-92596" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92596"><a href="https://highlandscurrent.org/category/arts/" data-wpel-link="internal">Arts</a></li>
<li id="menu-item-4285070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4285070"><a href="https://highlandscurrent.org/category/sports/" data-wpel-link="internal">Sports</a></li>
<li id="menu-item-4285086" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4285086"><a href="https://highlandscurrent.org/category/obituaries/" data-wpel-link="internal">Obits</a></li>
<li id="menu-item-1270852" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-1270852"><a href="https://highlandscurrent.org/category/columns/" class="dropdown-toggle" data-wpel-link="internal">Columns <b class="caret"></b></a>
<ul class="dropdown-menu">
<li id="menu-item-2145700" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2145700"><a href="https://highlandscurrent.org/tag/reporters-notebook/" data-wpel-link="internal">Reporter&#8217;s Notebook</a></li>
<li id="menu-item-1270862" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270862"><a href="https://highlandscurrent.org/tag/out-there/" data-wpel-link="internal">Out There</a></li>
<li id="menu-item-1270854" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270854"><a href="https://highlandscurrent.org/tag/roots-and-shoots/" data-wpel-link="internal">Roots and Shoots</a></li>
<li id="menu-item-1270853" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270853"><a href="https://highlandscurrent.org/tag/mouths-to-feed/" data-wpel-link="internal">Mouths to Feed</a></li>
<li id="menu-item-1270855" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270855"><a href="https://highlandscurrent.org/tag/small-good-things/" data-wpel-link="internal">Small Good Things</a></li>
<li id="menu-item-4808000" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4808000"><a href="https://highlandscurrent.org/tag/living-green/" data-wpel-link="internal">Living Green</a></li>
<li id="menu-item-1270859" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270859"><a href="https://highlandscurrent.org/tag/kid-friendly/" data-wpel-link="internal">Kid Friendly</a></li>
<li id="menu-item-1270861" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270861"><a href="https://highlandscurrent.org/tag/genealogy/" data-wpel-link="internal">Family Trails</a></li>
</ul>
</li>
<li id="menu-item-28023" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-28023"><a href="https://highlandscurrent.org/advertise/" class="dropdown-toggle" data-wpel-link="internal">Advertise <b class="caret"></b></a>
<ul class="dropdown-menu">
<li id="menu-item-3617400" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617400"><a href="https://highlandscurrent.org/advertise/" data-wpel-link="internal">View Media Kit</a></li>
<li id="menu-item-3617432" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617432"><a href="https://highlandscurrent.org/advertise/" data-wpel-link="internal">View Circulation Audit</a></li>
<li id="menu-item-3617396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617396"><a href="https://highlandscurrent.org/phils-list/" data-wpel-link="internal">View Classified Ads</a></li>
<li id="menu-item-3745912" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3745912"><a href="https://highlandscurrent.org/phils-list/place-ad/" data-wpel-link="internal">Place Classified Ad</a></li>
<li id="menu-item-3617392" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617392"><a href="https://highlandscurrent.org/public-notices/" data-wpel-link="internal">Public Notices</a></li>
<li id="menu-item-3617426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617426"><a href="https://highlandscurrent.org/advertise/adpay/" data-wpel-link="internal">Pay for Your Ad</a></li>
</ul>
</li>
<li id="menu-item-179247" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-179247"><a href="https://highlandscurrent.org/membership/" class="dropdown-toggle" data-wpel-link="internal">Support Our Work <b class="caret"></b></a>
<ul class="dropdown-menu">
<li id="menu-item-537662" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537662"><a href="https://highlandscurrent.org/membership/" data-wpel-link="internal">Become a member</a></li>
<li id="menu-item-3123099" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3123099"><a href="https://highlandscurrent.org/membership/renewal/" data-wpel-link="internal">Renew your membership</a></li>
<li id="menu-item-3123095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3123095"><a href="https://highlandscurrent.org/membership/gift-membership/" data-wpel-link="internal">Give a gift membership</a></li>
<li id="menu-item-3123118" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3123118"><a href="https://highlandscurrent.org/membership/donate/" data-wpel-link="internal">Make a special donation</a></li>
<li id="menu-item-3617738" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617738"><a href="https://highlandscurrent.org/membership/update-your-member-information/" data-wpel-link="internal">Update your information</a></li>
<li id="menu-item-4741458" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4741458"><a href="https://highlandscurrent.org/members-list/" data-wpel-link="internal">Member List</a></li>
</ul>
</li>
<li id="menu-item-4800863" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children dropdown menu-item-4800863"><a href="https://highlandscurrent.org" class="dropdown-toggle" data-wpel-link="internal">Resources <b class="caret"></b></a>
<ul class="dropdown-menu">
<li id="menu-item-4800866" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4800866"><a href="https://highlandscurrent.org/philipstown-calendar/" data-wpel-link="internal">Community Calendar</a></li>
<li id="menu-item-4800888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4800888"><a href="https://highlandscurrent.org/covid-testing-vaccines-putnam-dutchess/" data-wpel-link="internal">COVID Testing &#038; Vaccines</a></li>
<li id="menu-item-4800864" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4800864"><a href="https://highlandscurrent.org/storms-weather-updates-cold-spring-beacon/" data-wpel-link="internal">Storm Updates</a></li>
<li id="menu-item-105563" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-105563"><a href="https://highlandscurrent.org/business-directory/" data-wpel-link="internal">Business Directory <i class="icon-arrow-right"></i></a>
<ul class="dropdown-menu sub-menu">
<li id="menu-item-4800877" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4800877"><a href="https://highlandscurrent.org/shop-local-online/" data-wpel-link="internal">Shop Local, Online</a></li>
</ul>
</li>
<li id="menu-item-4800865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-4800865"><a href="https://highlandscurrent.org/local-officials/" data-wpel-link="internal">Local Officials <i class="icon-arrow-right"></i></a>
<ul class="dropdown-menu sub-menu">
<li id="menu-item-4800868" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4800868"><a href="https://highlandscurrent.org/meeting-videos/" data-wpel-link="internal">Meeting Videos</a></li>
</ul>
</li>
<li id="menu-item-127714" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-127714"><a href="https://highlandscurrent.org/help-wanted-cold-spring-garrison-new-york-jobs/" data-wpel-link="internal">Job Search <i class="icon-arrow-right"></i></a>
<ul class="dropdown-menu sub-menu">
<li id="menu-item-127719" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127719"><a href="https://highlandscurrent.org/beacon-jobs-employment-help-wanted/" data-wpel-link="internal">Beacon</a></li>
<li id="menu-item-127715" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127715"><a href="https://highlandscurrent.org/help-wanted-cold-spring-garrison-new-york-jobs/" data-wpel-link="internal">Philipstown</a></li>
</ul>
</li>
<li id="menu-item-4800867" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4800867"><a href="https://highlandscurrent.org/putnam-county-new-york-real-estate-data/" data-wpel-link="internal">Real Estate Data</a></li>
</ul>
</li>
<li id="menu-item-328205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children dropdown menu-item-328205"><a href="https://highlandscurrent.org" class="dropdown-toggle" data-wpel-link="internal">Reader Guide <b class="caret"></b></a>
<ul class="dropdown-menu">
<li id="menu-item-88586" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88586"><a href="https://highlandscurrent.org/contact/" data-wpel-link="internal">Contact</a></li>
<li id="menu-item-88585" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88585"><a href="https://highlandscurrent.org/about/" data-wpel-link="internal">About</a></li>
<li id="menu-item-537674" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537674"><a href="https://highlandscurrent.org/editorial-standards/" data-wpel-link="internal">Editorial Standards</a></li>
<li id="menu-item-4851780" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4851780"><a href="https://highlandscurrent.org/podcast/" data-wpel-link="internal">Podcast</a></li>
<li id="menu-item-328206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-328206"><a href="https://highlandscurrent.org/archives/" data-wpel-link="internal">Back Issues</a></li>
<li id="menu-item-537666" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537666"><a href="https://highlandscurrent.org/newsletter/" data-wpel-link="internal">Free Newsletter</a></li>
<li id="menu-item-537672" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537672"><a href="https://highlandscurrent.org/delivery/" data-wpel-link="internal">Mail Delivery</a></li>
<li id="menu-item-537669" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537669"><a href="https://highlandscurrent.org/pick-paper/" data-wpel-link="internal">Where to Find Paper</a></li>
<li id="menu-item-4822435" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4822435"><a href="https://highlandscurrent.org/student-journalists-program/" data-wpel-link="internal">Student Journalists</a></li>
</ul>
</li>
<li class="donate">
<a class="donate-link" href="https://highlandscurrent.org/membership/" data-wpel-link="internal">
<span>Become a Member</span>
</a>
</li> </ul>
</div>
</div>
</nav>
</div>
</div>
</div>
<header id="site-header" class="clearfix nocontent" itemscope itemtype="https://schema.org/Organization">
<h2 class="visuallyhidden">
<a itemprop="url" href="https://highlandscurrent.org/" data-wpel-link="internal">
<span class="sitename" itemprop="name">The Highlands Current</span>
<span class="tagline" itemprop="description"> - News for Philipstown (Cold Spring, Nelsonville, Garrison) and Beacon, New York</span>
</a>
</h2>
<a itemprop="url" href="https://highlandscurrent.org/" data-wpel-link="internal"><img class="header_img" src="" alt="" /></a><meta itemprop="logo" content="https://highlandscurrent.org/wp-content/uploads/2019/09/HC-circle-200.jpg" /><aside id="text-82" class="widget widget-1 odd default widget_text clearfix"> <div class="textwidget">May 02, 2022
</div>
</aside><aside id="ai_widget-3" class="widget widget-2 even default ai_widget clearfix"><div class='code-block code-block-2 ai-track' data-ai='WzIsIiIsIlRvcCBvZiBQYWdlIiwiIiwxXQ==' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<style>
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-filter-check, .ai-fallback, .ai-list-block, .ai-list-block-ip, .ai-list-block-filter {visibility: hidden; position: absolute; width: 50%; height: 1px; top: -1000px; z-index: -9999; margin: 0px!important;}
.ai-list-data, .ai-ip-data, .ai-filter-check, .ai-fallback {min-width: 1px;}
</style>
<div class='ai-rotate ai-unprocessed ai-2-1' data-info='WyIyLTEiLDNd' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="QQ==" data-time="MTA=">
<br>
<br>
<a href="https://highlandscurrent.org/membership" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2021/01/OnlineHouseLONG-Support_border.jpg" alt="Membership ad"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qg==" data-time="MTA=">
<br>
<br>
<a href="https://www.jdoqocy.com/q879xdmjdl09217265024AA1861" target="_blank" data-wpel-link="external" rel="external noopener">
<img src="https://www.tqlkg.com/b1110m-3sywHQJIOJNMHJLRRIPNI" alt="Magzter" border="0" /></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qw==" data-time="MTA=">
<br>
<br>
<a href="https://www.philipstowndemocrats.org" target="_blank" data-wpel-link="external" rel="external noopener">
<img src="https://highlandscurrent.org/wp-content/uploads/2022/05/banner-democrats.png" alt="Magzter" border="0" /></a></div>
</div>
</div>
</aside></header>
<header class="print-header nocontent">
<p>
<strong>The Highlands Current</strong>
(https://highlandscurrent.org/2022/05/01/beacon-obituaries-288/)
</p>
</header>
<nav id="main-nav" class="navbar clearfix">
<div class="navbar-inner">
<div class="container">
<div class="nav-shelf">
<ul class="nav">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92601"><a href="https://highlandscurrent.org/category/philipstown/" data-wpel-link="internal">Philipstown</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92597"><a href="https://highlandscurrent.org/category/beacon/" data-wpel-link="internal">Beacon</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92596"><a href="https://highlandscurrent.org/category/arts/" data-wpel-link="internal">Arts</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4285070"><a href="https://highlandscurrent.org/category/sports/" data-wpel-link="internal">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4285086"><a href="https://highlandscurrent.org/category/obituaries/" data-wpel-link="internal">Obits</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-1270852"><a href="https://highlandscurrent.org/category/columns/" class="dropdown-toggle" data-wpel-link="internal">Columns <b class="caret"></b></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2145700"><a href="https://highlandscurrent.org/tag/reporters-notebook/" data-wpel-link="internal">Reporter&#8217;s Notebook</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270862"><a href="https://highlandscurrent.org/tag/out-there/" data-wpel-link="internal">Out There</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270854"><a href="https://highlandscurrent.org/tag/roots-and-shoots/" data-wpel-link="internal">Roots and Shoots</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270853"><a href="https://highlandscurrent.org/tag/mouths-to-feed/" data-wpel-link="internal">Mouths to Feed</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270855"><a href="https://highlandscurrent.org/tag/small-good-things/" data-wpel-link="internal">Small Good Things</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4808000"><a href="https://highlandscurrent.org/tag/living-green/" data-wpel-link="internal">Living Green</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270859"><a href="https://highlandscurrent.org/tag/kid-friendly/" data-wpel-link="internal">Kid Friendly</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270861"><a href="https://highlandscurrent.org/tag/genealogy/" data-wpel-link="internal">Family Trails</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-28023"><a href="https://highlandscurrent.org/advertise/" class="dropdown-toggle" data-wpel-link="internal">Advertise <b class="caret"></b></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617400"><a href="https://highlandscurrent.org/advertise/" data-wpel-link="internal">View Media Kit</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617432"><a href="https://highlandscurrent.org/advertise/" data-wpel-link="internal">View Circulation Audit</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617396"><a href="https://highlandscurrent.org/phils-list/" data-wpel-link="internal">View Classified Ads</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3745912"><a href="https://highlandscurrent.org/phils-list/place-ad/" data-wpel-link="internal">Place Classified Ad</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617392"><a href="https://highlandscurrent.org/public-notices/" data-wpel-link="internal">Public Notices</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617426"><a href="https://highlandscurrent.org/advertise/adpay/" data-wpel-link="internal">Pay for Your Ad</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-179247"><a href="https://highlandscurrent.org/membership/" class="dropdown-toggle" data-wpel-link="internal">Support Our Work <b class="caret"></b></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537662"><a href="https://highlandscurrent.org/membership/" data-wpel-link="internal">Become a member</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3123099"><a href="https://highlandscurrent.org/membership/renewal/" data-wpel-link="internal">Renew your membership</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3123095"><a href="https://highlandscurrent.org/membership/gift-membership/" data-wpel-link="internal">Give a gift membership</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3123118"><a href="https://highlandscurrent.org/membership/donate/" data-wpel-link="internal">Make a special donation</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617738"><a href="https://highlandscurrent.org/membership/update-your-member-information/" data-wpel-link="internal">Update your information</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4741458"><a href="https://highlandscurrent.org/members-list/" data-wpel-link="internal">Member List</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children dropdown menu-item-4800863"><a href="https://highlandscurrent.org" class="dropdown-toggle" data-wpel-link="internal">Resources <b class="caret"></b></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4800866"><a href="https://highlandscurrent.org/philipstown-calendar/" data-wpel-link="internal">Community Calendar</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4800888"><a href="https://highlandscurrent.org/covid-testing-vaccines-putnam-dutchess/" data-wpel-link="internal">COVID Testing &#038; Vaccines</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4800864"><a href="https://highlandscurrent.org/storms-weather-updates-cold-spring-beacon/" data-wpel-link="internal">Storm Updates</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-105563"><a href="https://highlandscurrent.org/business-directory/" data-wpel-link="internal">Business Directory <i class="icon-arrow-right"></i></a>
<ul class="dropdown-menu sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4800877"><a href="https://highlandscurrent.org/shop-local-online/" data-wpel-link="internal">Shop Local, Online</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-4800865"><a href="https://highlandscurrent.org/local-officials/" data-wpel-link="internal">Local Officials <i class="icon-arrow-right"></i></a>
<ul class="dropdown-menu sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4800868"><a href="https://highlandscurrent.org/meeting-videos/" data-wpel-link="internal">Meeting Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-127714"><a href="https://highlandscurrent.org/help-wanted-cold-spring-garrison-new-york-jobs/" data-wpel-link="internal">Job Search <i class="icon-arrow-right"></i></a>
<ul class="dropdown-menu sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127719"><a href="https://highlandscurrent.org/beacon-jobs-employment-help-wanted/" data-wpel-link="internal">Beacon</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127715"><a href="https://highlandscurrent.org/help-wanted-cold-spring-garrison-new-york-jobs/" data-wpel-link="internal">Philipstown</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4800867"><a href="https://highlandscurrent.org/putnam-county-new-york-real-estate-data/" data-wpel-link="internal">Real Estate Data</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children dropdown menu-item-328205"><a href="https://highlandscurrent.org" class="dropdown-toggle" data-wpel-link="internal">Reader Guide <b class="caret"></b></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88586"><a href="https://highlandscurrent.org/contact/" data-wpel-link="internal">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88585"><a href="https://highlandscurrent.org/about/" data-wpel-link="internal">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537674"><a href="https://highlandscurrent.org/editorial-standards/" data-wpel-link="internal">Editorial Standards</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4851780"><a href="https://highlandscurrent.org/podcast/" data-wpel-link="internal">Podcast</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-328206"><a href="https://highlandscurrent.org/archives/" data-wpel-link="internal">Back Issues</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537666"><a href="https://highlandscurrent.org/newsletter/" data-wpel-link="internal">Free Newsletter</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537672"><a href="https://highlandscurrent.org/delivery/" data-wpel-link="internal">Mail Delivery</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537669"><a href="https://highlandscurrent.org/pick-paper/" data-wpel-link="internal">Where to Find Paper</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4822435"><a href="https://highlandscurrent.org/student-journalists-program/" data-wpel-link="internal">Student Journalists</a></li>
</ul>
</li>
</ul>
</div>
</div>
</div>
</nav>
<div id="main" class="row-fluid clearfix">
<div id="content" class="span8" role="main">
<article id="post-4910512" class="hnews item post-4910512 post type-post status-publish format-standard has-post-thumbnail hentry category-obituaries type-of-work-news type-of-work-obituary featured-media featured-media-image" itemscope itemtype="https://schema.org/Article">
<header>
<h1 class="entry-title" itemprop="headline">Beacon Obituaries</h1>
<h5 class="byline"><img src="https://highlandscurrent.org/wp-content/uploads/2021/05/HC-circle-500-1-60x60.png" alt="Staff" width="32" height="32" class="avatar avatar-32 photo" /> <span class="by-author"><span class="by">By</span> <span class="author vcard" itemprop="author"><a class="url fn n" href="https://highlandscurrent.org/author/site-editor/" title="More from Staff" rel="author" data-wpel-link="internal">Staff</a></span></span><span class="sep"> |</span> <time class="entry-date updated dtstamp pubdate" datetime="2022-05-01T22:26:31-04:00"><span class="time-ago">6 hours ago</span></time></h5>
<meta itemprop="description" content="Betty Baldwin, Israel Beltran Sr., Gloria Marchie
" />
<meta itemprop="datePublished" content="2022-05-01T22:26:31-04:00" />
<meta itemprop="dateModified" content="2022-05-01T22:26:31-04:00" />
<meta itemprop="image" content="https://highlandscurrent.org/wp-content/uploads/2021/10/candles-140x140.jpg" />
</header>
<div class="entry-content clearfix" itemprop="articleBody">
<div id="attachment_4910518" class="wp-caption module image alignright" style="max-width: 150px;"><img class=" wp-image-4910518" src="https://highlandscurrent.org/wp-content/uploads/2022/05/Elizabeth-Baldwin.png" alt="Betty Baldwin" width="150" height="150" srcset="https://highlandscurrent.org/wp-content/uploads/2022/05/Elizabeth-Baldwin.png 200w, https://highlandscurrent.org/wp-content/uploads/2022/05/Elizabeth-Baldwin-140x140.png 140w, https://highlandscurrent.org/wp-content/uploads/2022/05/Elizabeth-Baldwin-60x60.png 60w, https://highlandscurrent.org/wp-content/uploads/2022/05/Elizabeth-Baldwin-96x96.png 96w, https://highlandscurrent.org/wp-content/uploads/2022/05/Elizabeth-Baldwin-150x150.png 150w, https://highlandscurrent.org/wp-content/uploads/2022/05/Elizabeth-Baldwin-125x125.png 125w" sizes="(max-width: 150px) 100vw, 150px" /></a><p class="wp-caption-text">Betty Baldwin</p></div>
<p style="text-align: justify;"><strong>Betty Baldwin (1955-2022)</strong></p>
<p style="text-align: justify;">Elizabeth “Betty” Baldwin, 66, died April 23.</p>
<p style="text-align: justify;">She was born Oct. 3, 1955, in Brooklyn, the daughter of Harry and Muriel (Noonon) Koslow. Her husband, Russell Baldwin, died before her.</p>
<p style="text-align: justify;">Betty loved to crochet and play bingo. She enjoyed reading and doing arts and crafts with her grandchildren, but most of all she loved to spend time with her family. She had a kind spirit who loved to do for others, her family said.</p>
<p style="text-align: justify;">She is survived by her siblings: Patricia Brown (John Rich) and Larry Koslow; her children: Tonya Baldwin (Peter), Georgia Baldwin, Sabrina Turner (James) and Allen Baldwin (Desiree); her grandchildren, James Turner and Gage, Lily and Summerlin Baldwin; and her nieces, Tabitha Brown and Latisha Salgado (Rolando).</p>
<p style="text-align: justify;">A memorial service was held on April 26 at Brooks Funeral Home in Newburgh.</p>
<div id="attachment_4910517" class="wp-caption module image alignright" style="max-width: 148px;"><img loading="lazy" class=" wp-image-4910517" src="https://highlandscurrent.org/wp-content/uploads/2022/05/Israel-Beltran-Sr..jpg" alt="Israel Beltran Sr." width="148" height="190" srcset="https://highlandscurrent.org/wp-content/uploads/2022/05/Israel-Beltran-Sr..jpg 390w, https://highlandscurrent.org/wp-content/uploads/2022/05/Israel-Beltran-Sr.-336x431.jpg 336w, https://highlandscurrent.org/wp-content/uploads/2022/05/Israel-Beltran-Sr.-150x192.jpg 150w, https://highlandscurrent.org/wp-content/uploads/2022/05/Israel-Beltran-Sr.-374x480.jpg 374w" sizes="(max-width: 148px) 100vw, 148px" /></a><p class="wp-caption-text">Israel Beltran Sr.</p></div>
<p style="text-align: justify;"><strong>Israel Beltran Sr. (1955-2022)</strong></p>
<p style="text-align: justify;">Israel Beltran Sr., 67, a longtime resident of Beacon, died April 23 at Vassar Brothers Medical Center in Poughkeepsie.</p>
<p style="text-align: justify;">He was born on April 15, 1955, in Añasco, Puerto Rico, the son of Petra Ingles and Claudio Beltran. Israel had worked as a custodian for the Beacon City School District. He and his wife, Maria Rivas, were married for more than 40 years.</p>
<p style="text-align: justify;">In addition to his wife, Israel is survived by his children: Israel Beltran Jr. (Tanya Castro) and Jackie Beltran; his grandchildren: Joel, Tina Marie, Tiana, Tai and Trinity; his sisters, Gladys, Miriam, Maria and Nelida Beltran; his brothers, Manuel, Edwin, Tony, Claudio Jr. and Freddy Beltran (Carmen) and his nieces and nephews.</p>
<p style="text-align: justify;">A Mass of Christian Burial was held on April 27 at St. John the Evangelist Church in Beacon, followed by interment at St. Joachim Cemetery.</p>
<div id="attachment_4910516" class="wp-caption module image alignright" style="max-width: 155px;"><img loading="lazy" class=" wp-image-4910516" src="https://highlandscurrent.org/wp-content/uploads/2022/05/Gloria-Marchie.jpg" alt="Gloria Marchie" width="155" height="170" srcset="https://highlandscurrent.org/wp-content/uploads/2022/05/Gloria-Marchie.jpg 191w, https://highlandscurrent.org/wp-content/uploads/2022/05/Gloria-Marchie-150x165.jpg 150w" sizes="(max-width: 155px) 100vw, 155px" /></a><p class="wp-caption-text">Gloria Marchie</p></div>
<p style="text-align: justify;"><strong>Gloria Marchie (1930-2022)</strong></p>
<p style="text-align: justify;">Gloria J. Marchie, 91, a longtime resident of Beacon, died at her home on April 21.</p>
<p style="text-align: justify;">She was born on Dec. 31, 1930, in New York City, the daughter of John Phillips and Marie Mossa. Before she stopped working to raise her children and grandchildren, Gloria was a manager at Lloyd’s Department Store in Newburgh. On Feb. 7, 1981, she married William Marchie.</p>
<p style="text-align: justify;">Gloria was a parishioner of St. Joachim-St. John the Evangelist Church and a former member of Poughkeepsie Moose Lodge 904. She loved to sing and dance and regularly attended dinner events with her friends. Gloria was an avid baker who always created beautiful cakes for her family and friend’s special events. She was known for her kindness, compassion and loving spirit, her family said.</p>
<p style="text-align: justify;">In addition to her husband, Gloria is survived by her children, Marianna Dunderdale (Thomas) and John Casale (Barbara); her grandchildren, Maria, Lisa (Tim), Nicole (Justin), Marissa (Daniel) and Kara (Jake); and her great-grandchildren, Johnny, Alyssa, Nicholas, Joseph, Matthew, Saviana, Maximus and Marco. Her former husband, John Casale, died before her.</p>
<p style="text-align: justify;">A Mass of Christian Burial was held April 25 at St. Joachim Church in Beacon, followed by interment at St. Joachim Cemetery. Memorial donations may be made to the Alzheimer’s Association (<a href="https://alz.org" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span>alz.org</a>).</p>
<p><em>Information provided by local funeral homes</em></p>
<div class='heateorSssClear'></div><div class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' data-heateor-sss-href='https://highlandscurrent.org/2022/05/01/beacon-obituaries-288/'><div class='heateor_sss_sharing_title' style="font-weight:bold"></div><div class="heateor_sss_sharing_ul"><a class="heateor_sss_facebook wpel-icon-left" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fhighlandscurrent.org%2F2022%2F05%2F01%2Fbeacon-obituaries-288%2F" title="Facebook" rel="nofollow noopener external" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle" data-wpel-link="external"><span class="wpel-icon wpel-image wpel-icon-6"></span><span class="heateor_sss_svg" style="background-color:#3c589a;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_instagram wpel-icon-left" href="https://www.instagram.com/highlandscurrent" title="Instagram" rel="nofollow noopener external" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle" data-wpel-link="external"><span class="wpel-icon wpel-image wpel-icon-6"></span><span class="heateor_sss_svg" style="background-color:#53beee;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" version="1.1" viewBox="-10 -10 148 148" width="100%" height="100%" xml:space="preserve" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g><g><path d="M86,112H42c-14.336,0-26-11.663-26-26V42c0-14.337,11.664-26,26-26h44c14.337,0,26,11.663,26,26v44 C112,100.337,100.337,112,86,112z M42,24c-9.925,0-18,8.074-18,18v44c0,9.925,8.075,18,18,18h44c9.926,0,18-8.075,18-18V42 c0-9.926-8.074-18-18-18H42z" fill="#fff"></path></g><g><path d="M64,88c-13.234,0-24-10.767-24-24c0-13.234,10.766-24,24-24s24,10.766,24,24C88,77.233,77.234,88,64,88z M64,48c-8.822,0-16,7.178-16,16s7.178,16,16,16c8.822,0,16-7.178,16-16S72.822,48,64,48z" fill="#fff"></path></g><g><circle cx="89.5" cy="38.5" fill="#fff" r="5.5"></circle></g></g></svg></span></a><a class="heateor_sss_button_twitter wpel-icon-left" href="https://twitter.com/intent/tweet?via=highlandcurrent&amp;text=Beacon%20Obituaries&amp;url=https%3A%2F%2Fhighlandscurrent.org%2F2022%2F05%2F01%2Fbeacon-obituaries-288%2F" title="Twitter" rel="nofollow noopener external" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle" data-wpel-link="external"><span class="wpel-icon wpel-image wpel-icon-6"></span><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_twitter" style="background-color:#55acee;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a></div><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div> </div>
<footer class="post-meta bottom-meta">
</footer>
</article>
<div class="article-bottom nocontent"><aside id="text-97" class="widget widget-1 odd default widget_text clearfix"> <div class="textwidget"><hr>
</div>
</aside><aside id="largo-author-widget-2" class="widget widget-2 even default largo-author clearfix">
<div class="author-box row-fluid author vcard clearfix">
<h3 class="widgettitle">About <span class="fn n"><a class="url" href="https://highlandscurrent.org/author/site-editor/" rel="author" title="See all posts by Staff" data-wpel-link="internal">Staff</a></span></h3><div class="photo"><img src="https://highlandscurrent.org/wp-content/uploads/2021/05/HC-circle-500-1-96x96.png" alt="Staff" width="96" height="96" class="avatar avatar-96 photo" /></div><p>Articles attributed to &quot;staff&quot; are written by the editor or a senior editor. This is typically because they are brief items based on a single source, such as a press release, or there are multiple contributors, such as a collection of photos.</p> <ul class="social-links">
<li class="email">
<a class="email" href="/cdn-cgi/l/email-protection#0a7e6f69624a62636d62666b646e79697f78786f647e2465786d" title="e-mail Staff"><i class="icon-mail"></i></a>
</li>
<li class="author-posts-link"><a class="url" href="https://highlandscurrent.org/author/site-editor/" rel="author" title="See all posts by Staff" data-wpel-link="internal">More by Staff</a></li></ul>
</div>
</aside><aside id="text-98" class="widget widget-3 odd default widget_text clearfix"> <div class="textwidget"><hr>
</div>
</aside><aside id="custom_html-34" class="widget_text widget widget-4 even default widget_custom_html clearfix"><div class="textwidget custom-html-widget"><img src="https://highlandscurrent.org/wp-content/uploads/2020/09/trust-mark.png" align="right" alt="Trust Mark" /><font size="+1"><b>HOW WE REPORT</b></font><br><i>The Current</i> is a member of <a href="https://thetrustproject.org" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span>The Trust Project</a>, a consortium of news outlets that has adopted standards to allow readers to more easily assess the credibility of their journalism. Our best practices, including our verification and correction policies, <a href="https://highlandscurrent.org/editorial-standards/" data-wpel-link="internal">can be accessed here</a>. Have a comment? A news tip? Spot an error? Email <a href="/cdn-cgi/l/email-protection#30555459445f4270585957585c515e544353454242555e441e5f4257"><span class="__cf_email__" data-cfemail="4227262b362d30022a2b252a2e232c263121373030272c366c2d3025">[email&#160;protected]</span></a>.</div></aside><aside id="text-88" class="widget widget-5 odd default widget_text clearfix"> <div class="textwidget"><hr />
</div>
</aside><aside id="trust_indicators_article-5" class="widget widget-6 even default trust_indicators_article clearfix"><h3 class="widgettitle">Behind The Story</h3><p><strong>Type</strong>: News, Obituary</p><p>News: Based on facts, either observed and verified directly by the reporter, or reported and verified from knowledgeable sources.</p>
<p>Obituary: Reports the death of an individual, providing an account of the person’s life including their achievements, any controversies in which they were involved, and reminiscences by people who knew them.</p>
</aside></div> <div id="comments" class="clearfix">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/05/01/beacon-obituaries-288/#respond" style="display:none;" data-wpel-link="internal">Cancel reply</a></small></h3><form action="https://highlandscurrent.org/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment_notes">The Current welcomes comments on its coverage and local issues. All online comments are moderated, must include your full name and may appear in print. <a href="https://highlandscurrent.org/editorial-standards/actionable-feedback-letters-comments/" data-wpel-link="internal">See our guidelines here.</a></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" required="required" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<input type="hidden" name="_mc4wp_subscribe_wp-comment-form" value="0" /><p class=" mc4wp-checkbox mc4wp-checkbox-wp-comment-form"><label><input type="checkbox" name="_mc4wp_subscribe_wp-comment-form" value="1" /><span> Sign me up for news updates</span></label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='4910512' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><input type="hidden" id="ct_checkjs_eba0dc302bcd9a273f8bbb72be3a687b" name="ct_checkjs" value="0" /><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">setTimeout(function(){var ct_input_name = "ct_checkjs_eba0dc302bcd9a273f8bbb72be3a687b";if (document.getElementById(ct_input_name) !== null) {var ct_input_value = document.getElementById(ct_input_name).value;document.getElementById(ct_input_name).value = document.getElementById(ct_input_name).value.replace(ct_input_value, '1361632994');}}, 1000);</script></form> </div>
</div>
</div>
<aside id="sidebar" class="span4 nocontent">
<div class="widget-area" role="complementary">
<aside id="wpp-2" class="widget widget-1 odd default popular-posts clearfix">
<h3 class="widgettitle">Trending Right Now</h3>
<ul class="wpp-list wpp-list-with-thumbnails">
<li>
<a href="https://highlandscurrent.org/2022/04/29/mouths-to-feed-home-made/" target="_self" data-wpel-link="internal"><img width="60" height="60" src="https://highlandscurrent.org/wp-content/uploads/2022/04/IMG_9861-60x60.jpg" class="wpp-thumbnail wpp_featured attachment-60x60 size-60x60 wp-post-image" alt="Pasta with Asparagus and Salmon ‘Carbonara’" loading="lazy" srcset="https://highlandscurrent.org/wp-content/uploads/2022/04/IMG_9861-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2022/04/IMG_9861-336x340.jpg 336w, https://highlandscurrent.org/wp-content/uploads/2022/04/IMG_9861-771x780.jpg 771w, https://highlandscurrent.org/wp-content/uploads/2022/04/IMG_9861-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2022/04/IMG_9861-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2022/04/IMG_9861-150x152.jpg 150w, https://highlandscurrent.org/wp-content/uploads/2022/04/IMG_9861-494x500.jpg 494w, https://highlandscurrent.org/wp-content/uploads/2022/04/IMG_9861-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2022/04/IMG_9861-200x200.jpg 200w, https://highlandscurrent.org/wp-content/uploads/2022/04/IMG_9861-474x480.jpg 474w, https://highlandscurrent.org/wp-content/uploads/2022/04/IMG_9861.jpg 1000w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<a href="https://highlandscurrent.org/2022/04/29/mouths-to-feed-home-made/" class="wpp-post-title" target="_self" data-wpel-link="internal">Mouths to Feed: Home Made</a>
<span class="wpp-meta post-stats"><span class="wpp-author">by <a href="https://highlandscurrent.org/author/cbarbour/" data-wpel-link="internal">Celia Barbour</a></span> | <span class="wpp-date">posted on April 29, 2022</span></span>
</li>
<li>
<a href="https://highlandscurrent.org/2022/04/29/court-strikes-down-democrats-maps/" target="_self" data-wpel-link="internal"><img width="60" height="60" src="https://highlandscurrent.org/wp-content/uploads/2022/04/Screen-Shot-2022-04-29-at-12.52.55-AM-60x60.jpg" class="wpp-thumbnail wpp_featured attachment-60x60 size-60x60 wp-post-image" alt="New Map D 41" loading="lazy" srcset="https://highlandscurrent.org/wp-content/uploads/2022/04/Screen-Shot-2022-04-29-at-12.52.55-AM-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2022/04/Screen-Shot-2022-04-29-at-12.52.55-AM-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2022/04/Screen-Shot-2022-04-29-at-12.52.55-AM-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2022/04/Screen-Shot-2022-04-29-at-12.52.55-AM-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2022/04/Screen-Shot-2022-04-29-at-12.52.55-AM-200x200.jpg 200w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<a href="https://highlandscurrent.org/2022/04/29/court-strikes-down-democrats-maps/" class="wpp-post-title" target="_self" data-wpel-link="internal">Court Strikes Down Democrats’ Maps</a>
<span class="wpp-meta post-stats"><span class="wpp-author">by <a href="https://highlandscurrent.org/author/lsparks/" data-wpel-link="internal">Leonard Sparks</a></span> | <span class="wpp-date">posted on April 29, 2022</span></span>
</li>
<li>
<a href="https://highlandscurrent.org/2022/05/01/current-named-newspaper-of-year/" target="_self" data-wpel-link="internal"><img width="60" height="45" src="https://highlandscurrent.org/wp-content/uploads/2019/04/nypalogo.png" class="wpp-thumbnail wpp_featured attachment-60x60 size-60x60 wp-post-image" alt="" loading="lazy" srcset="https://highlandscurrent.org/wp-content/uploads/2019/04/nypalogo.png 337w, https://highlandscurrent.org/wp-content/uploads/2019/04/nypalogo-300x223.png 300w, https://highlandscurrent.org/wp-content/uploads/2019/04/nypalogo-119x89.png 119w, https://highlandscurrent.org/wp-content/uploads/2019/04/nypalogo-124x90.png 124w, https://highlandscurrent.org/wp-content/uploads/2019/04/nypalogo-150x111.png 150w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<a href="https://highlandscurrent.org/2022/05/01/current-named-newspaper-of-year/" class="wpp-post-title" target="_self" data-wpel-link="internal">Current Named Newspaper of Year</a>
<span class="wpp-meta post-stats"><span class="wpp-author">by <a href="https://highlandscurrent.org/author/site-editor/" data-wpel-link="internal">Staff</a></span> | <span class="wpp-date">posted on May 1, 2022</span></span>
</li>
<li>
<a href="https://highlandscurrent.org/2022/04/26/putnam-chair-could-lose-republican-line/" target="_self" data-wpel-link="internal"><img width="60" height="60" src="https://highlandscurrent.org/wp-content/uploads/2022/04/sullivan-60x60.png" class="wpp-thumbnail wpp_featured attachment-60x60 size-60x60 wp-post-image" alt="Neal Sullivan" loading="lazy" srcset="https://highlandscurrent.org/wp-content/uploads/2022/04/sullivan-60x60.png 60w, https://highlandscurrent.org/wp-content/uploads/2022/04/sullivan-140x140.png 140w, https://highlandscurrent.org/wp-content/uploads/2022/04/sullivan-96x96.png 96w, https://highlandscurrent.org/wp-content/uploads/2022/04/sullivan-125x125.png 125w, https://highlandscurrent.org/wp-content/uploads/2022/04/sullivan-200x200.png 200w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<a href="https://highlandscurrent.org/2022/04/26/putnam-chair-could-lose-republican-line/" class="wpp-post-title" target="_self" data-wpel-link="internal">Putnam Chair Could Lose Republican Line</a>
<span class="wpp-meta post-stats"><span class="wpp-author">by <a href="https://highlandscurrent.org/author/crowe/" data-wpel-link="internal">Chip Rowe</a></span> | <span class="wpp-date">posted on April 26, 2022</span></span>
</li>
<li>
<a href="https://highlandscurrent.org/2022/04/29/varsity-roundup-48/" target="_self" data-wpel-link="internal"><img width="60" height="60" src="https://highlandscurrent.org/wp-content/uploads/2022/04/DSC_1107-60x60.jpg" class="wpp-thumbnail wpp_featured attachment-60x60 size-60x60 wp-post-image" alt="Thomas Tucker" loading="lazy" srcset="https://highlandscurrent.org/wp-content/uploads/2022/04/DSC_1107-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2022/04/DSC_1107-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2022/04/DSC_1107-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2022/04/DSC_1107-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2022/04/DSC_1107-200x200.jpg 200w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<a href="https://highlandscurrent.org/2022/04/29/varsity-roundup-48/" class="wpp-post-title" target="_self" data-wpel-link="internal">Varsity Roundup</a>
<span class="wpp-meta post-stats"><span class="wpp-author">by <a href="https://highlandscurrent.org/author/spearlman/" data-wpel-link="internal">Skip Pearlman</a></span> | <span class="wpp-date">posted on April 29, 2022</span></span>
</li>
</ul>
</aside>
<aside id="text-73" class="widget widget-2 even default widget_text clearfix"> <div class="textwidget"><hr />
</div>
</aside><aside id="largo-about-widget-3" class="widget widget-3 odd default largo-about clearfix"><h3 class="widgettitle"><a href="https://highlandcurrent.org/membership" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span>About The Current</a></h3><p><a href="https://highlandscurrent.org/membership" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2019/12/join-us-200.jpg" alt="Join Now!" align="right" height="75" width="75"></a>We are a <a href="https://highlandscurrent.org/membership/" data-wpel-link="internal">member-supported</a>, nonprofit media organization that serves the communities of Philipstown (Cold Spring, Nelsonville and Garrison) and Beacon, New York, in the Hudson Highlands. <a href="https://highlandscurrent.org/membership" data-wpel-link="internal">Click here to support our journalism</a>.<hr></p></aside><aside id="ai_widget-7" class="widget widget-4 even default ai_widget clearfix"><div class='code-block code-block-3 ai-track' data-ai='WzMsIiIsIjMwMHgyNTAgVG9wIiwiIiwxXQ==' style='margin: 8px 0; clear: both;'>
<style>
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-filter-check, .ai-fallback, .ai-list-block, .ai-list-block-ip, .ai-list-block-filter {visibility: hidden; position: absolute; width: 50%; height: 1px; top: -1000px; z-index: -9999; margin: 0px!important;}
.ai-list-data, .ai-ip-data, .ai-filter-check, .ai-fallback {min-width: 1px;}
</style>
<div class='ai-rotate ai-unprocessed ai-3-1' data-info='WyIzLTEiLDdd' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="QQ==" data-time="MTA=">
<a href="https://www.southerndutchesseye.com" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2022/04/HighlandsCurrentWebButtonAd_April2022.png" alt="Southern Dutchess Eye Care"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qg==" data-time="MTA=">
<a href="https://carlin-felder.weichert.com/sell.php" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2022/03/carlin-felder-300.png" alt="Carlin Felder"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qw==" data-time="MTA=">
<a href="https://new.mta.info/schedules/metro-north-railroad" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2022/04/MTA-MNR-Express_300x250px_p6.png" alt="Metro-North"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="RA==" data-time="MTA=">
<a href="https://www.highlandschapel.org/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2022/04/choral-society-300.jpg" alt="Choral Society"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="RQ==" data-time="MTA=">
<a href="https://www.hvhospice.org/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2022/05/Highlands-Current-Banner-May-2022-Golf.jpg" alt="HV Hospice"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Rg==" data-time="MTA=">
<a href="https://highlandscurrent.org/wp-content/uploads/2022/04/real-cost-of-policing.pdf" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2022/04/policing-letter-ad.png" alt="Police letter"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Rw==" data-time="MTA=">
<a href="https://jaymarkjewelers.com" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2022/05/jaymark300.png" alt="Jaymark Jewelers"></a></div>
</div>
</div>
</aside><aside id="custom_html-37" class="widget_text widget widget-5 odd default widget_custom_html clearfix"><div class="textwidget custom-html-widget">See your ad here. <a href="https://highlandscurrent.org/advertise/" data-wpel-link="internal">Click for details.</a></div></aside><aside id="text-76" class="widget widget-6 even default widget_text clearfix"> <div class="textwidget"><hr />
</div>
</aside><aside id="custom_html-42" class="widget_text widget widget-7 odd default widget_custom_html clearfix"><h3 class="widgettitle"><a href="https://highlandscurrent.org/podcast" data-wpel-link="internal">Hear Latest Podcast</a></h3><div class="textwidget custom-html-widget"><iframe title="The Highlands Current Podcast" allowtransparency="true" height="315" width="100%" style="border: none; min-width: min(100%, 430px);" scrolling="no" data-name="pb-iframe-player" src="https://www.podbean.com/player-v2/?i=exadx-ce4505-pbblog-playlist&share=1&download=1&rtl=0&fonts=Arial&skin=1&font-color=&order=episodic&limit=5&filter=all&ss=bcd3b6878f94d235528ab1ba3e3d596d&btn-skin=7&size=315" allowfullscreen=""></iframe>
Subscribe at these services:
<div id="podcast-subscribe-button-4825281" class="secondline-psb-radius-style secondline-psb-alignment-none">
<div class="secondline-psb-subscribe-icons"><span class="secondline-psb-subscribe-Amazon-Music"><a title="Amazon-Music" onMouseOver="this.style.color=`#ffffff`; this.style.backgroundColor=`#2a2a2a`" onMouseOut="this.style.color=`#ffffff`; this.style.backgroundColor=`#1e73be`" style="color:#ffffff; background-color:#1e73be" class="button podcast-subscribe-button" href="https://music.amazon.com/podcasts/53535f87-9966-490b-9854-c7a3f829c93a/the-highlands-current-podcast" target="_blank" rel="noopener external" data-wpel-link="external"><img class="secondline-psb-subscribe-img" src="https://highlandscurrent.org/wp-content/plugins/podcast-subscribe-buttons/assets/img/icons/Amazon-Music.svg" alt="Amazon Music" /></a></span><span class="secondline-psb-subscribe-Apple-Podcasts"><a title="Apple-Podcasts" onMouseOver="this.style.color=`#ffffff`; this.style.backgroundColor=`#2a2a2a`" onMouseOut="this.style.color=`#ffffff`; this.style.backgroundColor=`#1e73be`" style="color:#ffffff; background-color:#1e73be" class="button podcast-subscribe-button" href="https://podcasts.apple.com/us/podcast/the-highlands-current-podcast/id1608262107" target="_blank" rel="noopener external" data-wpel-link="external"><img class="secondline-psb-subscribe-img" src="https://highlandscurrent.org/wp-content/plugins/podcast-subscribe-buttons/assets/img/icons/Apple-Podcasts.svg" alt="Apple Podcasts" /></a></span><span class="secondline-psb-subscribe-Google-Podcasts"><a title="Google-Podcasts" onMouseOver="this.style.color=`#ffffff`; this.style.backgroundColor=`#2a2a2a`" onMouseOut="this.style.color=`#ffffff`; this.style.backgroundColor=`#1e73be`" style="color:#ffffff; background-color:#1e73be" class="button podcast-subscribe-button" href="https://podcasts.google.com/feed/aHR0cHM6Ly9mZWVkLnBvZGJlYW4uY29tL2hpZ2hsYW5kc2N1cnJlbnQvZmVlZC54bWw?sa=X&#038;ved=0CAMQ4aUDahcKEwjwi7za-ff1AhUAAAAAHQAAAAAQNQ" target="_blank" rel="noopener external" data-wpel-link="external"><img class="secondline-psb-subscribe-img" src="https://highlandscurrent.org/wp-content/plugins/podcast-subscribe-buttons/assets/img/icons/Google-Podcasts.png" alt="Google Podcasts" /></a></span><span class="secondline-psb-subscribe-Spotify"><a title="Spotify" onMouseOver="this.style.color=`#ffffff`; this.style.backgroundColor=`#2a2a2a`" onMouseOut="this.style.color=`#ffffff`; this.style.backgroundColor=`#1e73be`" style="color:#ffffff; background-color:#1e73be" class="button podcast-subscribe-button" href="https://open.spotify.com/show/3c0p47FRyPPIhp5vyVPZlB" target="_blank" rel="noopener external" data-wpel-link="external"><img class="secondline-psb-subscribe-img" src="https://highlandscurrent.org/wp-content/plugins/podcast-subscribe-buttons/assets/img/icons/Spotify.svg" alt="Spotify" /></a></span><span class="secondline-psb-subscribe-Stitcher"><a title="Stitcher" onMouseOver="this.style.color=`#ffffff`; this.style.backgroundColor=`#2a2a2a`" onMouseOut="this.style.color=`#ffffff`; this.style.backgroundColor=`#1e73be`" style="color:#ffffff; background-color:#1e73be" class="button podcast-subscribe-button" href="https://www.stitcher.com/show/the-highlands-current-podcast" target="_blank" rel="noopener external" data-wpel-link="external"><img class="secondline-psb-subscribe-img" src="https://highlandscurrent.org/wp-content/plugins/podcast-subscribe-buttons/assets/img/icons/Stitcher.svg" alt="Stitcher" /></a></span></div>
</div></div></aside><aside id="text-103" class="widget widget-8 even default widget_text clearfix"> <div class="textwidget"><hr>
</div>
</aside><aside id="featured_ads_widget-3" class="widget widget-9 odd default widget_featured_ads_widget clearfix"><h3 class="widgettitle">Featured Classifieds</h3><ul class="awpcp-listings-widget-items-list"><li class="awpcp-listings-widget-item awpcp-listings-widget-item-with-thumbnail-above-in-desktop awpcp-listings-widget-item-with-thumbnail-above-in-mobile featured_ad_item awpcp-listings-widget-item-without-thumbnail"><div class="awpcplatestbox awpcp-clearfix"><div class="awpcp-listings-widget-item--title-and-content"><div class="awpcp-listing-title"><a href="https://highlandscurrent.org/phils-list/show-ad/4211308/healing-bodywork-with-vaccinated-joy-matalon/services/" data-wpel-link="internal">Healing Bodywork with Vaccinated Joy Matalon</a></div> <div class="awpcp-listings-widget-item-excerpt">Featured in New York magazine as "one of the best 15 massage therapists in NYC&hellip;</div></div><p class="awpcp-widget-read-more-container"><a class="awpcp-widget-read-more" href="https://highlandscurrent.org/phils-list/show-ad/4211308/healing-bodywork-with-vaccinated-joy-matalon/services/" data-wpel-link="internal">[Read more]</a></p></div></li>
<li class="awpcp-listings-widget-item awpcp-listings-widget-item-with-thumbnail-above-in-desktop awpcp-listings-widget-item-with-thumbnail-above-in-mobile featured_ad_item awpcp-listings-widget-item-without-thumbnail"><div class="awpcplatestbox awpcp-clearfix"><div class="awpcp-listings-widget-item--title-and-content"><div class="awpcp-listing-title"><a href="https://highlandscurrent.org/phils-list/show-ad/4890106/wanted-pick-pack-warehouse-operators/help-wanted/" data-wpel-link="internal">Wanted: Pick &amp; Pack Warehouse Operators</a></div> <div class="awpcp-listings-widget-item-excerpt">Our local family-owned company is looking for individuals to join warehouse team in full-time or&hellip;</div></div><p class="awpcp-widget-read-more-container"><a class="awpcp-widget-read-more" href="https://highlandscurrent.org/phils-list/show-ad/4890106/wanted-pick-pack-warehouse-operators/help-wanted/" data-wpel-link="internal">[Read more]</a></p></div></li>
<li class="awpcp-listings-widget-item awpcp-listings-widget-item-with-thumbnail-above-in-desktop awpcp-listings-widget-item-with-thumbnail-above-in-mobile featured_ad_item awpcp-listings-widget-item-without-thumbnail"><div class="awpcplatestbox awpcp-clearfix"><div class="awpcp-listings-widget-item--title-and-content"><div class="awpcp-listing-title"><a href="https://highlandscurrent.org/phils-list/show-ad/4852586/virtual-bookkeeping-services-2/services/" data-wpel-link="internal">Virtual Bookkeeping Services</a></div> <div class="awpcp-listings-widget-item-excerpt">Let me ensure that your financial records are accurate and up-to-date, while you concentrate on&hellip;</div></div><p class="awpcp-widget-read-more-container"><a class="awpcp-widget-read-more" href="https://highlandscurrent.org/phils-list/show-ad/4852586/virtual-bookkeeping-services-2/services/" data-wpel-link="internal">[Read more]</a></p></div></li>
<li class="awpcp-listings-widget-item awpcp-listings-widget-item-with-thumbnail-above-in-desktop awpcp-listings-widget-item-with-thumbnail-above-in-mobile featured_ad_item awpcp-listings-widget-item-without-thumbnail"><div class="awpcplatestbox awpcp-clearfix"><div class="awpcp-listings-widget-item--title-and-content"><div class="awpcp-listing-title"><a href="https://highlandscurrent.org/phils-list/show-ad/4852886/beaconhomelistings-com/real-estate-for-sale-rent/" data-wpel-link="internal">BeaconHomeListings.com</a></div> <div class="awpcp-listings-widget-item-excerpt">Beacon’s own, for sale or rent, real-time listings website! To celebrate spring (and more homegrown&hellip;</div></div><p class="awpcp-widget-read-more-container"><a class="awpcp-widget-read-more" href="https://highlandscurrent.org/phils-list/show-ad/4852886/beaconhomelistings-com/real-estate-for-sale-rent/" data-wpel-link="internal">[Read more]</a></p></div></li></ul></aside><aside id="text-48" class="widget widget-10 even default widget_text clearfix"> <div class="textwidget"><p>Tag sale? Car for sale? Space for rent? Help wanted? <a href="https://highlandscurrent.org/phils-list/place-ad/" data-wpel-link="internal">Place your ad here for $4.95</a>.</p>
<hr />
</div>
</aside><aside id="ai_widget-6" class="widget widget-11 odd default ai_widget clearfix"><div class='code-block code-block-4 ai-track' data-ai='WzQsIiIsIjMwMHgyNTAgYm90dG9tIiwiIiwxXQ==' style='margin: 8px 0; clear: both;'>
<style>
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-filter-check, .ai-fallback, .ai-list-block, .ai-list-block-ip, .ai-list-block-filter {visibility: hidden; position: absolute; width: 50%; height: 1px; top: -1000px; z-index: -9999; margin: 0px!important;}
.ai-list-data, .ai-ip-data, .ai-filter-check, .ai-fallback {min-width: 1px;}
</style>
<div class='ai-rotate ai-unprocessed ai-4-1' data-info='WyI0LTEiLDdd' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="QQ==" data-time="MTA=">
<a href="https://www.southerndutchesseye.com" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2022/04/HighlandsCurrentWebButtonAd_April2022.png" alt="Southern Dutchess Eye Care"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qg==" data-time="MTA=">
<a href="https://carlin-felder.weichert.com/sell.php" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2022/03/carlin-felder-300.png" alt="Carlin Felder"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qw==" data-time="MTA=">
<a href="https://new.mta.info/schedules/metro-north-railroad" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2022/04/MTA-MNR-Express_300x250px_p6.png" alt="Metro-North"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="RA==" data-time="MTA=">
<a href="https://www.highlandschapel.org/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2022/04/choral-society-300.jpg" alt="Choral Society"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="RQ==" data-time="MTA=">
<a href="https://www.hvhospice.org/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2022/04/Highlands-Current-Banner-April-2022.jpg" alt="HV Hospice"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Rg==" data-time="MTA=">
<a href="https://highlandscurrent.org/wp-content/uploads/2022/04/real-cost-of-policing.pdf" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2022/04/policing-letter-ad.png" alt="Police letter"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Rw==" data-time="MTA=">
<a href="https://jaymarkjewelers.com" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2022/05/jaymark300.png" alt="Jaymark Jewelers"></a></div>
</div>
</div>
</aside><aside id="custom_html-38" class="widget_text widget widget-12 even default widget_custom_html clearfix"><div class="textwidget custom-html-widget">See your ad here. <a href="https://highlandscurrent.org/advertise/" data-wpel-link="internal">Click for details.</a></div></aside><aside id="text-101" class="widget widget-13 odd default widget_text clearfix"> <div class="textwidget"><hr>
</div>
</aside><aside id="mc4wp_form_widget-12" class="widget widget-14 even default widget_mc4wp_form_widget clearfix"><h3 class="widgettitle">Free Newsletters</h3><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-91454 mc4wp-ajax" method="post" data-id="91454" data-name="Free Newsletter"><div class="mc4wp-form-fields"><p>
<p>
<label>
<input name="INTERESTS[492a248734][]" type="checkbox" value="4819c3c69d" checked="true"> <span>News Updates</span>
</label>
<label>
<input name="INTERESTS[492a248734][]" type="checkbox" value="e4d30e5c43" checked="true"> <span>Weekend Preview</span>
</label>
<label>
<input name="INTERESTS[492a248734][]" type="checkbox" value="82dceafde7" checked="true"> <span>Updates / Events</span>
</label>
</p>
</p>
<input type="text" name="FNAME" placeholder="First name" required><br>
<input type="text" name="LNAME" placeholder="Last name" required><br>
<input type="text" name="ZIP" placeholder="Zip code" required><br>
<input type="email" name="EMAIL" placeholder="Email address" required /><br>
<br>
<input type="submit" value="Sign me up!" /></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1651481541" /><input type="hidden" name="_mc4wp_form_id" value="91454" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></aside><aside id="text-104" class="widget widget-15 odd default widget_text clearfix"> <div class="textwidget"><hr />
</div>
</aside><aside id="heateor_sss_follow-2" class="widget widget-16 even default widget_heateor_sss_follow clearfix"><div class="heateor_sss_standard_follow_icons_container heateor_sss_bottom_follow"><h3 class="widgettitle">Follow Us</h3><div class="heateor_sss_follow_ul"><a class="heateor_sss_facebook wpel-icon-left" href="https://www.facebook.com/highlandscurrent" title="Facebook" rel="nofollow noopener external" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle;" data-wpel-link="external"><span class="wpel-icon wpel-image wpel-icon-6"></span><span style="background-color:#3c589a;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;width:32px;height:32px;border-radius:999px;" class="heateor_sss_svg"><svg focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sss_twitter wpel-icon-left" href="https://twitter.com/highlandcurrent" title="Twitter" rel="nofollow noopener external" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle;" data-wpel-link="external"><span class="wpel-icon wpel-image wpel-icon-6"></span><span style="background-color:#55acee;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;width:32px;height:32px;border-radius:999px;" class="heateor_sss_svg"><svg focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a><a class="heateor_sss_instagram wpel-icon-left" href="https://www.instagram.com/highlandscurrent" title="Instagram" rel="nofollow noopener external" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle;" data-wpel-link="external"><span class="wpel-icon wpel-image wpel-icon-6"></span><span style="background-color:#53beee;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;width:32px;height:32px;border-radius:999px;" class="heateor_sss_svg"><svg height="100%" width="100%" version="1.1" viewBox="-10 -10 148 148" xml:space="preserve" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g><g><path d="M86,112H42c-14.336,0-26-11.663-26-26V42c0-14.337,11.664-26,26-26h44c14.337,0,26,11.663,26,26v44    C112,100.337,100.337,112,86,112z M42,24c-9.925,0-18,8.074-18,18v44c0,9.925,8.075,18,18,18h44c9.926,0,18-8.075,18-18V42    c0-9.926-8.074-18-18-18H42z" fill="#fff"></path></g><g><path d="M64,88c-13.234,0-24-10.767-24-24c0-13.234,10.766-24,24-24s24,10.766,24,24C88,77.233,77.234,88,64,88z M64,48c-8.822,0-16,7.178-16,16s7.178,16,16,16c8.822,0,16-7.178,16-16S72.822,48,64,48z" fill="#fff"></path></g><g><circle cx="89.5" cy="38.5" fill="#fff" r="5.5"></circle></g></g></svg></span></a></div><div style="clear:both"></div></div></aside> </div>
</aside>
</div> 
</div>
<div class="footer-bg clearfix nocontent">
<footer id="site-footer">
<div id="supplementary" class="row-fluid _3col-default">
<div class="span3 widget-area" role="complementary">
<aside id="text-54" class="widget widget-1 odd default widget_text clearfix"><h3 class="widgettitle">Reader Guide</h3> <div class="textwidget"><p><a href="https://highlandscurrent.org/pick-paper/" data-wpel-link="internal">Where to find paper</a><br />
<a href="https://highlandscurrent.org/delivery/" data-wpel-link="internal">Get mail delivery</a><br />
<a href="https://highlandscurrent.org/add-the-current-to-your-phone/" data-wpel-link="internal">Add icon to phone</a><br />
<a href="https://highlandscurrent.org/editorial-standards/" data-wpel-link="internal">Editorial standards</a><br />
<a href="/cdn-cgi/l/email-protection#91f4f5f8e5fee3d1f9f8f6f9fdf0fff5e2f2e4e3e3f4ffe5bffee3f6">Email the editor</a></p>
</div>
</aside></div>
<div class="span6 widget-area" role="complementary">
<aside id="ai_widget-2" class="widget widget-1 odd default ai_widget clearfix"><div class='code-block code-block-1 ai-track' data-ai='WzEsIiIsIkJvdHRvbSBvZiBQYWdlIiwiIiwxXQ==' style='margin: 8px 0; clear: both;'>
<style>
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-filter-check, .ai-fallback, .ai-list-block, .ai-list-block-ip, .ai-list-block-filter {visibility: hidden; position: absolute; width: 50%; height: 1px; top: -1000px; z-index: -9999; margin: 0px!important;}
.ai-list-data, .ai-ip-data, .ai-filter-check, .ai-fallback {min-width: 1px;}
</style>
<div class='ai-rotate ai-unprocessed ai-1-1' data-info='WyIxLTEiLDNd' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="QQ==" data-time="MTA=">
<a href="https://highlandscurrent.org/membership" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2021/01/OnlineHouseLONG-Support_border.jpg" alt="Membership ad"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qg==" data-time="MTA=">
<a href="https://www.jdoqocy.com/q879xdmjdl09217265024AA1861" target="_blank" data-wpel-link="external" rel="external noopener">
<img src="https://www.tqlkg.com/b1110m-3sywHQJIOJNMHJLRRIPNI" alt="Magzter" border="0" /></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qw==" data-time="MTA=">
<a href="https://www.philipstowndemocrats.org" target="_blank" data-wpel-link="external" rel="external noopener">
<img src="https://highlandscurrent.org/wp-content/uploads/2022/05/banner-democrats.png" alt="Magzter" border="0" /></a></div>
</div>
</div>
</aside><aside id="text-81" class="widget widget-2 even default widget_text clearfix"> <div class="textwidget"><hr />
<p><center><em>The Highlands Current</em> is a member of the<br />
New York Press Association<br />
National Newspaper Association<br />
New York News Publishers Association<br />
Local Independent Online News<br />
Institute for Nonprofit News</center></p>
</div>
</aside></div>
<div class="span3 widget-area" role="complementary">
<aside id="text-78" class="widget widget-1 odd default widget_text clearfix"><h3 class="widgettitle">The Highlands Current</h3> <div class="textwidget"><p>142 Main St.<br />
Cold Spring, NY 10516<br />
845-809-5584<br />
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e0858489948f92a0888987888c818e849383959292858e94ce8f9287">[email&#160;protected]</a><br />
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="0160657241696866696d606f657262747373646f752f6e7366">[email&#160;protected]</a><br />
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e98a88858c878d889ba981808e818588878d9a8a9c9b9b8c879dc7869b8e">[email&#160;protected]</a></p>
</div>
</aside></div>
</div>
<div id="boilerplate">
<div class="row-fluid clearfix">
<div class="span6">
<ul id="footer-social" class="social-icons">
<li><a href="https://facebook.com/highlandscurrent" title="Link to Facebook Profile" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/highlandcurrent" title="Link to Twitter Page" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span><i class="icon-twitter"></i></a></li><li><a href="https://instagram.com/highlandscurrent" title="Link to Instagram Page" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span><i class="icon-instagram"></i></a></li><li><a href="https://highlandscurrent.org/feed/" title="Link to RSS Feed" data-wpel-link="internal"><i class="icon-rss"></i></a></li> </ul>
<div class="footer-bottom clearfix">

<p class="footer-credit">&copy; Copyright 2022, Highlands Current Inc.</p>
<ul id="menu-footer-bottom" class="menu"><li id="menu-item-300318" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-300318"><a href="https://highlandscurrent.org/awards/" data-wpel-link="internal">Awards</a></li>
<li id="menu-item-3301089" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3301089"><a href="https://highlandscurrent.org/podcast" data-wpel-link="internal">Audio</a></li>
<li id="menu-item-536422" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-536422"><a href="https://highlandscurrent.org/editorial-standards/" data-wpel-link="internal">Editorial Standards</a></li>
<li id="menu-item-293639" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293639"><a href="https://highlandscurrent.org/archives/" data-wpel-link="internal">Back Issues</a></li>
<li id="menu-item-293641" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293641"><a href="https://highlandscurrent.org/delivery/" data-wpel-link="internal">Delivery</a></li>
<li id="menu-item-318802" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-318802"><a href="https://highlandscurrent.org/privacy" data-wpel-link="internal">Privacy</a></li>
<li id="menu-item-293643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293643"><a href="https://highlandscurrent.org/contact/" data-wpel-link="internal">Contact</a></li>
</ul> </div>
</div>
<div class="span6 right">
<a href="//inn.org/" id="inn-logo-container" data-wpel-link="external" target="_blank" rel="external noopener">
<img id="inn-logo" src="https://highlandscurrent.org/wp-content/themes/largo-0.6.3/img/inn_light.svg" alt="The Highlands Current is a member of the Institute for Nonprofit News" />
</a>
<p class="footer-credit ">Built with the <a href="https://largo.inn.org/" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span>Largo WordPress Theme</a> from the <a href="https://inn.org" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span>Institute for Nonprofit News</a>.</p>
</div>
</div>
<p class="back-to-top visuallyhidden"><a href="#top">Back to top &uarr;</a></p>
</div>
</footer>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
              (function(e){
                  var el = document.createElement('script');
                  el.setAttribute('data-account', '5bVXSNZ6nq');
                  el.setAttribute('src', 'https://cdn.userway.org/widget.js');
                  document.body.appendChild(el);
                })();
              </script><script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script><div id="pum-4882761" class="pum pum-overlay pum-theme-118330 pum-theme-lightbox popmake-overlay pum-overlay-disabled click_open" data-popmake="{&quot;id&quot;:4882761,&quot;slug&quot;:&quot;all-visitors-multiple-pages&quot;,&quot;theme_id&quot;:118330,&quot;cookies&quot;:[{&quot;event&quot;:&quot;on_popup_close&quot;,&quot;settings&quot;:{&quot;name&quot;:&quot;pum-4882761&quot;,&quot;key&quot;:&quot;&quot;,&quot;session&quot;:false,&quot;path&quot;:&quot;1&quot;,&quot;time&quot;:&quot;1 month&quot;}}],&quot;triggers&quot;:[{&quot;type&quot;:&quot;click_open&quot;,&quot;settings&quot;:{&quot;cookie_name&quot;:[&quot;pum-4882761&quot;],&quot;extra_selectors&quot;:&quot;&quot;}}],&quot;mobile_disabled&quot;:null,&quot;tablet_disabled&quot;:null,&quot;meta&quot;:{&quot;display&quot;:{&quot;stackable&quot;:&quot;1&quot;,&quot;overlay_disabled&quot;:&quot;1&quot;,&quot;scrollable_content&quot;:false,&quot;disable_reposition&quot;:false,&quot;size&quot;:&quot;tiny&quot;,&quot;responsive_min_width&quot;:&quot;0%&quot;,&quot;responsive_min_width_unit&quot;:false,&quot;responsive_max_width&quot;:&quot;100%&quot;,&quot;responsive_max_width_unit&quot;:false,&quot;custom_width&quot;:&quot;640px&quot;,&quot;custom_width_unit&quot;:false,&quot;custom_height&quot;:&quot;380px&quot;,&quot;custom_height_unit&quot;:false,&quot;custom_height_auto&quot;:false,&quot;location&quot;:&quot;left bottom&quot;,&quot;position_from_trigger&quot;:false,&quot;position_top&quot;:&quot;100&quot;,&quot;position_left&quot;:&quot;10&quot;,&quot;position_bottom&quot;:&quot;10&quot;,&quot;position_right&quot;:&quot;0&quot;,&quot;position_fixed&quot;:&quot;1&quot;,&quot;animation_type&quot;:&quot;fade&quot;,&quot;animation_speed&quot;:&quot;350&quot;,&quot;animation_origin&quot;:&quot;left bottom&quot;,&quot;overlay_zindex&quot;:false,&quot;zindex&quot;:&quot;1999999999&quot;},&quot;close&quot;:{&quot;text&quot;:&quot;&quot;,&quot;button_delay&quot;:&quot;0&quot;,&quot;overlay_click&quot;:false,&quot;esc_press&quot;:false,&quot;f4_press&quot;:false},&quot;click_open&quot;:[],&quot;convert_on&quot;:&quot;link_click&quot;},&quot;conditions&quot;:[[{&quot;target&quot;:&quot;page_views&quot;,&quot;not_operand&quot;:false,&quot;settings&quot;:{&quot;morethan&quot;:&quot;3&quot;,&quot;lessthan&quot;:&quot;0&quot;},&quot;morethan&quot;:&quot;3&quot;,&quot;lessthan&quot;:&quot;0&quot;}]]}" role="dialog" aria-hidden="true" aria-labelledby="pum_popup_title_4882761">
<div id="popmake-4882761" class="pum-container popmake theme-118330 pum-responsive pum-responsive-tiny responsive size-tiny pum-position-fixed">
<div id="pum_popup_title_4882761" class="pum-title popmake-title">
Thank You for Reading! </div>
<div class="pum-content popmake-content" tabindex="0">
<p style="text-align: left;"><a href="https://highlandscurrent.org/wp-content/uploads/2022/04/brick-wall-tr.jpg" data-wpel-link="internal"><img loading="lazy" class=" wp-image-4872741 alignright" src="https://highlandscurrent.org/wp-content/uploads/2022/04/brick-wall-tr.jpg" alt="brick wall" width="112" height="222" srcset="https://highlandscurrent.org/wp-content/uploads/2022/04/brick-wall-tr.jpg 253w, https://highlandscurrent.org/wp-content/uploads/2022/04/brick-wall-tr-150x296.jpg 150w, https://highlandscurrent.org/wp-content/uploads/2022/04/brick-wall-tr-243x480.jpg 243w" sizes="(max-width: 112px) 100vw, 112px" /></a><span style="font-size: 12pt;">This news site is reader-supported, meaning it is provided free to the Beacon and Philipstown communities because of the support of readers like you who make recurring, <span style="text-decoration: underline;">tax-deductible</span> donations of $5 or $10 per month. If you aren&#8217;t already a member, will you join us?</span></p>
<h5 style="text-align: center;"><a href="https://highlandscurrent.org/membership/join" data-wpel-link="internal">Click here to get started</a><a href="https://highlandscurrent.org/membership/join" data-wpel-link="internal">.</a></h5>
</div>
<button type="button" class="pum-close popmake-close" aria-label="Close">
X </button>
</div>
</div>
<div id="pum-4872669" class="pum pum-overlay pum-theme-118330 pum-theme-lightbox popmake-overlay pum-overlay-disabled click_open" data-popmake="{&quot;id&quot;:4872669,&quot;slug&quot;:&quot;google-facebook-visitors&quot;,&quot;theme_id&quot;:118330,&quot;cookies&quot;:[{&quot;event&quot;:&quot;on_popup_close&quot;,&quot;settings&quot;:{&quot;name&quot;:&quot;pum-4872669&quot;,&quot;key&quot;:&quot;&quot;,&quot;session&quot;:false,&quot;path&quot;:&quot;1&quot;,&quot;time&quot;:&quot;1 month&quot;}}],&quot;triggers&quot;:[{&quot;type&quot;:&quot;click_open&quot;,&quot;settings&quot;:{&quot;cookie_name&quot;:[&quot;pum-4872669&quot;],&quot;extra_selectors&quot;:&quot;&quot;}}],&quot;mobile_disabled&quot;:null,&quot;tablet_disabled&quot;:null,&quot;meta&quot;:{&quot;display&quot;:{&quot;stackable&quot;:&quot;1&quot;,&quot;overlay_disabled&quot;:&quot;1&quot;,&quot;scrollable_content&quot;:false,&quot;disable_reposition&quot;:false,&quot;size&quot;:&quot;tiny&quot;,&quot;responsive_min_width&quot;:&quot;0%&quot;,&quot;responsive_min_width_unit&quot;:false,&quot;responsive_max_width&quot;:&quot;100%&quot;,&quot;responsive_max_width_unit&quot;:false,&quot;custom_width&quot;:&quot;640px&quot;,&quot;custom_width_unit&quot;:false,&quot;custom_height&quot;:&quot;380px&quot;,&quot;custom_height_unit&quot;:false,&quot;custom_height_auto&quot;:false,&quot;location&quot;:&quot;left bottom&quot;,&quot;position_from_trigger&quot;:false,&quot;position_top&quot;:&quot;100&quot;,&quot;position_left&quot;:&quot;10&quot;,&quot;position_bottom&quot;:&quot;10&quot;,&quot;position_right&quot;:&quot;0&quot;,&quot;position_fixed&quot;:&quot;1&quot;,&quot;animation_type&quot;:&quot;fade&quot;,&quot;animation_speed&quot;:&quot;350&quot;,&quot;animation_origin&quot;:&quot;left bottom&quot;,&quot;overlay_zindex&quot;:false,&quot;zindex&quot;:&quot;1999999999&quot;},&quot;close&quot;:{&quot;text&quot;:&quot;&quot;,&quot;button_delay&quot;:&quot;0&quot;,&quot;overlay_click&quot;:false,&quot;esc_press&quot;:false,&quot;f4_press&quot;:false},&quot;click_open&quot;:[],&quot;convert_on&quot;:&quot;link_click&quot;},&quot;conditions&quot;:[[{&quot;target&quot;:&quot;referrer_contains&quot;,&quot;not_operand&quot;:false,&quot;settings&quot;:{&quot;search&quot;:&quot;google&quot;},&quot;search&quot;:&quot;google&quot;},{&quot;target&quot;:&quot;referrer_contains&quot;,&quot;not_operand&quot;:false,&quot;settings&quot;:{&quot;search&quot;:&quot;facebook&quot;},&quot;search&quot;:&quot;facebook&quot;}]]}" role="dialog" aria-hidden="true" aria-labelledby="pum_popup_title_4872669">
<div id="popmake-4872669" class="pum-container popmake theme-118330 pum-responsive pum-responsive-tiny responsive size-tiny pum-position-fixed">
<div id="pum_popup_title_4872669" class="pum-title popmake-title">
Hey — Why No Paywall? </div>
<div class="pum-content popmake-content" tabindex="0">
<p style="text-align: left;"><a href="https://highlandscurrent.org/wp-content/uploads/2022/04/brick-wall-tr.jpg" data-wpel-link="internal"><img loading="lazy" class=" wp-image-4872741 alignright" src="https://highlandscurrent.org/wp-content/uploads/2022/04/brick-wall-tr.jpg" alt="brick wall" width="112" height="222" srcset="https://highlandscurrent.org/wp-content/uploads/2022/04/brick-wall-tr.jpg 253w, https://highlandscurrent.org/wp-content/uploads/2022/04/brick-wall-tr-150x296.jpg 150w, https://highlandscurrent.org/wp-content/uploads/2022/04/brick-wall-tr-243x480.jpg 243w" sizes="(max-width: 112px) 100vw, 112px" /></a><span style="font-size: 12pt;">This news site is reader-supported, meaning it is provided free to the Beacon and Philipstown communities because of the support of readers like you who make recurring, <span style="text-decoration: underline;">tax-deductible</span> donations of $5 or $10 per month. Will you join us?</span></p>
<h5 style="text-align: center;"><a href="https://highlandscurrent.org/membership/join" data-wpel-link="internal">Click here to get started</a><a href="https://highlandscurrent.org/membership/join" data-wpel-link="internal">.</a></h5>
</div>
<button type="button" class="pum-close popmake-close" aria-label="Close">
X </button>
</div>
</div>
<script type="text/template" id="tmpl-floating-social-buttons"><div class="largo-follow post-social clearfix"><span class="facebook"><a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fhighlandscurrent.org%2F2022%2F05%2F01%2Fbeacon-obituaries-288%2F"><i class="icon-facebook"></i><span class="hidden-phone">Share</span></a></span><span class="twitter"><a target="_blank" href="https://twitter.com/intent/tweet?text=Beacon%20Obituaries&url=https%3A%2F%2Fhighlandscurrent.org%2F2022%2F05%2F01%2Fbeacon-obituaries-288%2F&via=highlandcurrent"><i class="icon-twitter"></i><span class="hidden-phone">Tweet</span></a></span><span data-service="email" class="email share-button"><a href="mailto:?subject=Beacon%20Obituaries&body=Betty%20Baldwin%2C%20Israel%20Beltran%20Sr.%2C%20Gloria%20Marchiehttps%3A%2F%2Fhighlandscurrent.org%2F2022%2F05%2F01%2Fbeacon-obituaries-288%2F" target="_blank"><i class="icon-mail"></i> <span class="hidden-phone">Email</span></a></span><span class="print"><a href="#" onclick="window.print()" title="Print this article" rel="nofollow"><i class="icon-print"></i><span class="hidden-phone">Print</span></a></span><span class="more-social-links">
	<a class="popover-toggle" href="#"><i class="icon-plus"></i><span class="hidden-phone">More</span></a>
	<span class="popover">
	<ul>
		<li><a href="https://highlandscurrent.org/category/obituaries/"><i class="icon-link"></i> <span>More on Obituaries</span></a></li>
<li><a href="https://highlandscurrent.org/category/obituaries/feed/"><i class="icon-rss"></i> <span>Subscribe to Obituaries</span></a></li>
	</ul>
	</span>
</span></div></script> <script type="text/javascript" id="floating-social-buttons-width-json">
				window.floating_social_buttons_width = {"min":"1400","max":"9999"}			</script>
<script type="text/javascript" src="https://highlandscurrent.org/wp-content/themes/largo-0.6.3/js/floating-social-buttons.min.js?ver=0.6.3" async></script>
<link rel='stylesheet' id='whp5731tw-bs4.css-css' href='https://highlandscurrent.org/wp-content/plugins/wp-security-hardening/modules/inc/assets/css/tw-bs4.css' type='text/css' media='all' />
<link rel='stylesheet' id='whp4496font-awesome.min.css-css' href='https://highlandscurrent.org/wp-content/plugins/wp-security-hardening/modules/inc/fa/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='whp7345front.css-css' href='https://highlandscurrent.org/wp-content/plugins/wp-security-hardening/modules/css/front.css' type='text/css' media='all' />
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/document-gallery/assets/js/gallery.min.js' id='document-gallery-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/national-weather-service-alerts/js/nws-alerts.js' id='nws-alerts-js-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/podcast-subscribe-buttons/assets/js/modal.min.js' id='secondline_psb_button_modal_script-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/twenty20/assets/js/jquery.twenty20.js' id='twenty20-style-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/twenty20/assets/js/jquery.event.move.js' id='twenty20-eventmove-style-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/jquery/ui/core.min.js' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/jquery/ui/menu.min.js' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/dist/vendor/regenerator-runtime.min.js' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/dist/dom-ready.min.js' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/dist/hooks.min.js' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/dist/a11y.min.js' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/jquery/ui/autocomplete.min.js' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' id='popup-maker-site-js-extra'>
/* <![CDATA[ */
var pum_vars = {"version":"1.16.7","pm_dir_url":"https:\/\/highlandscurrent.org\/wp-content\/plugins\/popup-maker\/","ajaxurl":"https:\/\/highlandscurrent.org\/wp-admin\/admin-ajax.php","restapi":"https:\/\/highlandscurrent.org\/wp-json\/pum\/v1","rest_nonce":null,"default_theme":"118330","debug_mode":"","disable_tracking":"","home_url":"\/","message_position":"top","core_sub_forms_enabled":"1","popups":[],"analytics_route":"61dffea18a4543c22584ef22d4368770","analytics_api":"https:\/\/highlandscurrent.org\/wp-json\/c75709875aa943ece81500473bf5b65e\/v1","page":"4910512","geo_provider":"cloudflare","geo_data":{"country_code":"US"}};
var pum_sub_vars = {"ajaxurl":"https:\/\/highlandscurrent.org\/wp-admin\/admin-ajax.php","message_position":"top"};
var pum_popups = {"pum-4882761":{"triggers":[{"type":"click_open","settings":{"cookie_name":["pum-4882761"],"extra_selectors":""}}],"cookies":[{"event":"on_popup_close","settings":{"name":"pum-4882761","key":"","session":false,"path":"1","time":"1 month"}}],"disable_on_mobile":false,"disable_on_tablet":false,"explain":null,"type_section":null,"theme_id":"118330","size":"tiny","responsive_min_width":"0%","responsive_max_width":"100%","custom_width":"640px","custom_height_auto":false,"custom_height":"380px","scrollable_content":false,"animation_type":"fade","animation_speed":"350","animation_origin":"left bottom","open_sound":"none","custom_sound":"","location":"left bottom","position_top":"100","position_bottom":"10","position_left":"10","position_right":"0","position_from_trigger":false,"position_fixed":true,"overlay_disabled":true,"stackable":true,"disable_reposition":false,"zindex":"1999999999","close_button_delay":"0","fi_promotion":null,"close_on_form_submission":false,"close_on_form_submission_delay":"0","close_on_overlay_click":false,"close_on_esc_press":false,"close_on_f4_press":false,"disable_form_reopen":false,"disable_accessibility":false,"theme_slug":"lightbox","id":4882761,"slug":"all-visitors-multiple-pages","conditions":[[{"target":"page_views","not_operand":false,"settings":{"morethan":"3","lessthan":"0"},"morethan":"3","lessthan":"0"}]]},"pum-4872669":{"triggers":[{"type":"click_open","settings":{"cookie_name":["pum-4872669"],"extra_selectors":""}}],"cookies":[{"event":"on_popup_close","settings":{"name":"pum-4872669","key":"","session":false,"path":"1","time":"1 month"}}],"disable_on_mobile":false,"disable_on_tablet":false,"explain":null,"type_section":null,"theme_id":"118330","size":"tiny","responsive_min_width":"0%","responsive_max_width":"100%","custom_width":"640px","custom_height_auto":false,"custom_height":"380px","scrollable_content":false,"animation_type":"fade","animation_speed":"350","animation_origin":"left bottom","open_sound":"none","custom_sound":"","location":"left bottom","position_top":"100","position_bottom":"10","position_left":"10","position_right":"0","position_from_trigger":false,"position_fixed":true,"overlay_disabled":true,"stackable":true,"disable_reposition":false,"zindex":"1999999999","close_button_delay":"0","fi_promotion":null,"close_on_form_submission":false,"close_on_form_submission_delay":"0","close_on_overlay_click":false,"close_on_esc_press":false,"close_on_f4_press":false,"disable_form_reopen":false,"disable_accessibility":false,"theme_slug":"lightbox","id":4872669,"slug":"google-facebook-visitors","conditions":[[{"target":"referrer_contains","not_operand":false,"settings":{"search":"google"},"search":"google"},{"target":"referrer_contains","not_operand":false,"settings":{"search":"facebook"},"search":"facebook"}]]}};
/* ]]> */
</script>
<script type='text/javascript' src='//highlandscurrent.org/wp-content/uploads/a1ccf307a9bebd718f793d331c91a2e6.js?defer&#038;generated=1650734278' id='popup-maker-site-js'></script>
<script type='text/javascript' id='popmake-popup-analytics-js-js-extra'>
/* <![CDATA[ */
var popmake_pa = {"nonce":"58f8f7037c"};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/popup-maker-popup-analytics/assets/js/scripts.min.js?defer' id='popmake-popup-analytics-js-js'></script>
<script type='text/javascript' id='largoCore-js-extra'>
/* <![CDATA[ */
var Largo = {"is_home":"","is_single":"1","sticky_nav_options":{"sticky_nav_display":true,"main_nav_hide_article":false,"nav_overflow_label":"More"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/js/largoCore.min.js' id='largoCore-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/js/navigation.min.js' id='largo-navigation-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/js/largoPlugins.js' id='largoPlugins-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/lib/navis-slideshows/vendor/slick/slick.min.js' id='jquery-slick-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/lib/navis-slideshows/js/navis-slideshows.js' id='navis-slideshows-js'></script>
<script type='text/javascript' id='heateor_sss_sharing_js-js-before'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://highlandscurrent.org/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://highlandscurrent.org/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://highlandscurrent.org/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 0;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")}
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js' id='heateor_sss_sharing_js-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/js/vendor/jquery.qtip.min.js' id='simcal-qtip-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/js/vendor/moment.min.js' id='simcal-fullcal-moment-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/js/vendor/moment-timezone-with-data.min.js' id='simcal-moment-timezone-js'></script>
<script type='text/javascript' id='simcal-default-calendar-js-extra'>
/* <![CDATA[ */
var simcal_default_calendar = {"ajax_url":"\/wp-admin\/admin-ajax.php","nonce":"16fc308a09","locale":"en_US","text_dir":"ltr","months":{"full":["January","February","March","April","May","June","July","August","September","October","November","December"],"short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"]},"days":{"full":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]},"meridiem":{"AM":"AM","am":"am","PM":"PM","pm":"pm"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/js/default-calendar.min.js' id='simcal-default-calendar-js'></script>
<script type='text/javascript' id='pn-script-app-frontend-js-extra'>
/* <![CDATA[ */
var pnScriptSetting = {"nonce":"30926c46f5","pn_config":{"apiKey":"AIzaSyDhRbFy9m-NXZVkozYJwKdDYJuwsL6W_bw","authDomain":"pushnotificationsio.firebaseapp.com","databaseURL":"https:\/\/pushnotificationsio.firebaseio.com","projectId":"pushnotificationsio","storageBucket":"pushnotificationsio.appspot.com","messagingSenderId":"788493704860","appId":"1:788493704860:web:ba71fd692e7cc9651f5759","measurementId":"G-NXS0Z75BCH"},"swsource":"https:\/\/highlandscurrent.org\/?push_notification_sw=1","scope":"https:\/\/highlandscurrent.org\/","ajax_url":"https:\/\/highlandscurrent.org\/wp-admin\/admin-ajax.php","cookie_scope":"\/","notification_popup_show_again":"30","popup_show_afternseconds":"3","popup_show_afternpageview":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/push-notification//assets/public/application.min.js' id='pn-script-app-frontend-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/push-notification//assets/public/analytics.js' id='pn-script-analytics-js'></script>
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js' id='pn-script-gtag-js'></script>
<script type='text/javascript' id='pn-script-gtag-js-after'>
window.dataLayer = window.dataLayer || []; function gtag(){dataLayer.push(arguments);} gtag('js', new Date());
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/push-notification//assets/public/messaging.min.js' id='pn-script-messaging-frontend-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/pwa-register-sw.js' id='pwa-main-script-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/js/vendor/imagesloaded.pkgd.min.js' id='simplecalendar-imagesloaded-js'></script>
<script type='text/javascript' defer src='https://highlandscurrent.org/wp-content/plugins/mailchimp-for-wp/assets/js/forms.js' id='mc4wp-forms-api-js'></script>
<script type='text/javascript' id='mc4wp-ajax-forms-js-extra'>
/* <![CDATA[ */
var mc4wp_ajax_vars = {"loading_character":"\u2022","ajax_url":"https:\/\/highlandscurrent.org\/wp-admin\/admin-ajax.php?action=mc4wp-form","error_text":"Oops. Something went wrong. Please try again later."};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/mc4wp-premium/ajax-forms/assets/js/ajax-forms.js' id='mc4wp-ajax-forms-js'></script>
<style>.pn-wrapper{
			box-shadow: 0 1px 3px 0 rgba(60,64,67,0.302), 0 4px 8px 3px rgba(60,64,67,0.149);
		    font-family: Roboto,RobotoDraft,Helvetica,Arial,sans-serif;
		    font-size: 14px;
		    align-items: center;
		    background-color: #222;
		    border: none;
		    border-radius: 4px;
		    box-sizing: border-box;
		    color: #fff;
		    display: none;
		    flex-wrap: wrap;
		    font-weight: 400;
		    padding: 16px 22px;
		    z-index:99999;
		    text-align: left;
		    position: fixed;
		    bottom: 0;
		    left: 0;
		    margin: 20px;
		    right: auto;
		    top: auto;
		}
.pn-wrapper .pn-txt-wrap {
    display: flex;
    flex-wrap: wrap;
    position: relative;
    height: auto;
    line-height: 1;
}
.pn-wrapper .pn-btns{
    margin-left: 10px;
    display: flex;
}
.pn-wrapper .btn.act{color: #8ab4f8;}
.pn-wrapper .btn{
	align-items: center;
    border: none;
    display: inline-flex;
    outline: none;
    position: relative;
    font-size: 14px;
    background: none;
    border-radius: 4px;
    box-sizing: border-box;
    color: #5f6368;
    cursor: pointer;
    font-weight: 500;
    outline: none;
    margin-left: 8px;
    min-width: auto;
    padding: 0 8px;
    text-decoration: none;
}
</style><div class="pn-wrapper">
<span class="pn-txt-wrap">
<span class="pn-msg">Enable Notifications</span>
<span class="pn-btns">&nbsp;&nbsp;
<span class="btn act" id="pn-activate-permission_link" tabindex="0" role="link" aria-label="ok link">
OK
</span>
<span class="btn" id="pn-activate-permission_link_nothanks" tabindex="0" role="link" aria-label="no thanks link">
No thanks
</span>
</span>
</span>
</div> <script type="text/javascript">
				jQuery('.soliloquy-container').removeClass('no-js');
		</script>


<object id="ai-adb-dblclk" data="https://securepubads.g.doubleclick.net/tag/js/gpt.js" style="position:absolute; z-index: -100; top: -1000px; left: -1000px; visibility: hidden;"></object>
<object id="ai-adb-ga" data="https://www.google-analytics.com/analytics.js" style="position:absolute; z-index: -100; top: -1000px; left: -1000px; visibility: hidden;"></object>
<object id="ai-adb-mn" data="//contextual.media.net/dmedianet.js" style="position:absolute; z-index: -100; 1px; top: -1000px; left: -1000px; visibility: hidden;"></object>
<div id="banner-advert-container" class="adsense sponsor-ad" style="position:absolute; z-index: -10; height: 1px; width: 1px; top: -100px; left: -100px;"><img id="im_popupFixed" class="ad-inserter adsense ad-img ad-index" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/images/ads.png" width="1" height="1" alt="pixel"></div>
<script async id="ai-adb-ads" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/js/ads.js?ver=2.7.14-1651430684"></script>
<script async id="ai-adb-sponsors" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/js/sponsors.js?ver=2.7.14-1651430687"></script>
<script async id="ai-adb-advertising" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/js/advertising.js?ver=2.7.14-1651430684"></script>
<script async id="ai-adb-adverts" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/js/adverts.js?ver=2.7.14-1651430684"></script>
<script async id="ai-adb-banner" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/js/banner.js?ver=2.7.14"></script>
<script async id="ai-adb-300x250" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/js/300x250.js?ver=2.7.14"></script>


<script>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</script>
</body>
</html>
