<!DOCTYPE html>
<!--[if lt IE 7]> <html lang="en-US" class="no-js ie6"> <![endif]-->
<!--[if IE 7]>    <html lang="en-US" class="no-js ie7"> <![endif]-->
<!--[if IE 8]>    <html lang="en-US" class="no-js ie8"> <![endif]-->
<!--[if IE 9]>    <html lang="en-US" class="no-js ie9"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--> <html lang="en-US" class="no-js"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://highlandscurrent.org/xmlrpc.php" />
<script>
			function whichHeader() {
				var screenWidth = document.documentElement.clientWidth,
				header_img;
				if (screenWidth <= 767) {
					header_img = 'https://highlandscurrent.org/wp-content/uploads/2021/08/currentslogo-pantone3145U-768-240.png';
				} else if (screenWidth > 767 && screenWidth <= 979) {
					header_img = 'https://highlandscurrent.org/wp-content/uploads/2021/08/currentslogo-pantone3145U-980-180-771x142-1.png';
				} else {
					header_img = 'https://highlandscurrent.org/wp-content/uploads/2021/08/currentslogo-pantone3145U-500a-1.png';
				}
				return header_img;
			}
			var banner_img_src = whichHeader();
		</script>

<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Meet the Candidates" />
<meta property="og:description" content="Who&#039;s who on the Beacon ballot " />
<meta property="og:url" content="https://highlandscurrent.org/2021/10/22/meet-your-candidates/" />
<meta property="og:site_name" content="The Highlands Current" />
<meta property="og:updated_time" content="2021-10-22T15:00:47+00:00" />
<meta property="article:published_time" content="2021-10-22T10:58:04+00:00" />
<meta property="article:modified_time" content="2021-10-22T15:00:47+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Meet the Candidates" />
<meta name="twitter:description" content="Who&#039;s who on the Beacon ballot " />
<meta property="fb:app_id" content="244134510292665" />
<meta property="og:image" content="https://highlandscurrent.org/wp-content/uploads/2020/10/cc-square-thumb_vote.jpg" />
<meta name="twitter:image" content="https://highlandscurrent.org/wp-content/uploads/2020/10/cc-square-thumb_vote.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="600" />

<script type="text/javascript">                function apbct_attach_event_handler__backend(elem, event, callback){                    if(typeof window.addEventListener === "function") elem.addEventListener(event, callback);                    else                                              elem.attachEvent(event, callback);                }                apbct_attach_event_handler__backend(window, 'load', function(){                    ctSetCookie('ct_checkjs', '658866348' );                });    </script>

<title>Meet the Candidates - The Highlands Current</title>
<meta name="description" content="Who&#039;s who on the Beacon ballot " />
<link rel="canonical" href="https://highlandscurrent.org/2021/10/22/meet-your-candidates/" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Jeff Simms" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="6 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://highlandscurrent.org/#organization","name":"Highlands Current","url":"https://highlandscurrent.org/","sameAs":["https://www.facebook.com/highlandscurrent","https://www.instagram.com/highlandscurrent","https://www.youtube.com/c/HighlandsCurrent","https://twitter.com/highlandcurrent"],"logo":{"@type":"ImageObject","@id":"https://highlandscurrent.org/#logo","inLanguage":"en-US","url":"https://highlandscurrent.org/wp-content/uploads/2018/04/HC-circle.png","contentUrl":"https://highlandscurrent.org/wp-content/uploads/2018/04/HC-circle.png","width":600,"height":600,"caption":"Highlands Current"},"image":{"@id":"https://highlandscurrent.org/#logo"}},{"@type":"WebSite","@id":"https://highlandscurrent.org/#website","url":"https://highlandscurrent.org/","name":"The Highlands Current","description":"News for Philipstown (Cold Spring, Nelsonville, Garrison) and Beacon, New York","publisher":{"@id":"https://highlandscurrent.org/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://highlandscurrent.org/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://highlandscurrent.org/2021/10/22/meet-your-candidates/#primaryimage","inLanguage":"en-US","url":"https://highlandscurrent.org/wp-content/uploads/2020/10/cc-square-thumb_vote.jpg","contentUrl":"https://highlandscurrent.org/wp-content/uploads/2020/10/cc-square-thumb_vote.jpg","width":600,"height":600},{"@type":"WebPage","@id":"https://highlandscurrent.org/2021/10/22/meet-your-candidates/#webpage","url":"https://highlandscurrent.org/2021/10/22/meet-your-candidates/","name":"Meet the Candidates - The Highlands Current","isPartOf":{"@id":"https://highlandscurrent.org/#website"},"primaryImageOfPage":{"@id":"https://highlandscurrent.org/2021/10/22/meet-your-candidates/#primaryimage"},"datePublished":"2021-10-22T14:58:04+00:00","dateModified":"2021-10-22T19:00:47+00:00","description":"Who's who on the Beacon ballot\u00a0","breadcrumb":{"@id":"https://highlandscurrent.org/2021/10/22/meet-your-candidates/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://highlandscurrent.org/2021/10/22/meet-your-candidates/"]}]},{"@type":"BreadcrumbList","@id":"https://highlandscurrent.org/2021/10/22/meet-your-candidates/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://highlandscurrent.org/"},{"@type":"ListItem","position":2,"name":"Meet the Candidates"}]},{"@type":"Article","@id":"https://highlandscurrent.org/2021/10/22/meet-your-candidates/#article","isPartOf":{"@id":"https://highlandscurrent.org/2021/10/22/meet-your-candidates/#webpage"},"author":{"@id":"https://highlandscurrent.org/#/schema/person/a32ddf1bec340030494daa073b3b2079"},"headline":"Meet the Candidates","datePublished":"2021-10-22T14:58:04+00:00","dateModified":"2021-10-22T19:00:47+00:00","mainEntityOfPage":{"@id":"https://highlandscurrent.org/2021/10/22/meet-your-candidates/#webpage"},"wordCount":809,"commentCount":0,"publisher":{"@id":"https://highlandscurrent.org/#organization"},"image":{"@id":"https://highlandscurrent.org/2021/10/22/meet-your-candidates/#primaryimage"},"thumbnailUrl":"https://highlandscurrent.org/wp-content/uploads/2020/10/cc-square-thumb_vote.jpg","articleSection":["Beacon News"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://highlandscurrent.org/2021/10/22/meet-your-candidates/#respond"]}]},{"@type":"Person","@id":"https://highlandscurrent.org/#/schema/person/a32ddf1bec340030494daa073b3b2079","name":"Jeff Simms","image":{"@type":"ImageObject","@id":"https://highlandscurrent.org/#personlogo","inLanguage":"en-US","url":"https://highlandscurrent.org/wp-content/wphb-cache/gravatar/a9b/a9b3a449bac7e8eac98955132b335283x96.jpg","contentUrl":"https://highlandscurrent.org/wp-content/wphb-cache/gravatar/a9b/a9b3a449bac7e8eac98955132b335283x96.jpg","caption":"Jeff Simms"},"description":"Simms has covered Beacon for The Current since 2015. He studied journalism at Appalachian State University and has reported for newspapers in North Carolina and Maryland. Location: Beacon. Languages: English. Area of expertise: Beacon politics","url":"https://highlandscurrent.org/author/jsimms/"}]}</script>

<link rel="manifest" href="https://highlandscurrent.org/pwa-manifest.json">
<link rel="apple-touch-icon-precomposed" sizes="192x192" href="https://highlandscurrent.org/wp-content/uploads/2020/12/HC-circle-192.jpg">
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//google-analytics.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//ssl.google-analytics.com' />
<link rel='dns-prefetch' href='//youtube.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='preconnect' href='//www.google-analytics.com' />
<link rel="alternate" type="application/rss+xml" title="The Highlands Current &raquo; Feed" href="https://highlandscurrent.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Highlands Current &raquo; Comments Feed" href="https://highlandscurrent.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Highlands Current &raquo; Meet the Candidates Comments Feed" href="https://highlandscurrent.org/2021/10/22/meet-your-candidates/feed/" />
<style>
		.apbct_wc_honeypot {
			display: none !important;
		}
		</style><style type="text/css">ul.wpbdp-categories > li {width: 33% !important;}</style><link rel='stylesheet' id='SFSIPLUSmainCss-css' href='https://highlandscurrent.org/wp-content/plugins/Ultimate-Premium-Plugin/css/sfsi-style.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='amazonpolly-css' href='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/7c4e3cd4d1384cb246b58a0d393331ea.css' type='text/css' media='all' />
<link rel='stylesheet' id='document-gallery-css' href='https://highlandscurrent.org/wp-content/plugins/document-gallery/assets/css/style.min.css?ver=4.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='dpsp-frontend-style-pro-css' href='https://highlandscurrent.org/wp-content/plugins/social-pug/assets/dist/style-frontend-pro.1.19.1.css?ver=1.19.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpb-google-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans&#038;ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpel-style-css' href='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/c8f52c1d04c244510e04b54f7ec68b27.css' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://highlandscurrent.org/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='largo-stylesheet-css' href='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/css/style.min.css?ver=0.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-featured-ads-css' href='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/085c48ee82f7de8997887503bfc09aea.css' type='text/css' media='all' />
<script type="text/javascript">
			ajaxurl = typeof(ajaxurl) !== 'string' ? 'https://highlandscurrent.org/wp-admin/admin-ajax.php' : ajaxurl;
		</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/shortcode-for-current-date/dist/script.js?ver=5.8.1' id='shortcode-for-current-date-script-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' id='wphb-1-js-extra'>
/* <![CDATA[ */
var ctPublicFunctions = {"_ajax_nonce":"021e1cdc5e","_rest_nonce":"5e05f6a3b8","_ajax_url":"\/wp-admin\/admin-ajax.php","_rest_url":"https:\/\/highlandscurrent.org\/index.php?rest_route=\/","_apbct_ajax_url":"https:\/\/highlandscurrent.org\/wp-content\/plugins\/cleantalk-spam-protect\/lib\/Cleantalk\/ApbctWP\/Ajax.php","data__set_cookies":"1","data__ajax_type":"rest"};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/073b29136bad6573f8c946ef4db9d03c.js' id='wphb-1-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/cleantalk-spam-protect/js/cleantalk-modal.min.js?ver=5.164.1' id='cleantalk-modal-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/467bd81043d410b25590e7042ee8d467.js' id='wphb-2-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/highlandscurrent.org\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/highlandscurrent.org\/wp-json\/wordpress-popular-posts","ID":4670581,"token":"5e05f6a3b8","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.4.2' id='wpp-js-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/js/load-more-posts.min.js?ver=1561210853' id='load-more-posts-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/js/modernizr.custom.js?ver=0.6.3' id='largo-modernizr-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/24862ad0b77bcdae0ce26041c73ddf5a.js' id='caos-analytics-js'></script>
<script type='text/javascript' id='caos-analytics-js-after'>
    


    window.ga = window.ga || function() {
        (ga.q = ga.q || []).push(arguments);
    };
    ga.l = +new Date;

        ga('create', 'UA-45190490-1', {"cookieName":"caosLocalGa","cookieDomain":"highlandscurrent.org","cookieExpires":2592000,"cookieFlags":"samesite=none;secure","siteSpeedSampleRate":"1"});
        ga('require', 'displayfeatures');    ga('send', 'pageview');
                    setTimeout("ga('send', 'event', 'Adjusted Bounce Rate', '45 seconds')", 45000);
        
</script>
<link rel="https://api.w.org/" href="https://highlandscurrent.org/wp-json/" /><link rel="alternate" type="application/json" href="https://highlandscurrent.org/wp-json/wp/v2/posts/4670581" /><link rel='shortlink' href='https://highlandscurrent.org?p=4670581' />
<link rel="alternate" type="application/json+oembed" href="https://highlandscurrent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fhighlandscurrent.org%2F2021%2F10%2F22%2Fmeet-your-candidates%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://highlandscurrent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fhighlandscurrent.org%2F2021%2F10%2F22%2Fmeet-your-candidates%2F&#038;format=xml" />
<style type="text/css">
					</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-45190490-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-45190490-1');
</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=G-Z4JXBVNWCV"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-Z4JXBVNWCV');
</script>

<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}<br />	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.<br />	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */<br /></style>


<style type="text/css">
#iubenda-cs-banner {
    bottom: 0px !important;
    left: 0px !important;
    position: fixed !important;
    width: 100% !important;
    z-index: 99999998 !important;
    background-color: black;
  }
  .iubenda-cs-content {
    display: block;
    margin: 0 auto;
    padding: 20px;
    width: auto;
    font-family: Helvetica,Arial,FreeSans,sans-serif;
    font-size: 14px;
    background: #000;
    color: #fff;}
  .iubenda-cs-rationale {
    max-width: 900px;
    position: relative;
    margin: 0 auto;
  }
  .iubenda-banner-content > p {
    font-family: Helvetica,Arial,FreeSans,sans-serif;
    line-height: 1.5;
  }
  .iubenda-cs-close-btn {
    margin:0;
    color: #fff;
    text-decoration: none;
    font-size: 14px;
    position: absolute;
    top: 0;
    right: 0;
    border: none;
  }
  .iubenda-cs-cookie-policy-lnk {
    text-decoration: underline;
    color: #fff;
    font-size: 14px;
    font-weight: 900;
  }
</style>
<script type="text/javascript">
var _iub = _iub || [];
_iub.csConfiguration = {"lang":"en","siteId":1322595,"gdprAppliesGlobally":false,"whitelabel":false,"cookiePolicyId":25776182, "banner":{ "slideDown":false,"applyStyles":false,"textColor":"#0080c0","backgroundColor":"#c0c0c0","position":"float-bottom-center" }};
</script>
<script type="text/javascript" src="//cdn.iubenda.com/cs/iubenda_cs.js" charset="UTF-8" async></script>


<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NMQQZ2K');</script>

<meta property="fb:pages" content="130747183632721" />
<meta property="ia:markup_url" content="https://highlandscurrent.org/2021/10/22/meet-your-candidates/?ia_markup=1" />
<script>/* <![CDATA[ */ portfolio_slideshow = { options : {"psHash":"false","psLoader":"false"}, slideshows : new Array() }; /* ]]> */</script> <script type="text/javascript">
        function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: 'ee40659687'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://highlandscurrent.org/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }
    </script><style type="text/css" data-source="Grow Social by Mediavine">
				@media screen and ( max-width : 720px ) {
					.dpsp-content-wrapper.dpsp-hide-on-mobile,
					.dpsp-share-text.dpsp-hide-on-mobile,
					.dpsp-content-wrapper .dpsp-network-label {
						display: none;
					}
					.dpsp-has-spacing .dpsp-networks-btns-wrapper li {
						margin:0 2% 10px 0;
					}
					.dpsp-network-btn.dpsp-has-label:not(.dpsp-has-count) {
						max-height: 40px;
						padding: 0;
						justify-content: center;
					}
					.dpsp-content-wrapper.dpsp-size-small .dpsp-network-btn.dpsp-has-label:not(.dpsp-has-count){
						max-height: 32px;
					}
					.dpsp-content-wrapper.dpsp-size-large .dpsp-network-btn.dpsp-has-label:not(.dpsp-has-count){
						max-height: 46px;
					}
				}
			</style> <style>
            @-webkit-keyframes bgslide {
                from {
                    background-position-x: 0;
                }
                to {
                    background-position-x: -200%;
                }
            }

            @keyframes bgslide {
                    from {
                        background-position-x: 0;
                    }
                    to {
                        background-position-x: -200%;
                    }
            }

            .wpp-widget-placeholder {
                margin: 0 auto;
                width: 60px;
                height: 3px;
                background: #dd3737;
                background: -webkit-gradient(linear, left top, right top, from(#dd3737), color-stop(10%, #571313), to(#dd3737));
                background: linear-gradient(90deg, #dd3737 0%, #571313 10%, #dd3737 100%);
                background-size: 200% auto;
                border-radius: 3px;
                -webkit-animation: bgslide 1s infinite linear;
                animation: bgslide 1s infinite linear;
            }
        </style>
<meta property="fb:admins" content="130747183632721" /><meta property="fb:app_id" content="448227681904822" /><link rel="apple-touch-icon" href="https://highlandscurrent.org/wp-content/uploads/2019/09/HC-circle-200.jpg" /><link rel="shortcut icon" href="https://highlandscurrent.org/wp-content/uploads/2019/09/HC-circle-16.jpg" /><meta name="news_keywords" content="Beacon News"><meta name="original-source" content="https://highlandscurrent.org/2021/10/22/meet-your-candidates/" /><meta name="syndication-source" content="https://highlandscurrent.org/2021/10/22/meet-your-candidates/" /><script type="application/ld+json">
{
    "@context": "http:\/\/schema.org",
    "@type": [
        "ReportageNewsArticle"
    ],
    "publishingPrinciples": "https:\/\/highlandscurrent.org\/editorial-standards\/",
    "image": "https:\/\/highlandscurrent.org\/wp-content\/uploads\/2020\/10\/cc-square-thumb_vote-140x140.jpg",
    "headline": "Meet the Candidates",
    "datePublished": "2021-10-22 10:58:04",
    "author": {
        "@type": "Person",
        "workLocation": {
            "@type": "Place",
            "name": "Beacon, New York"
        },
        "contactPoint": {
            "@type": "ContactPoint",
            "contactType": "Journalist",
            "telephone": "845-809-5584",
            "email": "jsimms@highlandscurrent.org"
        },
        "sameAs": [
            "https:\/\/highlandscurrent.org\/author\/jsimms\/"
        ],
        "name": "Jeff Simms",
        "description": "Simms has covered Beacon for The Current since 2015. He studied journalism at Appalachian State University and has reported for newspapers in North Carolina and Maryland. Location: Beacon. Languages: English. Area of expertise: Beacon politics",
        "knowsAbout": [
            "Beacon politics",
            {
                "@type": "Place",
                "name": "Beacon, New York"
            }
        ],
        "jobTitle": "Beacon Editor"
    },
    "knowsLanguage": [
        {
            "@type": "Language",
            "name": "English"
        }
    ]
}
</script>
<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style>
<style type='text/css'>
/* START Styles Simple Side Tab v2.1.4 */
#rum_sst_tab {
    font-family:Verdana, sans-serif;
    top:175px;
    background-color:#007788;
    color:#ffffff;
    border-style:solid;
    border-width:0px;
}

#rum_sst_tab:hover {
    background-color: #a4a4a4;
	-moz-box-shadow:    -3px -3px 5px 2px #ccc;
	-webkit-box-shadow: -3px -3px 5px 2px #ccc;
	box-shadow:         -3px -3px 5px 2px #ccc;
}
.rum_sst_contents {
    position:fixed;
    margin:0;
    padding:6px 13px 8px 13px;
    text-decoration:none;
    text-align:center;
    font-size:15px;
    font-weight:normal;
    border-style:solid;
    display:block;
    z-index:100000;
}
.rum_sst_left {
    left:-2px;
    cursor: pointer;
    -webkit-transform-origin:0 0;
    -moz-transform-origin:0 0;
    -o-transform-origin:0 0;
    -ms-transform-origin:0 0;
    -webkit-transform:rotate(270deg);
    -moz-transform:rotate(270deg);
    -ms-transform:rotate(270deg);
    -o-transform:rotate(270deg);
    transform:rotate(270deg);
    -moz-border-radius-bottomright:10px;
    border-bottom-right-radius:10px;
    -moz-border-radius-bottomleft:10px;
    border-bottom-left-radius:10px;
}
.rum_sst_right {
    right:-1px;
    cursor: pointer;
    -webkit-transform-origin:100% 100%;
    -moz-transform-origin:100% 100%;
    -o-transform-origin:100% 100%;
    -ms-transform-origin:100% 100%;
    -webkit-transform:rotate(-90deg);
    -moz-transform:rotate(-90deg);
    -ms-transform:rotate(-90deg);
    -o-transform:rotate(-90deg);
    transform:rotate(-90deg);
    -moz-border-radius-topright:10px;
    border-top-right-radius:10px;
    -moz-border-radius-topleft:10px;
    border-top-left-radius:10px;
}
.rum_sst_right.less-ie-9 {
    right:-120px;
    filter: progid:DXImageTransform.Microsoft.BasicImage(rotation=1);
}
.rum_sst_left.less-ie-9 {
    filter: progid:DXImageTransform.Microsoft.BasicImage(rotation=3);
}
/* END Styles Simple Side Tab */
</style>
<link rel="icon" href="https://highlandscurrent.org/wp-content/uploads/2018/04/cropped-HC-circle-new-32x32.png" sizes="32x32" />
<link rel="icon" href="https://highlandscurrent.org/wp-content/uploads/2018/04/cropped-HC-circle-new-192x192.png" sizes="192x192" />
<meta name="msapplication-TileImage" content="https://highlandscurrent.org/wp-content/uploads/2018/04/cropped-HC-circle-new-270x270.png" />
<meta name="pwaforwp" content="wordpress-plugin" />
<meta name="theme-color" content="#D5E0EB">
<meta name="apple-mobile-web-app-title" content="The Highlands Current">
<meta name="application-name" content="The Highlands Current">
<meta name="apple-mobile-web-app-capable" content="yes">
<meta name="apple-mobile-web-app-status-bar-style" content="default">
<meta name="mobile-web-app-capable" content="yes">
<meta name="apple-mobile-web-app-title" content=" The Highlands Current">
<meta name="apple-touch-fullscreen" content="YES">
<link rel="apple-touch-startup-image" href="https://highlandscurrent.org/wp-content/uploads/2020/12/HC-circle-192.jpg">
<link rel="apple-touch-icon" sizes="192x192" href="https://highlandscurrent.org/wp-content/uploads/2020/12/HC-circle-192.jpg">
<link rel="apple-touch-icon" sizes="512x512" href="https://highlandscurrent.org/wp-content/uploads/2018/04/cropped-HC-circle-new.png">
<style type="text/css">.sfsibeforpstwpr .sfsiplus_norm_row.sfsi_plus_wDivothr .sfsi_premium_wicons:nth-child(2) {margin-left: 2.5px !important;margin-right: 2.5px !important;} .sfsibeforpstwpr .sfsiplus_norm_row.sfsi_plus_wDivothr .sfsi_premium_wicons, .sfsiaftrpstwpr .sfsiplus_norm_row.sfsi_plus_wDivothr .sfsi_premium_wicons{width: 40px !important;height: 40px !important; margin-left: 2.5px !important;margin-right: 2.5px !important;margin-bottom: 5px !important;}</style> <style type="text/css" id="wp-custom-css">
			.wp-caption-text {
display:block !important;
font-size:10px !important;
font-style:normal !important;
margin:0 auto !important;
padding:3px 10px 3px !important;
text-align:left !important;
font-family: "Roboto", arial, sans-serif !important; }
.trust_indicators_article h4 {
  font-size: 1em;
}
.trust_indicators_article .widgettitle {
  text-tras: ;
  text-transform: none;
  font-size: 1em;
}
.trust_indicators_article p {
  margin-bottom: 0.5em;
}
.trust_indicators_article h4 {
  margin-bottom: 0.5em;
}
.trust_indicators_article .widgettitle {
  margin-bottom: 0.5em;
}
.trust_indicators_article > :last-child {
  margin: ;
  margin-bottom: 0;
}
.article-bottom .trust_indicators_article {
  background: #eee;
  padding: 1em;
}
.trust_indicators_article p {
  font-size: 90%;
}		</style>
</head>
<body class="post-template-default single single-post postid-4670581 single-format-standard wp-embed-responsive fpt-template-largo-0.6.3 wpbdp-with-button-styles usm-premium-15.9-updated-2021-06-04 classic">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NMQQZ2K"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="top"></div>
<div class="global-nav-bg">
<div class="global-nav">
<nav id="top-nav" class="span12">
<span class="visuallyhidden">
<a href="#main" title="Skip to content">Skip to content</a>
</span>
<div class="nav-right">
<div class="donate-btn"><a href="https://highlandscurrent.org/membership/" data-wpel-link="internal"><i class="icon-heart"></i>Become a Member</a></div> <div id="header-search">
<form class="form-search" role="search" method="get" action="https://highlandscurrent.org/">
<div class="input-append">
<input type="text" placeholder="Search" class="input-medium appendedInputButton search-query" value="" name="s" /><button type="submit" class="search-submit btn">GO</button>
</div>
</form>
</div>

</div>
</nav>
</div> 
</div> 
<div id="page" class="hfeed clearfix">
<div class="sticky-nav-wrapper nocontent">
<div class="sticky-nav-holder">
<div class="sticky-nav-container">
<nav id="sticky-nav" class="sticky-navbar navbar clearfix">
<div class="container">
<div class="nav-right">
<ul id="header-extras">
<li class="donate">
<a class="donate-link" href="https://highlandscurrent.org/membership/" data-wpel-link="internal">
<span><i class="icon-heart"></i>Become a Member</span>
</a>
</li> <li id="sticky-nav-search">
<a href="#" class="toggle">
<i class="icon-search" title="Search" role="button"></i>
</a>
<form class="form-search" role="search" method="get" action="https://highlandscurrent.org/">
<div class="input-append">
<span class="text-input-wrapper">
<input type="text" placeholder="Search" class="input-medium appendedInputButton search-query" value="" name="s" />
</span>
<button type="submit" class="search-submit btn">Go</button>
</div>
</form>
</li>
<li>

<a class="btn btn-navbar toggle-nav-bar" title="More">
<div class="bars">
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</div>
</a>
</li>
</ul>
</div>

<div class="nav-left">
<ul>
<li class="home-icon"><a href="https://highlandscurrent.org/" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2021/08/currentslogo-pantone3145U-500a-1.png" class="attachment-home-logo" alt="logo"></a></li>
</ul>
</div>


<div class="nav-shelf">
<ul class="nav">
<li class="home-icon">
<a href="https://highlandscurrent.org/" data-wpel-link="internal">
<img src="https://highlandscurrent.org/wp-content/uploads/2021/08/currentslogo-pantone3145U-500a-1.png" class="attachment-home-logo" alt="logo"> </a>
</li>
<li id="menu-item-92601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92601"><a href="https://highlandscurrent.org/stories/" data-wpel-link="internal">Philipstown</a></li>
<li id="menu-item-92597" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-92597"><a href="https://highlandscurrent.org/beacon/" data-wpel-link="internal">Beacon</a></li>
<li id="menu-item-92596" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92596"><a href="https://highlandscurrent.org/arts/" data-wpel-link="internal">Arts</a></li>
<li id="menu-item-4285070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4285070"><a href="https://highlandscurrent.org/sports/" data-wpel-link="internal">Sports</a></li>
<li id="menu-item-4285086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4285086"><a href="https://highlandscurrent.org/obituaries/" data-wpel-link="internal">Obits</a></li>
<li id="menu-item-1270852" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-1270852"><a href="https://highlandscurrent.org/columns/" class="dropdown-toggle" data-wpel-link="internal">Columns <b class="caret"></b></a>
<ul class="dropdown-menu">
<li id="menu-item-2145700" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2145700"><a href="https://highlandscurrent.org/tag/reporters-notebook/" data-wpel-link="internal">Reporter&#8217;s Notebook</a></li>
<li id="menu-item-1270862" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270862"><a href="https://highlandscurrent.org/tag/out-there/" data-wpel-link="internal">Out There</a></li>
<li id="menu-item-1270854" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270854"><a href="https://highlandscurrent.org/tag/roots-and-shoots/" data-wpel-link="internal">Roots and Shoots</a></li>
<li id="menu-item-1270853" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270853"><a href="https://highlandscurrent.org/tag/mouths-to-feed/" data-wpel-link="internal">Mouths to Feed</a></li>
<li id="menu-item-1270855" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270855"><a href="https://highlandscurrent.org/tag/small-good-things/" data-wpel-link="internal">Small Good Things</a></li>
<li id="menu-item-1270859" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270859"><a href="https://highlandscurrent.org/tag/kid-friendly/" data-wpel-link="internal">Kid Friendly</a></li>
<li id="menu-item-1270861" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270861"><a href="https://highlandscurrent.org/tag/genealogy/" data-wpel-link="internal">Family Trails</a></li>
</ul>
</li>
<li id="menu-item-28023" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-28023"><a href="https://highlandscurrent.org/advertise/" class="dropdown-toggle" data-wpel-link="internal">Advertise <b class="caret"></b></a>
<ul class="dropdown-menu">
<li id="menu-item-3617400" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617400"><a href="https://highlandscurrent.org/advertise/" data-wpel-link="internal">View Media Kit</a></li>
<li id="menu-item-3617432" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617432"><a href="https://highlandscurrent.org/advertise/" data-wpel-link="internal">View Circulation Audit</a></li>
<li id="menu-item-3617396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617396"><a href="https://highlandscurrent.org/phils-list/" data-wpel-link="internal">View Classified Ads</a></li>
<li id="menu-item-3745912" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3745912"><a href="https://highlandscurrent.org/phils-list/place-ad/" data-wpel-link="internal">Place Classified Ad</a></li>
<li id="menu-item-3617392" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617392"><a href="https://highlandscurrent.org/public-notices/" data-wpel-link="internal">Public Notices</a></li>
<li id="menu-item-3617426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617426"><a href="https://highlandscurrent.org/advertise/adpay/" data-wpel-link="internal">Pay for Your Ad</a></li>
</ul>
</li>
<li id="menu-item-179247" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-179247"><a href="https://highlandscurrent.org/membership/" class="dropdown-toggle" data-wpel-link="internal">Support Our Work <b class="caret"></b></a>
<ul class="dropdown-menu">
<li id="menu-item-537662" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537662"><a href="https://highlandscurrent.org/membership/" data-wpel-link="internal">Become a member</a></li>
<li id="menu-item-3123099" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3123099"><a href="https://highlandscurrent.org/membership/renewal/" data-wpel-link="internal">Renew your membership</a></li>
<li id="menu-item-3123095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3123095"><a href="https://highlandscurrent.org/membership/gift-membership/" data-wpel-link="internal">Give a gift membership</a></li>
<li id="menu-item-3123118" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3123118"><a href="https://highlandscurrent.org/membership/donate/" data-wpel-link="internal">Make a donation</a></li>
<li id="menu-item-3617738" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617738"><a href="https://highlandscurrent.org/membership/update-your-member-information/" data-wpel-link="internal">Update your information</a></li>
</ul>
</li>
<li id="menu-item-328205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children dropdown menu-item-328205"><a href="https://highlandscurrent.org" class="dropdown-toggle" data-wpel-link="internal">Reader Guide <b class="caret"></b></a>
<ul class="dropdown-menu">
<li id="menu-item-88586" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88586"><a href="https://highlandscurrent.org/contact/" data-wpel-link="internal">Contact</a></li>
<li id="menu-item-88585" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88585"><a href="https://highlandscurrent.org/about/" data-wpel-link="internal">About</a></li>
<li id="menu-item-537674" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537674"><a href="https://highlandscurrent.org/editorial-standards/" data-wpel-link="internal">Editorial Standards</a></li>
<li id="menu-item-537666" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537666"><a href="https://highlandscurrent.org/newsletter/" data-wpel-link="internal">Free Newsletter</a></li>
<li id="menu-item-105563" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-105563"><a href="https://highlandscurrent.org/business-directory/" data-wpel-link="internal">Community Directory</a></li>
<li id="menu-item-537672" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537672"><a href="https://highlandscurrent.org/delivery/" data-wpel-link="internal">Mail Delivery</a></li>
<li id="menu-item-537669" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537669"><a href="https://highlandscurrent.org/pick-paper/" data-wpel-link="internal">Where to Find Paper</a></li>
<li id="menu-item-328206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-328206"><a href="https://highlandscurrent.org/archives/" data-wpel-link="internal">Back Issues</a></li>
<li id="menu-item-2145750" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2145750"><a href="https://highlandscurrent.org/high-schools/" data-wpel-link="internal">Student Journalists</a></li>
<li id="menu-item-127714" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-127714"><a href="https://highlandscurrent.org/help-wanted-cold-spring-garrison-new-york-jobs/" data-wpel-link="internal">Job Search <i class="icon-arrow-right"></i></a>
<ul class="dropdown-menu sub-menu">
<li id="menu-item-127719" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127719"><a href="https://highlandscurrent.org/beacon-jobs-employment-help-wanted/" data-wpel-link="internal">Beacon</a></li>
<li id="menu-item-127715" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127715"><a href="https://highlandscurrent.org/help-wanted-cold-spring-garrison-new-york-jobs/" data-wpel-link="internal">Philipstown</a></li>
</ul>
</li>
</ul>
</li>
<li class="donate">
<a class="donate-link" href="https://highlandscurrent.org/membership/" data-wpel-link="internal">
<span>Become a Member</span>
</a>
 </li> </ul>
</div>
</div>
</nav>
</div>
</div>
</div>
<header id="site-header" class="clearfix nocontent" itemscope itemtype="https://schema.org/Organization">
<h2 class="visuallyhidden">
<a itemprop="url" href="https://highlandscurrent.org/" data-wpel-link="internal">
<span class="sitename" itemprop="name">The Highlands Current</span>
<span class="tagline" itemprop="description"> - News for Philipstown (Cold Spring, Nelsonville, Garrison) and Beacon, New York</span>
</a>
</h2>
<a itemprop="url" href="https://highlandscurrent.org/" data-wpel-link="internal"><img class="header_img" src="" alt="" /></a><meta itemprop="logo" content="https://highlandscurrent.org/wp-content/uploads/2019/09/HC-circle-200.jpg" /><aside id="text-82" class="widget widget-1 odd default widget_text clearfix"> <div class="textwidget">October 22, 2021
</div>
</aside><aside id="ai_widget-3" class="widget widget-2 even default ai_widget clearfix"><div class='code-block code-block-2 ai-track' data-ai='WzIsIiIsIlRvcCBvZiBQYWdlIiwiIiwxXQ==' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<style>
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-filter-check, .ai-fallback, .ai-list-block, .ai-list-block-ip, .ai-list-block-filter {visibility: hidden; position: absolute; width: 50%; height: 1px; top: -1000px; z-index: -9999; margin: 0px!important;}
</style>
<div class='ai-rotate ai-unprocessed ai-2' data-info='WzIsNl0=' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="QQ==" data-time="MTA=">
<br>
<br>
<a href="https://highlandscurrent.org/delivery" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2021/01/OnlineHouseLONG-Deliver_border.jpg" alt="Mail Delivery ad"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qg==" data-time="MTA=">
<br>
<br>
<a href="https://highlandscurrent.org/membership" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2021/01/OnlineHouseLONG-Support_border.jpg" alt="Membership ad"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qw==" data-time="MTA=">
<br>
<br>
<a href="https://mblink.it/1P4Xl1PLB" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/04/1P4Xl1PLB.jpg" alt="Generac generators"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="RA==" data-time="MTA=">
<br>
<br>
<a href="https://www.philipstowndemocrats.org/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/09/PDems_T.P.Online_Banner_Ad_2021_HC.png" alt="Vote Van Tassel"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="RQ==" data-time="MTA=">
<br>
<br>
<a href="https://www.philipstowndemocrats.org/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/09/PDems_T.P.Online_Banner_Ad_2021_HC2.png" alt="Vote Cotter"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Rg==" data-time="MTA=">
<br>
<br>
<a href="https://www.philipstowndemocrats.org/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/09/PDems_T.P.Online_Banner_Ad_2021_HC3.png" alt="Vote Angell"></a></div>
</div>
</div>
</aside></header>
<header class="print-header nocontent">
<p>
<strong>The Highlands Current</strong>
(https://highlandscurrent.org/2021/10/22/meet-your-candidates/)
</p>
</header>
<nav id="main-nav" class="navbar clearfix">
<div class="navbar-inner">
<div class="container">
<div class="nav-shelf">
<ul class="nav">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92601"><a href="https://highlandscurrent.org/stories/" data-wpel-link="internal">Philipstown</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-92597"><a href="https://highlandscurrent.org/beacon/" data-wpel-link="internal">Beacon</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92596"><a href="https://highlandscurrent.org/arts/" data-wpel-link="internal">Arts</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4285070"><a href="https://highlandscurrent.org/sports/" data-wpel-link="internal">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4285086"><a href="https://highlandscurrent.org/obituaries/" data-wpel-link="internal">Obits</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-1270852"><a href="https://highlandscurrent.org/columns/" class="dropdown-toggle" data-wpel-link="internal">Columns <b class="caret"></b></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2145700"><a href="https://highlandscurrent.org/tag/reporters-notebook/" data-wpel-link="internal">Reporter&#8217;s Notebook</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270862"><a href="https://highlandscurrent.org/tag/out-there/" data-wpel-link="internal">Out There</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270854"><a href="https://highlandscurrent.org/tag/roots-and-shoots/" data-wpel-link="internal">Roots and Shoots</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270853"><a href="https://highlandscurrent.org/tag/mouths-to-feed/" data-wpel-link="internal">Mouths to Feed</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270855"><a href="https://highlandscurrent.org/tag/small-good-things/" data-wpel-link="internal">Small Good Things</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270859"><a href="https://highlandscurrent.org/tag/kid-friendly/" data-wpel-link="internal">Kid Friendly</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1270861"><a href="https://highlandscurrent.org/tag/genealogy/" data-wpel-link="internal">Family Trails</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-28023"><a href="https://highlandscurrent.org/advertise/" class="dropdown-toggle" data-wpel-link="internal">Advertise <b class="caret"></b></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617400"><a href="https://highlandscurrent.org/advertise/" data-wpel-link="internal">View Media Kit</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617432"><a href="https://highlandscurrent.org/advertise/" data-wpel-link="internal">View Circulation Audit</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617396"><a href="https://highlandscurrent.org/phils-list/" data-wpel-link="internal">View Classified Ads</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3745912"><a href="https://highlandscurrent.org/phils-list/place-ad/" data-wpel-link="internal">Place Classified Ad</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617392"><a href="https://highlandscurrent.org/public-notices/" data-wpel-link="internal">Public Notices</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617426"><a href="https://highlandscurrent.org/advertise/adpay/" data-wpel-link="internal">Pay for Your Ad</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-179247"><a href="https://highlandscurrent.org/membership/" class="dropdown-toggle" data-wpel-link="internal">Support Our Work <b class="caret"></b></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537662"><a href="https://highlandscurrent.org/membership/" data-wpel-link="internal">Become a member</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3123099"><a href="https://highlandscurrent.org/membership/renewal/" data-wpel-link="internal">Renew your membership</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3123095"><a href="https://highlandscurrent.org/membership/gift-membership/" data-wpel-link="internal">Give a gift membership</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3123118"><a href="https://highlandscurrent.org/membership/donate/" data-wpel-link="internal">Make a donation</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3617738"><a href="https://highlandscurrent.org/membership/update-your-member-information/" data-wpel-link="internal">Update your information</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children dropdown menu-item-328205"><a href="https://highlandscurrent.org" class="dropdown-toggle" data-wpel-link="internal">Reader Guide <b class="caret"></b></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88586"><a href="https://highlandscurrent.org/contact/" data-wpel-link="internal">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88585"><a href="https://highlandscurrent.org/about/" data-wpel-link="internal">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537674"><a href="https://highlandscurrent.org/editorial-standards/" data-wpel-link="internal">Editorial Standards</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537666"><a href="https://highlandscurrent.org/newsletter/" data-wpel-link="internal">Free Newsletter</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-105563"><a href="https://highlandscurrent.org/business-directory/" data-wpel-link="internal">Community Directory</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537672"><a href="https://highlandscurrent.org/delivery/" data-wpel-link="internal">Mail Delivery</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-537669"><a href="https://highlandscurrent.org/pick-paper/" data-wpel-link="internal">Where to Find Paper</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-328206"><a href="https://highlandscurrent.org/archives/" data-wpel-link="internal">Back Issues</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2145750"><a href="https://highlandscurrent.org/high-schools/" data-wpel-link="internal">Student Journalists</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-127714"><a href="https://highlandscurrent.org/help-wanted-cold-spring-garrison-new-york-jobs/" data-wpel-link="internal">Job Search <i class="icon-arrow-right"></i></a>
<ul class="dropdown-menu sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127719"><a href="https://highlandscurrent.org/beacon-jobs-employment-help-wanted/" data-wpel-link="internal">Beacon</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127715"><a href="https://highlandscurrent.org/help-wanted-cold-spring-garrison-new-york-jobs/" data-wpel-link="internal">Philipstown</a></li>
</ul>
</li>
</ul>
</li>
</ul>
</div>
</div>
</div>
</nav>
<div id="main" class="row-fluid clearfix">
<div id="content" class="span8" role="main">
<article id="post-4670581" class="hnews item post-4670581 post type-post status-publish format-standard has-post-thumbnail hentry category-beacon type-of-work-news featured-media featured-media-image" itemscope itemtype="https://schema.org/Article">
<header>
<h1 class="entry-title" itemprop="headline">Meet the Candidates</h1>
<h5 class="byline"><img src="https://highlandscurrent.org/wp-content/uploads/2021/04/simms-1-60x60.png" alt="Jeff Simms" width="32" height="32" class="avatar avatar-32 photo" /> <span class="by-author"><span class="by">By</span> <span class="author vcard" itemprop="author"><a class="url fn n" href="https://highlandscurrent.org/author/jsimms/" title="More from Jeff Simms" rel="author" data-wpel-link="internal">Jeff Simms</a></span></span><span class="job-title"><span class="comma">,</span> Beacon Editor</span><span class="sep"> |</span> <time class="entry-date updated dtstamp pubdate" datetime="2021-10-22T10:58:04-04:00"><span class="time-ago">7 hours ago</span></time></h5>
<meta itemprop="description" content="Who&#8217;s who on the Beacon ballot 

	
		
		
	
	Share

		
		
	
	Tweet

		
		
	
	Email


					
						
						
							Click to hear this post.
							
			
				
			
		
							
							
						
						
					" />
<meta itemprop="datePublished" content="2021-10-22T10:58:04-04:00" />
<meta itemprop="dateModified" content="2021-10-22T15:00:47-04:00" />
<meta itemprop="image" content="https://highlandscurrent.org/wp-content/uploads/2020/10/cc-square-thumb_vote-140x140.jpg" />
</header>
<div class="entry-content clearfix" itemprop="articleBody">
<p style="text-align: justify;"><em>Who’s who on the Beacon ballot</em></p>
<p style="text-align: justify;"><span style="font-size: 18pt;"><b>Beacon City Council</b></span><b></b><b></b></p>
<p><img loading="lazy" class=" wp-image-4670661 alignright" src="https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Molly-Rhodes-1-336x336.jpg" alt="Molly Rhodes" width="149" height="149" srcset="https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Molly-Rhodes-1-336x336.jpg 336w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Molly-Rhodes-1-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Molly-Rhodes-1-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Molly-Rhodes-1-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Molly-Rhodes-1-150x150.jpg 150w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Molly-Rhodes-1-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Molly-Rhodes-1-200x200.jpg 200w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Molly-Rhodes-1.jpg 400w" sizes="(max-width: 149px) 100vw, 149px" /><span style="color: #0000ff;"><b>Molly Rhodes </b><b>(Ward 1)</b></span></p>
<p style="text-align: justify;"><b>Why are you running?</b> After being part of the 2020 police chief search committee, I felt inspired to continue working to ensure everyone in Beacon feels valued and supported and benefits from a growing anti-racist community of care. I particularly want to continue Beacon’s focus and investment in safe and affordable housing for all.<br />
<b>Biggest issue:</b> Public safety<b></b><b></b></p>
<p><img loading="lazy" class=" wp-image-4670663 alignright" src="https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Justice-McCray-1-336x336.jpg" alt="Justice McCray" width="149" height="149" srcset="https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Justice-McCray-1-336x336.jpg 336w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Justice-McCray-1-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Justice-McCray-1-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Justice-McCray-1-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Justice-McCray-1-150x150.jpg 150w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Justice-McCray-1-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Justice-McCray-1-200x200.jpg 200w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Justice-McCray-1.jpg 400w" sizes="(max-width: 149px) 100vw, 149px" /><span style="color: #0000ff;"><b>Justice McCray </b><b>(Ward 2)</b></span></p>
<p style="text-align: justify;"><b>Why are you running?</b> Ending systemic racism requires systemic change. Through my work with Beacon 4 Black Lives, I’ve seen the power of civic engagement and mutual aid and I want to create policies that are actively anti-racist, foster sustainability and address the direct needs of the people who live here now. We can redefine our understanding of community safety when we center the lived experiences of those who are most vulnerable. The only way forward is through accountability, transparency, accessibility, compassion and creativity.<br />
<b>Biggest issue: </b>Housing insecurity</p>
<p><img loading="lazy" class=" wp-image-4670665 alignright" src="https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Wren-Longno-1-336x336.jpg" alt="Wren Longno" width="150" height="150" srcset="https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Wren-Longno-1-336x336.jpg 336w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Wren-Longno-1-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Wren-Longno-1-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Wren-Longno-1-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Wren-Longno-1-150x150.jpg 150w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Wren-Longno-1-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Wren-Longno-1-200x200.jpg 200w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Wren-Longno-1.jpg 400w" sizes="(max-width: 150px) 100vw, 150px" /><span style="color: #0000ff;"><b>Wren Longno </b><b>(Ward 3)</b></span></p>
<p style="text-align: justify;"><b>Why are you running?</b> As a working parent and 18-year veteran in nonprofit management, I value practicality and the importance of operational, essential systems run by government. On the council, I hope to improve communications between the city and residents so that local policymaking can be a community project.<br />
<b>Biggest issue: </b>We have to face changes responsibly by intentionally protecting our natural environment and our human environment, including protections for affordable housing for all.<span class="Apple-converted-space"> </span></p>
<p><img loading="lazy" class=" wp-image-4670667 alignright" src="https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Dan-Aymar-Blair-1-336x336.jpg" alt="Dan Aymar-Blair" width="152" height="152" srcset="https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Dan-Aymar-Blair-1-336x336.jpg 336w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Dan-Aymar-Blair-1-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Dan-Aymar-Blair-1-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Dan-Aymar-Blair-1-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Dan-Aymar-Blair-1-150x150.jpg 150w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Dan-Aymar-Blair-1-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Dan-Aymar-Blair-1-200x200.jpg 200w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Dan-Aymar-Blair-1.jpg 400w" sizes="(max-width: 152px) 100vw, 152px" /><span style="color: #0000ff;"><b>Dan Aymar-Blair </b><b>(Ward 4)*</b></span></p>
<p style="text-align: justify;"><b>Why are you running? </b>I’m listening to working-class people who tell me they haven’t felt the benefits of new development and tourism. We must make Beacon’s success work for everyone while minimizing the negative impacts. Can we make our streets safer? Can we make Beacon affordable again? Can we finally build a community center and provide municipal broadband? Let’s roll up our sleeves and get it done.<br />
<b>Biggest issue:</b> Improving the quality of life for the people who built this community.</p>
<p><img loading="lazy" class=" wp-image-4670668 alignright" src="https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-mansfield-1-336x336.jpg" alt="George Mansfeld" width="151" height="151" srcset="https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-mansfield-1-336x336.jpg 336w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-mansfield-1-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-mansfield-1-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-mansfield-1-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-mansfield-1-150x150.jpg 150w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-mansfield-1-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-mansfield-1-200x200.jpg 200w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-mansfield-1.jpg 400w" sizes="(max-width: 151px) 100vw, 151px" /><span style="color: #0000ff;"><b>George Mansfield </b><b>(At-large)*</b></span></p>
<p style="text-align: justify;"><b>Why are you running?</b> I am excited to be running for City Council with a slate of individuals who will bring fresh ideas and unique perspectives to local government. With my 12 years of experience on the council and two years on the Planning Board, I can offer a unique historical perspective and deep institutional knowledge on the challenges we face.<br />
<b>Biggest issue: </b>Our human infrastructure: social services, community kitchen, youth and senior services and a community center.</p>
<p><img loading="lazy" class=" wp-image-4670674 alignright" src="https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Paloma-Wake-1-336x336.jpg" alt="Paloma Wake" width="152" height="152" srcset="https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Paloma-Wake-1-336x336.jpg 336w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Paloma-Wake-1-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Paloma-Wake-1-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Paloma-Wake-1-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Paloma-Wake-1-150x150.jpg 150w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Paloma-Wake-1-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Paloma-Wake-1-200x200.jpg 200w, https://highlandscurrent.org/wp-content/uploads/2021/10/BEACON-COUNCIL-Paloma-Wake-1.jpg 400w" sizes="(max-width: 152px) 100vw, 152px" /><span style="color: #0000ff;"><b>Paloma Wake</b><b> (At-large)</b></span></p>
<p style="text-align: justify;"><b>Why are you running?</b> I am running to change the dynamic of city government to be more collaborative, transparent and anti-racist. I seek to extend my work with Beacon 4 Black Lives, Mutual Aid Beacon and the Human Rights Commission to more effectively address the basic needs of our city’s residents and meet our biggest challenges with brave solutions.<br />
<b>Biggest issue: </b>The rising tide of the climate crisis, which has intersectional consequences and requires intersectional solutions covering housing, food and community connections, which become frayed when basic needs are not being met.</p>
<p style="text-align: justify;"><span style="font-size: 18pt;"><b>Dutchess County Legislature (District 16)</b></span></p>
<p><img loading="lazy" class=" wp-image-4670676 alignright" src="https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-ron-davis-1-336x336.jpg" alt="Ron Davis" width="149" height="149" srcset="https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-ron-davis-1-336x336.jpg 336w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-ron-davis-1-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-ron-davis-1-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-ron-davis-1-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-ron-davis-1-150x150.jpg 150w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-ron-davis-1-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-ron-davis-1-200x200.jpg 200w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-ron-davis-1.jpg 400w" sizes="(max-width: 149px) 100vw, 149px" /><span style="color: #0000ff;"><b>Ronald Davis (R)<span class="Apple-converted-space"> </span></b></span></p>
<p style="text-align: justify;"><b>Why are you running? </b>I have made the Beacon Hills community my home for more than 40 years. It is time for me to give back to the area by offering my experience to serve in the Legislature. My priority will be to ensure that our county lives within its means. County agencies need to be efficient in dealing with tax dollars.<br />
<b>Biggest issue: </b>To make the Community Resource Center in Poughkeepsie, where our youth can learn quality skills, become an active part of our community, too.</p>
<p><img loading="lazy" class=" wp-image-4670677 alignright" src="https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-Yvette-Valdes-Smith-1-336x336.jpg" alt="Yvette Valdes Smith" width="151" height="151" srcset="https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-Yvette-Valdes-Smith-1-336x336.jpg 336w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-Yvette-Valdes-Smith-1-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-Yvette-Valdes-Smith-1-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-Yvette-Valdes-Smith-1-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-Yvette-Valdes-Smith-1-150x150.jpg 150w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-Yvette-Valdes-Smith-1-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-Yvette-Valdes-Smith-1-200x200.jpg 200w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-16-Yvette-Valdes-Smith-1.jpg 400w" sizes="(max-width: 151px) 100vw, 151px" /><span style="color: #0000ff;"><b>Yvette Valdes Smith (D)</b></span></p>
<p style="text-align: justify;"><b>Why are you running? </b>As a past public school teacher, proud union member and mother, I know that hard work and everyday values are worth fighting for. Our government should be more inclusive and diverse, and I will be a strong advocate for all of us. I serve on the board of directors for Stony Kill Farm and have sat on the Environmental Management Council for the Legislature. I know the uphill battles we face to make our community strong and healthy, and I’m ready to tackle them.<br />
<b>Biggest issue: </b>The county is receiving American Rescue Plan funding that must be invested in rebuilding our communities. I am running to ensure the proper oversight and usage of said funds and our tax dollars, and to serve the people of our area.<span class="Apple-converted-space"> </span></p>
<p style="text-align: justify;"><span style="font-size: 18pt;"><b>Dutchess County Legislature (District 18)</b></span></p>
<p><img loading="lazy" class=" wp-image-4670681 alignright" src="https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-18-page1-1-336x336.jpg" alt="Nick Page" width="149" height="149" srcset="https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-18-page1-1-336x336.jpg 336w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-18-page1-1-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-18-page1-1-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-18-page1-1-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-18-page1-1-150x150.jpg 150w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-18-page1-1-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-18-page1-1-200x200.jpg 200w, https://highlandscurrent.org/wp-content/uploads/2021/10/LEGISLATURE-18-page1-1.jpg 400w" sizes="(max-width: 149px) 100vw, 149px" /><span style="color: #0000ff;"><b>Nick Page (D)*</b></span></p>
<p style="text-align: justify;"><b>Why are you running?</b> I’d like to be a part of a county legislature that’s committed to providing the people of Dutchess County with forward-thinking infrastructure improvements, real social services and career opportunities, and serious attention to reducing the local cost of living.<span class="Apple-converted-space"><br />
</span><b>Biggest issue:</b> The Legislature has the potential to be what it is on paper — a separate and functional branch of county government.</p>
<p style="text-align: justify;"><em>*Incumbents</em></p>
<table id="amazon-polly-audio-table">
<tr>
<td id="amazon-polly-audio-tab">
<div id="amazon-ai-player-label">Click to hear this post.</div>
<div id="amazon-ai-player-container">
<audio class="amazon-ai-player" id="amazon-ai-player" preload="none" controls>
<source type="audio/mpeg" src="https://s3.us-east-1.amazonaws.com/audio-for-wordpress-30581202957c51937b6dacc89aaecad51734e18f/2021/10/amazon_polly_4670581.mp3?version=1634929262">
</audio>
</div>
<div id="amazon-polly-subscribe-tab"></div>
<div id="amazon-polly-by-tab"></div>
</td>
</tr>
</table> </div>
<footer class="post-meta bottom-meta">
</footer>
</article>
<div class="article-bottom nocontent"><aside id="text-97" class="widget widget-1 odd default widget_text clearfix"> <div class="textwidget"><hr>
</div>
</aside><aside id="largo-author-widget-2" class="widget widget-2 even default largo-author clearfix">
<div class="author-box row-fluid author vcard clearfix">
<h3 class="widgettitle">About <span class="fn n"><a class="url" href="https://highlandscurrent.org/author/jsimms/" rel="author" title="See all posts by Jeff Simms" data-wpel-link="internal">Jeff Simms</a></span></h3><div class="photo"><img src="https://highlandscurrent.org/wp-content/uploads/2021/04/simms-1-96x96.png" alt="Jeff Simms" width="96" height="96" class="avatar avatar-96 photo" /></div><p class="job-title">Beacon Editor</p><p>Simms has covered Beacon for The Current since 2015. He studied journalism at Appalachian State University and has reported for newspapers in North Carolina and Maryland. Location: Beacon. Languages: English. Area of expertise: Beacon politics</p> <ul class="social-links">
<li class="email">
<a class="email" href="/cdn-cgi/l/email-protection#91fbe2f8fcfce2d1f9f8f6f9fdf0fff5e2f2e4e3e3f4ffe5bffee3f6" title="e-mail Jeff Simms"><i class="icon-mail"></i></a>
</li>
<li class="author-posts-link"><a class="url" href="https://highlandscurrent.org/author/jsimms/" rel="author" title="See all posts by Jeff" data-wpel-link="internal">More by Jeff</a></li></ul>
</div>
</aside><aside id="text-98" class="widget widget-3 odd default widget_text clearfix"> <div class="textwidget"><hr>
</div>
</aside><aside id="custom_html-34" class="widget_text widget widget-4 even default widget_custom_html clearfix"><div class="textwidget custom-html-widget"><img src="https://highlandscurrent.org/wp-content/uploads/2020/09/trust-mark.png" align="right" alt="Trust Mark" /><font size="+1"><b>HOW WE REPORT</b></font><br><i>The Current</i> is a member of <a href="https://thetrustproject.org" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span>The Trust Project</a>, a consortium of news outlets that has adopted standards to allow readers to more easily assess the credibility of their journalism. Our best practices, including our verification and correction policies, <a href="https://highlandscurrent.org/editorial-standards/" data-wpel-link="internal">can be accessed here</a>. Have a comment? A news tip? Spot an error? Email <a href="/cdn-cgi/l/email-protection#d3b6b7baa7bca193bbbab4bbbfb2bdb7a0b0a6a1a1b6bda7fdbca1b4"><span class="__cf_email__" data-cfemail="1673727f627964567e7f717e7a777872657563646473786238796471">[email&#160;protected]</span></a>.</div></aside><aside id="trust_indicators_article-3" class="widget widget-5 odd default trust_indicators_article clearfix"><h3 class="widgettitle">What Type of Story?</h3><p><strong>Type</strong>: News</p><p>News: Based on facts, either observed and verified directly by the reporter, or reported and verified from knowledgeable sources.</p>
</aside><aside id="text-88" class="widget widget-6 even default widget_text clearfix"> <div class="textwidget"><hr />
</div>
</aside></div> <div id="comments" class="clearfix">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/10/22/meet-your-candidates/#respond" style="display:none;" data-wpel-link="internal">Cancel reply</a></small></h3><form action="https://highlandscurrent.org/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment_notes">The Current welcomes comments on its coverage and local issues. Submissions are selected by the editor to provide a variety of opinions and voices, and all are subject to editing for accuracy, clarity and length. We ask that writers remain civil and avoid personal attacks. Submissions must include your first and last name (no pseudonyms), as well as a valid email address (which will not be published). Please allow up to 24 hours for an approved submission to be posted. All online comments may also appear in print.</p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" required='required' /></p>
<p class="comment-form-url"><label for="url">Town Village City</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<input type="hidden" name="_mc4wp_subscribe_wp-comment-form" value="0" /><p class=" mc4wp-checkbox mc4wp-checkbox-wp-comment-form"><label><input type="checkbox" name="_mc4wp_subscribe_wp-comment-form" value="1" /><span> Sign me up for news updates</span></label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='4670581' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="6a67957317" /></p><input type="hidden" id="ct_checkjs_287e03db1d99e0ec2edb90d079e142f3" name="ct_checkjs" value="0" /><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">setTimeout(function(){var ct_input_name = "ct_checkjs_287e03db1d99e0ec2edb90d079e142f3";if (document.getElementById(ct_input_name) !== null) {var ct_input_value = document.getElementById(ct_input_name).value;document.getElementById(ct_input_name).value = document.getElementById(ct_input_name).value.replace(ct_input_value, '658866348');}}, 1000);</script><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="49" /><script>document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</div>
</div>
<aside id="sidebar" class="span4 nocontent">
<div class="widget-area" role="complementary">
<aside id="wpp-2" class="widget widget-1 odd default popular-posts clearfix">
<h3 class="widgettitle">Trending Right Now</h3>
<ul class="wpp-list wpp-list-with-thumbnails">
<li>
<a href="https://highlandscurrent.org/2021/10/19/looking-back-in-beacon-22/" target="_self" data-wpel-link="internal"><img width="60" height="60" src="https://highlandscurrent.org/wp-content/uploads/2021/10/50-YEARS-william-few-60x60.jpg" class="wpp-thumbnail wpp_featured attachment-60x60 size-60x60 wp-post-image" alt="William Few" loading="lazy" srcset="https://highlandscurrent.org/wp-content/uploads/2021/10/50-YEARS-william-few-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2021/10/50-YEARS-william-few-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2021/10/50-YEARS-william-few-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2021/10/50-YEARS-william-few-613x600.jpg 613w, https://highlandscurrent.org/wp-content/uploads/2021/10/50-YEARS-william-few-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2021/10/50-YEARS-william-few-200x200.jpg 200w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<a href="https://highlandscurrent.org/2021/10/19/looking-back-in-beacon-22/" class="wpp-post-title" target="_self" data-wpel-link="internal">Looking Back in Beacon</a>
<span class="wpp-meta post-stats"><span class="wpp-author">by <a href="https://highlandscurrent.org/author/crowe/" data-wpel-link="internal">Chip Rowe</a></span> | <span class="wpp-date">posted on October 19, 2021</span></span>
</li>
<li>
<a href="https://highlandscurrent.org/2021/10/22/merandy-endorses-tamagna-for-cold-spring-mayor/" target="_self" data-wpel-link="internal"><img width="60" height="60" src="https://highlandscurrent.org/wp-content/uploads/2021/03/merandy-60x60.jpg" class="wpp-thumbnail wpp_featured attachment-60x60 size-60x60 wp-post-image" alt="Merandy" loading="lazy" srcset="https://highlandscurrent.org/wp-content/uploads/2021/03/merandy-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2021/03/merandy-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2021/03/merandy-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2021/03/merandy-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2021/03/merandy-200x200.jpg 200w, https://highlandscurrent.org/wp-content/uploads/2021/03/merandy-80x80.jpg 80w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<a href="https://highlandscurrent.org/2021/10/22/merandy-endorses-tamagna-for-cold-spring-mayor/" class="wpp-post-title" target="_self" data-wpel-link="internal">Merandy Endorses Tamagna for Cold Spring Mayor</a>
<span class="wpp-meta post-stats"><span class="wpp-author">by <a href="https://highlandscurrent.org/author/crowe/" data-wpel-link="internal">Chip Rowe</a></span> | <span class="wpp-date">posted on October 22, 2021</span></span>
</li>
<li>
<a href="https://highlandscurrent.org/2021/10/21/latest-coronavirus-update/" target="_self" data-wpel-link="internal"><img width="60" height="60" src="https://highlandscurrent.org/wp-content/uploads/2021/09/AdobeStock_374847977-60x60.jpeg" class="wpp-thumbnail wpp_featured attachment-60x60 size-60x60 wp-post-image" alt="Covid Update" loading="lazy" srcset="https://highlandscurrent.org/wp-content/uploads/2021/09/AdobeStock_374847977-60x60.jpeg 60w, https://highlandscurrent.org/wp-content/uploads/2021/09/AdobeStock_374847977-140x140.jpeg 140w, https://highlandscurrent.org/wp-content/uploads/2021/09/AdobeStock_374847977-96x96.jpeg 96w, https://highlandscurrent.org/wp-content/uploads/2021/09/AdobeStock_374847977-125x125.jpeg 125w, https://highlandscurrent.org/wp-content/uploads/2021/09/AdobeStock_374847977-200x200.jpeg 200w, https://highlandscurrent.org/wp-content/uploads/2021/09/AdobeStock_374847977-80x80.jpeg 80w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<a href="https://highlandscurrent.org/2021/10/21/latest-coronavirus-update/" class="wpp-post-title" target="_self" data-wpel-link="internal">Latest Coronavirus Update</a>
<span class="wpp-meta post-stats"><span class="wpp-author">by <a href="https://highlandscurrent.org/author/site-editor/" data-wpel-link="internal">Staff</a></span> | <span class="wpp-date">posted on October 21, 2021</span></span>
</li>
<li>
<a href="https://highlandscurrent.org/2021/10/22/challenger-accuses-sheriff-of-misconduct/" target="_self" data-wpel-link="internal"><img width="60" height="60" src="https://highlandscurrent.org/wp-content/uploads/2021/10/collage-sheriff-60x60.jpg" class="wpp-thumbnail wpp_featured attachment-60x60 size-60x60 wp-post-image" alt="McConville Langley" loading="lazy" srcset="https://highlandscurrent.org/wp-content/uploads/2021/10/collage-sheriff-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2021/10/collage-sheriff-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2021/10/collage-sheriff-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2021/10/collage-sheriff-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2021/10/collage-sheriff-200x200.jpg 200w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<a href="https://highlandscurrent.org/2021/10/22/challenger-accuses-sheriff-of-misconduct/" class="wpp-post-title" target="_self" data-wpel-link="internal">Challenger Accuses Sheriff of Misconduct</a>
<span class="wpp-meta post-stats"><span class="wpp-author">by <a href="https://highlandscurrent.org/author/crowe/" data-wpel-link="internal">Chip Rowe</a></span> | <span class="wpp-date">posted on October 22, 2021</span></span>
</li>
<li>
<a href="https://highlandscurrent.org/2021/10/22/beacon-election-preview/" target="_self" data-wpel-link="internal"><img width="60" height="60" src="https://highlandscurrent.org/wp-content/uploads/2021/05/vote-flag-60x60.jpg" class="wpp-thumbnail wpp_featured attachment-60x60 size-60x60 wp-post-image" alt="Vote results" loading="lazy" srcset="https://highlandscurrent.org/wp-content/uploads/2021/05/vote-flag-60x60.jpg 60w, https://highlandscurrent.org/wp-content/uploads/2021/05/vote-flag-140x140.jpg 140w, https://highlandscurrent.org/wp-content/uploads/2021/05/vote-flag-96x96.jpg 96w, https://highlandscurrent.org/wp-content/uploads/2021/05/vote-flag-125x125.jpg 125w, https://highlandscurrent.org/wp-content/uploads/2021/05/vote-flag-200x200.jpg 200w, https://highlandscurrent.org/wp-content/uploads/2021/05/vote-flag-80x80.jpg 80w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<a href="https://highlandscurrent.org/2021/10/22/beacon-election-preview/" class="wpp-post-title" target="_self" data-wpel-link="internal">Beacon Election Preview</a>
<span class="wpp-meta post-stats"><span class="wpp-author">by <a href="https://highlandscurrent.org/author/jsimms/" data-wpel-link="internal">Jeff Simms</a></span> | <span class="wpp-date">posted on October 22, 2021</span></span>
</li>
</ul>
</aside>
<aside id="text-73" class="widget widget-2 even default widget_text clearfix"> <div class="textwidget"><hr />
</div>
</aside><aside id="largo-about-widget-3" class="widget widget-3 odd default largo-about clearfix"><h3 class="widgettitle"><a href="https://highlandcurrent.org/membership" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span>About The Current</a></h3><p><a href="https://highlandscurrent.org/membership" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2019/12/join-us-200.jpg" alt="Join Now!" align="right" height="75" width="75"></a>We are a <a href="https://highlandscurrent.org/membership/" data-wpel-link="internal">member-supported</a>, nonprofit media organization that serves the communities of Philipstown (Cold Spring, Nelsonville and Garrison) and Beacon, New York, in the Hudson Highlands. <a href="https://highlandscurrent.org/membership" data-wpel-link="internal">Click here to support our journalism</a>.
<hr></p></aside><aside id="ai_widget-7" class="widget widget-4 even default ai_widget clearfix"><div class='code-block code-block-3 ai-track' data-ai='WzMsIiIsIjMwMHgyNTAgVG9wIiwiIiwxXQ==' style='margin: 8px 0; clear: both;'>
<style>
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-filter-check, .ai-fallback, .ai-list-block, .ai-list-block-ip, .ai-list-block-filter {visibility: hidden; position: absolute; width: 50%; height: 1px; top: -1000px; z-index: -9999; margin: 0px!important;}
</style>
<div class='ai-rotate ai-unprocessed ai-3' data-info='WzMsN10=' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="QQ==" data-time="MTA=">
<a href="https://www.southerndutchesseye.com" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/10/HighlandsCurrentWebButtonAd_Oct2021.png" alt="Southern Dutchess Eye Care"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qg==" data-time="MTA=">
<a href="https://mblink.it/1PHBl1PLA" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/09/generac.jpg" alt="Generac"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qw==" data-time="MTA=">
<a href="http://www.busterlevigallery.com/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/10/buster-levi-oct.png" alt="Buster Levi"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="RA==" data-time="MTA=">
<a href="http://www.juniperbirth.com/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/10/juniper-birth-300.jpg" alt="Juniper"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="RQ==" data-time="MTA=">
<a href="http://www.hvhospice.org/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/10/HV-Hospice.jpg" alt="HV Hospice"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Rg==" data-time="MTA=">
<a href="https://fb.me/e/VqAuaT1a" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/10/ronguitar.jpg" alt-"RonzWorld"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Rw==" data-time="MTA=">
<a href="https://highlandscurrent.org/halloween-costume-contest/" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2021/10/halloween_300x250.png" alt-"Costume Contest"></a></div>
</div>
</div>
</aside><aside id="custom_html-37" class="widget_text widget widget-5 odd default widget_custom_html clearfix"><div class="textwidget custom-html-widget">See your ad here. <a href="https://highlandscurrent.org/advertise/" data-wpel-link="internal">Click for details.</a></div></aside><aside id="text-76" class="widget widget-6 even default widget_text clearfix"> <div class="textwidget"><hr />
</div>
</aside><aside id="featured_ads_widget-3" class="widget widget-7 odd default widget_featured_ads_widget clearfix"><h3 class="widgettitle">Featured Classifieds</h3><ul class="awpcp-listings-widget-items-list"><li class="awpcp-listings-widget-item awpcp-listings-widget-item-with-thumbnail-above-in-desktop awpcp-listings-widget-item-with-thumbnail-above-in-mobile featured_ad_item awpcp-listings-widget-item-without-thumbnail"><div class="awpcplatestbox awpcp-clearfix"><div class="awpcp-listings-widget-item--title-and-content"><div class="awpcp-listing-title"><a href="https://highlandscurrent.org/phils-list/show-ad/4462446/server-hostess-helper-available/positions-wanted/" data-wpel-link="internal">Server/Hostess/Helper Available</a></div> <div class="awpcp-listings-widget-item-excerpt">For in-home parties and events. 20 years of experience.  Call Diane at 845-222-3093.</div></div><p class="awpcp-widget-read-more-container"><a class="awpcp-widget-read-more" href="https://highlandscurrent.org/phils-list/show-ad/4462446/server-hostess-helper-available/positions-wanted/" data-wpel-link="internal">[Read more]</a></p></div></li>
<li class="awpcp-listings-widget-item awpcp-listings-widget-item-with-thumbnail-above-in-desktop awpcp-listings-widget-item-with-thumbnail-above-in-mobile featured_ad_item awpcp-listings-widget-item-without-thumbnail"><div class="awpcplatestbox awpcp-clearfix"><div class="awpcp-listings-widget-item--title-and-content"><div class="awpcp-listing-title"><a href="https://highlandscurrent.org/phils-list/show-ad/4211308/healing-bodywork-with-vaccinated-joy-matalon/services/" data-wpel-link="internal">Healing Bodywork with Vaccinated Joy Matalon</a></div> <div class="awpcp-listings-widget-item-excerpt">Featured in New York magazine as "one of the best 15 massage therapists in NYC&hellip;</div></div><p class="awpcp-widget-read-more-container"><a class="awpcp-widget-read-more" href="https://highlandscurrent.org/phils-list/show-ad/4211308/healing-bodywork-with-vaccinated-joy-matalon/services/" data-wpel-link="internal">[Read more]</a></p></div></li>
<li class="awpcp-listings-widget-item awpcp-listings-widget-item-with-thumbnail-above-in-desktop awpcp-listings-widget-item-with-thumbnail-above-in-mobile featured_ad_item awpcp-listings-widget-item-without-thumbnail"><div class="awpcplatestbox awpcp-clearfix"><div class="awpcp-listings-widget-item--title-and-content"><div class="awpcp-listing-title"><a href="https://highlandscurrent.org/phils-list/show-ad/4368770/3-simple-steps-to-school-success/services/" data-wpel-link="internal">3 Simple Steps to School Success</a></div> <div class="awpcp-listings-widget-item-excerpt">Study system that works from Sara Dulaney Gilbert, local writing and study skills coach. Locally&hellip;</div></div><p class="awpcp-widget-read-more-container"><a class="awpcp-widget-read-more" href="https://highlandscurrent.org/phils-list/show-ad/4368770/3-simple-steps-to-school-success/services/" data-wpel-link="internal">[Read more]</a></p></div></li>
<li class="awpcp-listings-widget-item awpcp-listings-widget-item-with-thumbnail-above-in-desktop awpcp-listings-widget-item-with-thumbnail-above-in-mobile featured_ad_item awpcp-listings-widget-item-without-thumbnail"><div class="awpcplatestbox awpcp-clearfix"><div class="awpcp-listings-widget-item--title-and-content"><div class="awpcp-listing-title"><a href="https://highlandscurrent.org/phils-list/show-ad/4315462/wanted-cleaning-service/help-wanted/" data-wpel-link="internal">Wanted: Cleaning Service</a></div> <div class="awpcp-listings-widget-item-excerpt">The Highlands Current is looking for a service that would be willing to clean our&hellip;</div></div><p class="awpcp-widget-read-more-container"><a class="awpcp-widget-read-more" href="https://highlandscurrent.org/phils-list/show-ad/4315462/wanted-cleaning-service/help-wanted/" data-wpel-link="internal">[Read more]</a></p></div></li>
<li class="awpcp-listings-widget-item awpcp-listings-widget-item-with-thumbnail-above-in-desktop awpcp-listings-widget-item-with-thumbnail-above-in-mobile featured_ad_item awpcp-listings-widget-item-without-thumbnail"><div class="awpcplatestbox awpcp-clearfix"><div class="awpcp-listings-widget-item--title-and-content"><div class="awpcp-listing-title"><a href="https://highlandscurrent.org/phils-list/show-ad/4595431/for-rent-beacon-1br-plus-office/real-estate-for-sale-rent/" data-wpel-link="internal">For Rent: Beacon 1BR Plus Office</a></div> <div class="awpcp-listings-widget-item-excerpt">Beautiful bright, spacious one-bedroom plus office, original hardwood floors. First-floor office space, second-floor kitchen, dining,&hellip;</div></div><p class="awpcp-widget-read-more-container"><a class="awpcp-widget-read-more" href="https://highlandscurrent.org/phils-list/show-ad/4595431/for-rent-beacon-1br-plus-office/real-estate-for-sale-rent/" data-wpel-link="internal">[Read more]</a></p></div></li></ul></aside><aside id="text-48" class="widget widget-8 even default widget_text clearfix"> <div class="textwidget"><p>Tag sale? Car for sale? Space for rent? Help wanted? <a href="https://highlandscurrent.org/phils-list/place-ad/" data-wpel-link="internal">Place your ad here for $4.95</a>.</p>
<hr />
</div>
</aside><aside id="ai_widget-6" class="widget widget-9 odd default ai_widget clearfix"><div class='code-block code-block-4 ai-track' data-ai='WzQsIiIsIjMwMHgyNTAgYm90dG9tIiwiIiwxXQ==' style='margin: 8px 0; clear: both;'>
<style>
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-filter-check, .ai-fallback, .ai-list-block, .ai-list-block-ip, .ai-list-block-filter {visibility: hidden; position: absolute; width: 50%; height: 1px; top: -1000px; z-index: -9999; margin: 0px!important;}
</style>
<div class='ai-rotate ai-unprocessed ai-4' data-info='WzQsN10=' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="QQ==" data-time="MTA=">
<a href="https://www.southerndutchesseye.com" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/10/HighlandsCurrentWebButtonAd_Oct2021.png" alt="Southern Dutchess Eye Care"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qg==" data-time="MTA=">
<a href="http://www.juniperbirth.com/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/10/juniper-birth-300.jpg" alt="Juniper"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qw==" data-time="MTA=">
<a href="http://www.hvhospice.org/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/10/HV-Hospice.jpg" alt="HV Hospice"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="RA==" data-time="MTA=">
<a href="https://mblink.it/1PHBl1PLA" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/09/generac.jpg" alt="Generac"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="RQ==" data-time="MTA=">
<a href="http://www.busterlevigallery.com/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/10/buster-levi-oct.png" alt="Buster Levi"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Rg==" data-time="MTA=">
<a href="https://fb.me/e/VqAuaT1a" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/10/ronguitar.jpg" alt-"RonzWorld"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Rw==" data-time="MTA=">
<a href="https://highlandscurrent.org/halloween-costume-contest/" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2021/10/halloween_300x250.png" alt-"Costume Contest"></a></div>
</div>
</div>
</aside><aside id="custom_html-38" class="widget_text widget widget-10 even default widget_custom_html clearfix"><div class="textwidget custom-html-widget">See your ad here. <a href="https://highlandscurrent.org/advertise/" data-wpel-link="internal">Click for details.</a></div></aside><aside id="text-91" class="widget widget-11 odd default widget_text clearfix"> <div class="textwidget"><hr />
</div>
</aside><aside id="mc4wp_form_widget-10" class="widget widget-12 even default widget_mc4wp_form_widget clearfix"><h3 class="widgettitle">Free Newsletters</h3><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-91454 mc4wp-ajax" method="post" data-id="91454" data-name="Free Newsletter"><div class="mc4wp-form-fields"><p>
<p>
<label>
<input name="INTERESTS[492a248734][]" type="checkbox" value="4819c3c69d" checked="true"> <span>News Updates (M, F)</span>
</label>
<label>
<input name="INTERESTS[492a248734][]" type="checkbox" value="e4d30e5c43" checked="true"> <span>Weekend Preview (Th)</span>
</label>
<label>
<input name="INTERESTS[492a248734][]" type="checkbox" value="82dceafde7" checked="true"> <span>Occasional Updates / Events</span>
</label>
</p>
</p>
<input type="text" name="FNAME" placeholder="First name" required><br>
<input type="text" name="LNAME" placeholder="Last name" required><br>
<input type="text" name="ZIP" placeholder="Zip code" required><br>
<input type="email" name="EMAIL" placeholder="Email address" required /><br>
<br>
<input type="submit" value="Sign me up!" /></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1634940254" /><input type="hidden" name="_mc4wp_form_id" value="91454" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2" /><div class="mc4wp-response"></div></form></aside> </div>
</aside>
</div> 
</div>
<div class="footer-bg clearfix nocontent">
<footer id="site-footer">
<div id="supplementary" class="row-fluid _3col-default">
<div class="span3 widget-area" role="complementary">
<aside id="text-54" class="widget widget-1 odd default widget_text clearfix"><h3 class="widgettitle">Reader Guide</h3> <div class="textwidget"><p><a href="https://highlandscurrent.org/pick-paper/" data-wpel-link="internal">Where to find paper</a><br />
<a href="https://highlandscurrent.org/delivery/" data-wpel-link="internal">Get mail delivery</a><br />
<a href="https://highlandscurrent.org/add-the-current-to-your-phone/" data-wpel-link="internal">Add icon to phone</a><br />
<a href="https://highlandscurrent.org/editorial-standards/" data-wpel-link="internal">Editorial standards</a><br />
<a href="/cdn-cgi/l/email-protection#c4a1a0adb0abb684acada3aca8a5aaa0b7a7b1b6b6a1aab0eaabb6a3">Email the editor</a></p>
</div>
</aside><aside id="gtranslate-2" class="widget widget-2 even default widget_gtranslate clearfix">
<a href="#" onclick="doGTranslate(&#039;en|en&#039;);return false;" title="English" class="gflag nturl" style="background-position:-0px -0px;"><img src="https://highlandscurrent.org/wp-content/plugins/gtranslate/blank.png" height="24" width="24" alt="English" /></a><a href="#" onclick="doGTranslate(&#039;en|fr&#039;);return false;" title="French" class="gflag nturl" style="background-position:-200px -100px;"><img src="https://highlandscurrent.org/wp-content/plugins/gtranslate/blank.png" height="24" width="24" alt="French" /></a><a href="#" onclick="doGTranslate(&#039;en|de&#039;);return false;" title="German" class="gflag nturl" style="background-position:-300px -100px;"><img src="https://highlandscurrent.org/wp-content/plugins/gtranslate/blank.png" height="24" width="24" alt="German" /></a><a href="#" onclick="doGTranslate(&#039;en|it&#039;);return false;" title="Italian" class="gflag nturl" style="background-position:-600px -100px;"><img src="https://highlandscurrent.org/wp-content/plugins/gtranslate/blank.png" height="24" width="24" alt="Italian" /></a><a href="#" onclick="doGTranslate(&#039;en|ru&#039;);return false;" title="Russian" class="gflag nturl" style="background-position:-500px -200px;"><img src="https://highlandscurrent.org/wp-content/plugins/gtranslate/blank.png" height="24" width="24" alt="Russian" /></a><a href="#" onclick="doGTranslate(&#039;en|es&#039;);return false;" title="Spanish" class="gflag nturl" style="background-position:-600px -200px;"><img src="https://highlandscurrent.org/wp-content/plugins/gtranslate/blank.png" height="24" width="24" alt="Spanish" /></a><style type="text/css">
<!--
#goog-gt-tt {display:none !important;}
.goog-te-banner-frame {display:none !important;}
.goog-te-menu-value:hover {text-decoration:none !important;}
body {top:0 !important;}
#google_translate_element2 {display:none!important;}
-->
</style>
<div id="google_translate_element2"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
function googleTranslateElementInit2() {new google.translate.TranslateElement({pageLanguage: 'en',autoDisplay: false}, 'google_translate_element2');}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit2"></script>
<script type="text/javascript">
/* <![CDATA[ */
function GTranslateFireEvent(element,event){try{if(document.createEventObject){var evt=document.createEventObject();element.fireEvent('on'+event,evt)}else{var evt=document.createEvent('HTMLEvents');evt.initEvent(event,true,true);element.dispatchEvent(evt)}}catch(e){}}function doGTranslate(lang_pair){if(lang_pair.value)lang_pair=lang_pair.value;if(lang_pair=='')return;var lang=lang_pair.split('|')[1];var teCombo;var sel=document.getElementsByTagName('select');for(var i=0;i<sel.length;i++)if(sel[i].className=='goog-te-combo')teCombo=sel[i];if(document.getElementById('google_translate_element2')==null||document.getElementById('google_translate_element2').innerHTML.length==0||teCombo.length==0||teCombo.innerHTML.length==0){setTimeout(function(){doGTranslate(lang_pair)},500)}else{teCombo.value=lang;GTranslateFireEvent(teCombo,'change');GTranslateFireEvent(teCombo,'change')}}
/* ]]> */
</script>
</aside></div>
<div class="span6 widget-area" role="complementary">
<aside id="ai_widget-2" class="widget widget-1 odd default ai_widget clearfix"><div class='code-block code-block-1 ai-track' data-ai='WzEsIiIsIkJvdHRvbSBvZiBQYWdlIiwiIiwxXQ==' style='margin: 8px 0; clear: both;'>
<style>
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-filter-check, .ai-fallback, .ai-list-block, .ai-list-block-ip, .ai-list-block-filter {visibility: hidden; position: absolute; width: 50%; height: 1px; top: -1000px; z-index: -9999; margin: 0px!important;}
</style>
<div class='ai-rotate ai-unprocessed ai-1' data-info='WzEsNl0=' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="QQ==" data-time="MTA=">
<a href="https://highlandscurrent.org/delivery" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2021/01/OnlineHouseLONG-Deliver_border.jpg" alt="Mail delivery ad"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qg==" data-time="MTA=">
<a href="https://www.philipstowndemocrats.org/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/09/PDems_T.P.Online_Banner_Ad_2021_HC.png" alt="Vote Van Tassel"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qw==" data-time="MTA=">
<a href="https://highlandscurrent.org/membership" data-wpel-link="internal"><img src="https://highlandscurrent.org/wp-content/uploads/2021/01/OnlineHouseLONG-Support_border.jpg" alt="Membership ad"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="RA==" data-time="MTA=">
<a href="https://www.philipstowndemocrats.org/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/09/PDems_T.P.Online_Banner_Ad_2021_HC2.png" alt="Vote Cotter"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="RQ==" data-time="MTA=">
<a href="https://mblink.it/1P4Xl1PLB" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/04/1P4Xl1PLB.jpg" alt="Generac generators"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Rg==" data-time="MTA=">
<a href="https://www.philipstowndemocrats.org/" data-wpel-link="external" target="_blank" rel="external noopener"><img src="https://highlandscurrent.org/wp-content/uploads/2021/09/PDems_T.P.Online_Banner_Ad_2021_HC3.png" alt="Vote Angell"></a></div>
</div>
</div>
</aside><aside id="text-81" class="widget widget-2 even default widget_text clearfix"> <div class="textwidget"><hr />
<p><center><em>The Highlands Current</em> is a member of the<br />
New York Press Association<br />
National Newspaper Association<br />
New York News Publishers Association<br />
Local Independent Online News<br />
Institute for Nonprofit News</center></p>
</div>
</aside></div>
<div class="span3 widget-area" role="complementary">
<aside id="text-78" class="widget widget-1 odd default widget_text clearfix"><h3 class="widgettitle">The Highlands Current</h3> <div class="textwidget"><p>142 Main St.<br />
Cold Spring, NY 10516<br />
845-809-5584<br />
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="5f3a3b362b302d1f37363837333e313b2c3c2a2d2d3a312b71302d38">[email&#160;protected]</a><br />
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="87e6e3f4c7efeee0efebe6e9e3f4e4f2f5f5e2e9f3a9e8f5e0">[email&#160;protected]</a><br />
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="f99a98959c979d988bb991909e919598979d8a9a8c8b8b9c978dd7968b9e">[email&#160;protected]</a></p>
</div>
</aside></div>
</div>
<div id="boilerplate">
<div class="row-fluid clearfix">
<div class="span6">
<ul id="footer-social" class="social-icons">
<li><a href="https://facebook.com/highlandscurrent" title="Link to Facebook Profile" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/highlandcurrent" title="Link to Twitter Page" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span><i class="icon-twitter"></i></a></li><li><a href="https://www.youtube.com/c/HighlandsCurrent" title="Link to YouTube Page" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span><i class="icon-youtube"></i></a></li><li><a href="https://instagram.com/highlandscurrent" title="Link to Instagram Page" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span><i class="icon-instagram"></i></a></li><li><a href="https://linkedin.com/company/highlands-current" title="Link to LinkedIn Page" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span><i class="icon-linkedin"></i></a></li><li><a href="https://highlandscurrent.org/feed/" title="Link to RSS Feed" data-wpel-link="internal"><i class="icon-rss"></i></a></li> </ul>
<div class="footer-bottom clearfix">

<p class="footer-credit">&copy; Copyright 2021, Highlands Current Inc.</p>
<ul id="menu-footer-bottom" class="menu"><li id="menu-item-300318" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-300318"><a href="https://highlandscurrent.org/awards/" data-wpel-link="internal">Awards</a></li>
<li id="menu-item-3301089" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3301089"><a href="https://highlandscurrent.org/podcast" data-wpel-link="internal">Audio</a></li>
<li id="menu-item-536422" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-536422"><a href="https://highlandscurrent.org/editorial-standards/" data-wpel-link="internal">Editorial Standards</a></li>
<li id="menu-item-293639" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293639"><a href="https://highlandscurrent.org/archives/" data-wpel-link="internal">Back Issues</a></li>
<li id="menu-item-293641" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293641"><a href="https://highlandscurrent.org/delivery/" data-wpel-link="internal">Delivery</a></li>
<li id="menu-item-318802" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-318802"><a href="https://highlandscurrent.org/privacy" data-wpel-link="internal">Privacy</a></li>
<li id="menu-item-293643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293643"><a href="https://highlandscurrent.org/contact/" data-wpel-link="internal">Contact</a></li>
</ul> </div>
</div>
<div class="span6 right">
<a href="//inn.org/" id="inn-logo-container" data-wpel-link="external" target="_blank" rel="external noopener">
<img id="inn-logo" src="https://highlandscurrent.org/wp-content/themes/largo-0.6.3/img/inn_light.svg" alt="The Highlands Current is a member of the Institute for Nonprofit News" />
</a>
<p class="footer-credit ">Built with the <a href="https://largo.inn.org/" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span>Largo WordPress Theme</a> from the <a href="https://inn.org" data-wpel-link="external" target="_blank" rel="external noopener" class="wpel-icon-left"><span class="wpel-icon wpel-image wpel-icon-6"></span>Institute for Nonprofit News</a>.</p>
</div>
</div>
<p class="back-to-top visuallyhidden"><a href="#top">Back to top &uarr;</a></p>
</div>
</footer>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
			if (typeof jQuery != 'undefined') {

				function sfsi_plus_align_icons_center_orientation(_centerPosition) {

					function applyOrientation() {

						var elemF = jQuery('#sfsi_plus_floater');

						if (elemF.length > 0) {

							switch (_centerPosition) {
								case 'center-right':
								case 'center-left':
									var toptalign = (jQuery(window).height() - elemF.height()) / 2;
									elemF.css('top', toptalign);
									break;

								case 'center-top':
								case 'center-bottom':
									var leftalign = (jQuery(window).width() - elemF.width()) / 2;
									elemF.css('left', leftalign);

									break;
							}
						}
					}

					var prev_onresize = window.onresize;
					window.onresize = function(event) {

						if ('function' === typeof prev_onload) {
							prev_onresize(), applyOrientation();
						} else {
							applyOrientation();
						}
					}
				}

				jQuery(document).ready(function(e) {
					jQuery("body").addClass("sfsi_plus_15.9")
				});

				function sfsi_plus_processfurther(ref) {
					var feed_id = 'dlNyVHBUaHkxc3VTcTNBcGNsZVdjSXo0bVdNQzh3WkowRldkYlJFbm01Rmk3SXFhdWZJdUpiS1Vpb3NLYXhZak9jMENPZm1KcFc1Vi9qNXBkRlZERkJGdE5DYy90eGtMWFB1Smg1eEEyclpHZHRyM0VabkVHdW4ydHg3Qi9iUmF8OFZGV1B0OTJmaHlWWkw1MG80emZTSnhXM2IxWCt3ektpSkNidzlUM29tQT0=';
					var feedtype = 8;
					var email = jQuery(ref).find('input[name="email"]').val();
					var filter = /^([a-zA-Z0-9_\.\-])+\@(([a-zA-Z0-9\-])+\.)+([a-zA-Z0-9]{2,4})+$/;
					if ((email != "Enter your email") && (filter.test(email))) {
						if (feedtype == "8") {
							var url = "https://api.follow.it/subscription-form/" + feed_id + "/" + feedtype;
							window.open(url, "popupwindow", "scrollbars=yes,width=1080,height=760");
							return true;
						}
					} else {
						alert("Please enter email address");
						jQuery(ref).find('input[name="email"]').focus();
						return false;
					}
				}
			}
		</script>
<style type="text/css">
			.sfsi_plus_widget_sub_container .sfsiplus_norm_row.sfsi_plus_wDiv {
				width: 140px !important;
			}

			.sfsi_plus_widget.sfsi_plus_widget_sub_container {
				text-align: left;
			}

			.sfsi_plus_widget.sfsi_plus_widget_sub_container {
				float: left;
			}

			.sfsi_plus_widget.sfsi_plus_widget_sub_container .sfsiplus_norm_row.sfsi_plus_wDiv {
				position: relative !important;
			}

			.sfsi_plus_widget.sfsi_plus_widget_sub_container .sfsi_plus_holders {
				display: none;
			}

			.sfsi_plus_shortcode_container {
				/* float: left; */
			}

			.sfsi_plus_shortcode_container .sfsiplus_norm_row.sfsi_plus_wDiv {
				position: relative !important;
			}

			.sfsi_plus_shortcode_container .sfsi_plus_holders {
				display: none;
			}

			.sfsiaftrpstwpr .sfsi_plus_Sicons div:first-child span,
			.sfsibeforpstwpr .sfsi_plus_Sicons div:first-child span {
				font-size: 20px;
				font-style: normal;
				font-family: inherit;
				color: #000000;
			}

			.sfsibeforpstwpr,
			.sfsiaftrpstwpr {
				margin-top: 5px !important;
				margin-bottom: 5px !important;
			}

			.sfsi_plus_rectangle_icons_shortcode_container {
				margin-top: 5px !important;
				margin-bottom: 5px !important;
			}

			.sfsi_plus_subscribe_Popinner {
				width: 100% !important;
				height: auto !important;
				border: 1px solid #b5b5b5 !important;
				padding: 18px 0px !important;
				background-color: #ffffff !important;
			}

			@media screen and (max-width: 768px) {
				.sfsi_premium_responsive_fixed_width .sfsi_premium_responsive_icon_item_container.sfsi_premium_medium_button {
													width: 37px !important;
								height: 37px !important;
								padding: 10px !important;
								border-radius: 30px !important;
								text-align: center !important;
								display: flex;
								align-items: center;
								justify-content: center;
									}
			}

			.sfsi_plus_subscribe_Popinner form {
				margin: 0 20px !important;
			}

			.sfsi_plus_subscribe_Popinner h5 {
				font-family: Helvetica,Arial,sans-serif;
				font-weight: bold !important;
				color: #000000 !important;
				font-size: 16px !important;
				text-align: center !important;
				margin: 0 0 10px !important;
				padding: 0 !important;
			}

			.sfsi_plus_subscription_form_field {
				margin: 5px 0 !important;
				width: 100% !important;
				display: inline-flex;
				display: -webkit-inline-flex;
			}

			.sfsi_plus_subscription_form_field input {
				width: 100% !important;
				padding: 10px 0px !important;
			}

			.sfsi_plus_subscribe_Popinner input[type=email] {
				font-family: Helvetica,Arial,sans-serif;
				font-style: normal !important;
				color: #000000 !important;
				font-size: 14px !important;
				text-align: center !important;
			}

			.sfsi_plus_subscribe_Popinner input[type=email]::-webkit-input-placeholder {
				font-family: Helvetica,Arial,sans-serif !important;
				font-style: normal !important;
				color: #000000 !important;
				font-size: 14px !important;
				text-align: center !important;
			}

			.sfsi_plus_subscribe_Popinner input[type=email]:-moz-placeholder {
				/* Firefox 18- */
				font-family: Helvetica,Arial,sans-serif !important;
				font-style: normal !important;
				color: #000000 !important;
				font-size: 14px !important;
				text-align: center !important;
			}

			.sfsi_plus_subscribe_Popinner input[type=email]::-moz-placeholder {
				/* Firefox 19+ */
				font-family: Helvetica,Arial,sans-serif !important;
				font-style: normal !important;
				color: #000000 !important;
				font-size: 14px !important;
				text-align: center !important;
			}

			.sfsi_plus_subscribe_Popinner input[type=email]:-ms-input-placeholder {
				font-family: Helvetica,Arial,sans-serif !important;
				font-style: normal !important;
				color: #000000 !important;
				font-size: 14px !important;
				text-align: center !important;
			}

			.sfsi_plus_subscribe_Popinner input[type=submit] {
				font-family: Helvetica,Arial,sans-serif !important;
				font-weight: bold !important;
				color: #000000 !important;
				font-size: 16px !important;
				text-align: center !important;
				background-color: #dedede !important;
			}
		</style>
<div style="display: none;"><div id="boxzilla-box-307282-content"><h4>Free News Updates</h4>
<p>Sign up to receive updates by email (no spam).<br />
<script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><form id="mc4wp-form-3" class="mc4wp-form mc4wp-form-91454 mc4wp-ajax" method="post" data-id="91454" data-name="Free Newsletter"><div class="mc4wp-form-fields"><p>
<p>
<label>
<input name="INTERESTS[492a248734][]" type="checkbox" value="4819c3c69d" checked="true"> <span>News Updates (M, F)</span>
</label>
<label>
<input name="INTERESTS[492a248734][]" type="checkbox" value="e4d30e5c43" checked="true"> <span>Weekend Preview (Th)</span>
</label>
<label>
<input name="INTERESTS[492a248734][]" type="checkbox" value="82dceafde7" checked="true"> <span>Occasional Updates / Events</span>
</label>
</p>
</p>
<input type="text" name="FNAME" placeholder="First name" required><br>
<input type="text" name="LNAME" placeholder="Last name" required><br>
<input type="text" name="ZIP" placeholder="Zip code" required><br>
<input type="email" name="EMAIL" placeholder="Email address" required /><br>
<br>
<input type="submit" value="Sign me up!" /></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1634940254" /><input type="hidden" name="_mc4wp_form_id" value="91454" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-3" /><div class="mc4wp-response"></div></form><br />
<span style="font-size: 10pt;">You will receive an email shortly asking you to confirm your subscription.</span></p>
</div></div>
<script type="text/javascript">
				/* Code to show flip effect on mouseover of icon STARTS */
				(function($) {

					$(document).ready(function() {

						var allIcons = $(".sfsiplus_inerCnt");

						$.each(allIcons, function(i, elem) {

							var currElem = $(elem);

							var othericoneffect = currElem.attr("data-othericoneffect");

							if ("string" === typeof othericoneffect && othericoneffect.length > 0) {

								var backElem = currElem.find('.sciconback');

								if (backElem.length == 1) {

									switch (othericoneffect) {

										case "noeffect":

											var frontElem = currElem.find('.sciconfront');

											currElem.hover(function() {

												if (frontElem.hasClass("sfsihide")) {
													frontElem.removeClass("sfsihide").addClass('sfsishow');
													backElem.removeClass("sfsishow").addClass('sfsihide');
												} else if (frontElem.hasClass("sfsishow")) {
													frontElem.removeClass("sfsishow").addClass('sfsihide');
													backElem.removeClass("sfsihide").addClass('sfsishow');
												}

											});

											break;

										case "flip":

											currElem.hover(function() {
												$(this).trigger("click");
											});

											var frontElem = currElem.find('.sciconfront');

											currElem.flip({

												axis: 'x',
												trigger: 'click',
												reverse: true,
												front: frontElem,
												back: backElem,
												autoSize: true
											}, function() {

											});

											break;

									}

								}

							}

						});

					});

				})(jQuery);

				/* Code to show flip effect on mouseover of icon STARTS */
			</script>
<script type="text/javascript">
					var __limit = 'no';

					function sfsi_plus_setCookie(name, value, time) {
						var date = new Date();
						date.setTime(date.getTime() + (time * 1000));
						document.cookie = name + "=" + value + "; expires=" + date.toGMTString() + "; path=/";
					}

					function sfsi_plus_getCookie(name) {
						var nameEQ = name + "=";
						var ca = document.cookie.split(';');
						for (var i = 0; i < ca.length; i++) {
							var c = ca[i];
							while (c.charAt(0) == ' ') c = c.substring(1, c.length);
							if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length, c.length)
						}
						return null;
					}

					function sfsi_plus_eraseCookie(name) {
						sfsi_plus_setCookie(name, null, -1)
					}

					/* Returns timestamp in the second */
					function sfsi_plusGetCurrentUTCTimestamp() {
						var tmLoc = new Date();
						/* The offset is in minutes -- convert it to ms */
						var timeStamp = (tmLoc.getTime() + tmLoc.getTimezoneOffset() * 60000) / 1000;
						return Math.floor(timeStamp);
					}

					function sfsi_plusGetCurrentTimestamp() {
						var tmLoc = new Date();
						/* The offset is in minutes -- convert it to ms */
						var timeStamp = (tmLoc.getTime()) / 1000;
						return Math.floor(timeStamp);
					}

					function sfsi_plus_is_null_or_undefined(value) {

						var type = Object.prototype.toString.call(value);

						if ("[object Null]" == type || "[object Undefined]" == type) {
							return true;
						}

						return false;
					}

					var __popTime = 0;

					function sfsi_plusShallShowPopup(_popUpTime) {

						var _popUpTime = parseInt(_popUpTime);
						var _currTimestamp = parseInt(sfsi_plusGetCurrentTimestamp());
						var _sfsi_popupCookie = parseInt(sfsi_plus_getCookie('sfsi_popup'));

						_shallShowPopup = true;

						if (false != _popUpTime && typeof _sfsi_popupCookie != 'undefined' && _sfsi_popupCookie != null) {

							_diff = (_sfsi_popupCookie - _currTimestamp) < _popUpTime;

							if (_diff) {
								_shallShowPopup = false;
							}
						}

						return _shallShowPopup;

					}

					function sfsi_plus_hidemypopup() {
						SFSI(".sfsi_plus_FrntInner").fadeOut("fast");

						
					if (__limit == "yes") {
						sfsi_plus_setCookie("sfsi_popup", "yes", __popTime);
					}
					}
				</script>
<script>
				if (typeof jQuery !== 'undefined') {

					jQuery(document).ready(function($) {

						if ("yes" != __limit) {
							sfsi_plus_eraseCookie('sfsi_popup');
						}

						jQuery(document).scroll(function($) {

							var cookieVal = sfsi_plus_getCookie("sfsi_popup");

							if (sfsi_plus_is_null_or_undefined(cookieVal)) {

								var y = jQuery(this).scrollTop();

								var _Hide_popupOnScroll = 'yes';
								_Hide_popupOnScroll = 0 == _Hide_popupOnScroll.length ? 'no' : _Hide_popupOnScroll;
								var disatancefrombottom= jQuery(document).height()-(jQuery(window).scrollTop() + jQuery(window).height());
								if (/Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent)) {
									if (disatancefrombottom < 100) {
										jQuery('.sfsi_plus_outr_div').css({
											'z-index': '9996',
											opacity: 1,
											top: (jQuery(window).scrollTop() +(jQuery(window).height() >200? ((jQuery(window).height() - 200)/2): (jQuery(window).height() - 200) ) + "px"),
											position: "absolute"
										});
										jQuery('.sfsi_plus_outr_div').fadeIn(200);
										jQuery('.sfsi_plus_FrntInner').fadeIn(200);

										if ("yes" == __limit) {
											sfsi_plus_setCookie("sfsi_popup", "yes", __popTime);
										}

									} else {
										if ("yes" == _Hide_popupOnScroll) {
											jQuery('.sfsi_plus_outr_div').fadeOut();
											jQuery('.sfsi_plus_FrntInner').fadeOut();
										}
									}
								} else {
									
									if (disatancefrombottom<3) {

										jQuery('.sfsi_plus_outr_div').css({
											'z-index': '9996',
											opacity: 1,
											top: (jQuery(window).scrollTop() +(jQuery(window).height() >200? ((jQuery(window).height() - 200)/2): (jQuery(window).height() - 200) ) + "px"),
											position: "absolute"
										});
										jQuery('.sfsi_plus_outr_div').fadeIn(200);
										jQuery('.sfsi_plus_FrntInner').fadeIn(200);

										if ("yes" == __limit) {
											sfsi_plus_setCookie("sfsi_popup", "yes", __popTime);
										}

									} else {

										if ("yes" == _Hide_popupOnScroll) {
											jQuery('.sfsi_plus_outr_div').fadeOut();
											jQuery('.sfsi_plus_FrntInner').fadeOut();
										}
									}
								}
							}
						});
					});
				}
			</script>
</div>
<div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div><div id="mv-grow-data" data-settings='{&quot;general&quot;:{&quot;contentSelector&quot;:false},&quot;shareCounts&quot;:[],&quot;shouldRun&quot;:true,&quot;buttonSVG&quot;:{&quot;facebook&quot;:{&quot;height&quot;:32,&quot;width&quot;:18,&quot;paths&quot;:[&quot;M17.12 0.224v4.704h-2.784q-1.536 0-2.080 0.64t-0.544 1.92v3.392h5.248l-0.704 5.28h-4.544v13.568h-5.472v-13.568h-4.544v-5.28h4.544v-3.904q0-3.328 1.856-5.152t4.96-1.824q2.624 0 4.064 0.224z&quot;]},&quot;twitter&quot;:{&quot;height&quot;:32,&quot;width&quot;:30,&quot;paths&quot;:[&quot;M28.928 7.296q-1.184 1.728-2.88 2.976 0 0.256 0 0.736 0 2.336-0.672 4.64t-2.048 4.448-3.296 3.744-4.608 2.624-5.792 0.96q-4.832 0-8.832-2.592 0.608 0.064 1.376 0.064 4.032 0 7.168-2.464-1.888-0.032-3.36-1.152t-2.048-2.848q0.608 0.096 1.088 0.096 0.768 0 1.536-0.192-2.016-0.416-3.328-1.984t-1.312-3.68v-0.064q1.216 0.672 2.624 0.736-1.184-0.8-1.888-2.048t-0.704-2.752q0-1.568 0.8-2.912 2.176 2.656 5.248 4.256t6.656 1.76q-0.16-0.672-0.16-1.312 0-2.4 1.696-4.064t4.064-1.696q2.528 0 4.224 1.824 1.952-0.384 3.68-1.408-0.672 2.048-2.56 3.2 1.664-0.192 3.328-0.896z&quot;]},&quot;email&quot;:{&quot;height&quot;:32,&quot;width&quot;:28,&quot;paths&quot;:[&quot;M18.56 17.408l8.256 8.544h-25.248l8.288-8.448 4.32 4.064zM2.016 6.048h24.32l-12.16 11.584zM20.128 15.936l8.224-7.744v16.256zM0 24.448v-16.256l8.288 7.776z&quot;]}},&quot;inlineContentHook&quot;:[&quot;loop_start&quot;]}'></div><script>
              (function(e){
                  var el = document.createElement('script');
                  el.setAttribute('data-account', '5bVXSNZ6nq');
                  el.setAttribute('src', 'https://cdn.userway.org/widget.js');
                  document.body.appendChild(el);
                })();
              </script>
<script type="text/javascript">
				var _paq = _paq || [];
					_paq.push(['setCustomDimension', 1, '{"ID":24,"name":"Jeff Simms","avatar":"a9b3a449bac7e8eac98955132b335283"}']);
				_paq.push(['trackPageView']);
								(function () {
					var u = "https://stats1.wpmudev.com/";
					_paq.push(['setTrackerUrl', u + 'track/']);
					_paq.push(['setSiteId', '21431']);
					var d   = document, g = d.createElement('script'), s = d.getElementsByTagName('script')[0];
					g.type  = 'text/javascript';
					g.async = true;
					g.defer = true;
					g.src   = 'https://stats.wpmucdn.com/analytics.js';
					s.parentNode.insertBefore(g, s);
				})();
			</script>
<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script><a href="https://highlandscurrent.org/membership" target="_blank" id="rum_sst_tab" class="rum_sst_contents rum_sst_right" data-wpel-link="internal">Become a Member</a><link rel='stylesheet' id='gtranslate-style-css' href='https://highlandscurrent.org/wp-content/plugins/gtranslate/gtranslate-style24.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://highlandscurrent.org/wp-includes/css/dist/block-library/style.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='better-recent-comments-css' href='https://highlandscurrent.org/wp-content/plugins/better-recent-comments/assets/css/better-recent-comments.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='twenty20-style-css' href='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/6ac99203677383459720944dca6f95f9.css' type='text/css' media='all' />
<link rel='stylesheet' id='weather-atlas-css' href='https://highlandscurrent.org/wp-content/plugins/weather-atlas/public/css/weather-atlas-public.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-css' href='https://highlandscurrent.org/wp-content/plugins/weather-atlas/public/font/weather-icons/weather-icons.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='crossword-custom-css' href='https://highlandscurrent.org/wp-content/plugins/wp-crossword/modules/css/custom.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slick-css' href='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/204a5af90f0badaf96c3ff62d2346542.css' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slides-css' href='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/46b0b8315ce50574afbdbc624a50b97f.css' type='text/css' media='all' />
<link rel='stylesheet' id='largo-stylesheet-gutenberg-css' href='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/css/gutenberg.min.css?ver=1561210853' type='text/css' media='all' />
<link rel='stylesheet' id='wpbdp-zip-module-css' href='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/9434d08cf2afffe40107852104d240c6.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpbdp-jquery-ui-css-css' href='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/6c79d2f4cd4b87f41293182bc86b4765.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpbdp-widgets-css' href='https://highlandscurrent.org/wp-content/plugins/business-directory-plugin/assets/css/widgets.min.css?ver=5.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-qtip-css' href='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/css/vendor/jquery.qtip.min.css?ver=3.1.36' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-grid-css' href='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/css/default-calendar-grid.min.css?ver=3.1.36' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-list-css' href='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/css/default-calendar-list.min.css?ver=3.1.36' type='text/css' media='all' />
<link rel='stylesheet' id='pwaforwp-style-css' href='https://highlandscurrent.org/wp-content/plugins/pwa-for-wp/assets/css/pwaforwp-main.min.css?ver=1.7.39' type='text/css' media='all' />
<link rel='stylesheet' id='default-styles-css' href='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/dcdc25744e4eba936ce924ea9da81707.css' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-font-awesome-css' href='https://use.fontawesome.com/releases/v5.2.0/css/all.css?ver=5.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-frontend-style-css' href='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/e1ab62c8f3b3b3871bd501bad862d705.css' type='text/css' media='all' />
<!--[if lte IE 6]>
<link rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/5288ef1f11cf7b9a4dd53a60cecbac88.css' type='text/css' media='all' />
<![endif]-->
<!--[if lte IE 7]>
<link rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='https://highlandscurrent.org/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css?ver=4.1.5' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='awpcp-custom-css-css' href='https://highlandscurrent.org/wp-content/plugins/awpcp_custom_stylesheet.css?ver=4.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='modal-css' href='https://highlandscurrent.org/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.css?ver=4.3.23' type='text/css' media='all' />
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/comment-reply.min.js?ver=5.8.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/Ultimate-Premium-Plugin/js/shuffle/modernizr.custom.min.js?ver=5.8.1' id='SFSIPLUSjqueryModernizr-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/Ultimate-Premium-Plugin/js/shuffle/jquery.shuffle.min.js?ver=5.8.1' id='SFSIPLUSjqueryShuffle-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/Ultimate-Premium-Plugin/js/shuffle/random-shuffle-min.js?ver=5.8.1' id='SFSIPLUSjqueryrandom-shuffle-js'></script>
<script type='text/javascript' id='SFSIPLUSCustomJs-js-extra'>
/* <![CDATA[ */
var sfsi_premium_ajax_object = {"ajax_url":"https:\/\/highlandscurrent.org\/wp-admin\/admin-ajax.php","plugin_url":"https:\/\/highlandscurrent.org\/wp-content\/plugins\/Ultimate-Premium-Plugin\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/Ultimate-Premium-Plugin/js/custom.js?ver=5.8.1' id='SFSIPLUSCustomJs-js'></script>
<script type='text/javascript' id='ct_public-js-extra'>
/* <![CDATA[ */
var ctPublic = {"pixel__setting":"0","pixel__enabled":"","pixel__url":null,"data__email_check_before_post":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.min.js?ver=5.164.1' id='ct_public-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/cleantalk-spam-protect/js/cleantalk_external.min.js?ver=5.164.1' id='ct_external-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/document-gallery/assets/js/gallery.min.js?ver=4.4.3' id='document-gallery-js'></script>
<script type='text/javascript' async data-noptimize src='https://highlandscurrent.org/wp-content/plugins/social-pug/assets/dist/front-end-free.1.19.1.js?ver=1.19.1' id='dpsp-frontend-js-pro-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/twenty20/assets/js/jquery.twenty20.js?ver=1.5.7' id='twenty20-style-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/twenty20/assets/js/jquery.event.move.js?ver=1.5.7' id='twenty20-eventmove-style-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/jquery/ui/menu.min.js?ver=1.12.1' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/dist/dom-ready.min.js?ver=71883072590656bf22c74c7b887df3dd' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/dist/i18n.min.js?ver=5f1269854226b4dd90450db411a12b79' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/dist/a11y.min.js?ver=0ac8327cc1c40dcfdf29716affd7ac63' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.12.1' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/weather-atlas/public/js/weather-atlas-public.min.js?ver=1.2.1' id='weather-atlas-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/weather-atlas/public/js/jquery-cookie.min.js?ver=1.2.1' id='jquery-cookie-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/2bccd90444d7e525eb8575f64fa4b7af.js' id='crossword-custom-js'></script>
<script type='text/javascript' id='largoCore-js-extra'>
/* <![CDATA[ */
var Largo = {"is_home":"","is_single":"1","sticky_nav_options":{"sticky_nav_display":true,"main_nav_hide_article":false,"nav_overflow_label":"More"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/js/largoCore.min.js?ver=0.6.3' id='largoCore-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/js/navigation.min.js?ver=1561210853' id='largo-navigation-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/js/largoPlugins.js?ver=0.6.3' id='largoPlugins-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/lib/navis-slideshows/vendor/slick/slick.min.js?ver=1561210853' id='jquery-slick-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/themes/largo-0.6.3/lib/navis-slideshows/js/navis-slideshows.js?ver=1561210853' id='navis-slideshows-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/uploads/hummingbird-assets/e46659b7827b5fbd9431c1b22139c225.js' id='wpbdp-zipcodesearch-js-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/business-directory-categories/resources/categories-module.min.js?ver=4.0.1' id='wpbdp-categories-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/js/vendor/jquery.qtip.min.js?ver=3.1.36' id='simcal-qtip-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/js/vendor/moment.min.js?ver=3.1.36' id='simcal-fullcal-moment-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/js/vendor/moment-timezone-with-data.min.js?ver=3.1.36' id='simcal-moment-timezone-js'></script>
<script type='text/javascript' id='simcal-default-calendar-js-extra'>
/* <![CDATA[ */
var simcal_default_calendar = {"ajax_url":"\/wp-admin\/admin-ajax.php","nonce":"01232872f1","locale":"en_US","text_dir":"ltr","months":{"full":["January","February","March","April","May","June","July","August","September","October","November","December"],"short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"]},"days":{"full":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]},"meridiem":{"AM":"AM","am":"am","PM":"PM","pm":"pm"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/js/default-calendar.min.js?ver=3.1.36' id='simcal-default-calendar-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/pwa-register-sw.js?ver=1.7.39' id='pwa-main-script-js'></script>
<script type='text/javascript' id='boxzilla-js-extra'>
/* <![CDATA[ */
var boxzilla_options = {"testMode":"","boxes":[{"id":307282,"icon":"&times;","content":"","css":{"background_color":"#edf9ff","width":340,"border_color":"#5f7fb5","border_width":4,"border_style":"solid","position":"center"},"trigger":{"method":"percentage","value":25},"animation":"slide","cookie":{"triggered":720,"dismissed":720},"rehide":true,"position":"center","screenWidthCondition":null,"closable":true,"post":{"id":307282,"title":"Free News Updates","slug":"free-news-updates"}}]};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/boxzilla/assets/js/script.min.js?ver=3.2.25' id='boxzilla-js'></script>
<script type='text/javascript' defer src='https://highlandscurrent.org/wp-content/plugins/mailchimp-for-wp/assets/js/forms.js?ver=4.8.6' id='mc4wp-forms-api-js'></script>
<script type='text/javascript' id='mc4wp-ajax-forms-js-extra'>
/* <![CDATA[ */
var mc4wp_ajax_vars = {"loading_character":"\u2022","ajax_url":"https:\/\/highlandscurrent.org\/wp-admin\/admin-ajax.php?action=mc4wp-form","error_text":"Oops. Something went wrong. Please try again later."};
/* ]]> */
</script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/mc4wp-premium/ajax-forms/assets/js/ajax-forms.js?ver=4.8.19' id='mc4wp-ajax-forms-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/google-calendar-events/assets/js/vendor/imagesloaded.pkgd.min.js?ver=3.1.36' id='simplecalendar-imagesloaded-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-includes/js/wp-embed.min.js?ver=5.8.1' id='wp-embed-js'></script>
<script type='text/javascript' src='https://highlandscurrent.org/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.js?ver=4.3.23' id='modal-js'></script>
<script type="text/javascript">
	     	jQuery('.soliloquy-container').removeClass('no-js');
	   </script>
<style></style>

<object id="ai-adb-dblclk" data="https://securepubads.g.doubleclick.net/tag/js/gpt.js" style="position:absolute; z-index: -100; top: -1000px; left: -1000px; visibility: hidden;"></object>
<object id="ai-adb-ga" data="https://www.google-analytics.com/analytics.js" style="position:absolute; z-index: -100; top: -1000px; left: -1000px; visibility: hidden;"></object>
<object id="ai-adb-mn" data="//contextual.media.net/dmedianet.js" style="position:absolute; z-index: -100; 1px; top: -1000px; left: -1000px; visibility: hidden;"></object>
<div id="banner-advert-container" class="adsense sponsor-ad" style="position:absolute; z-index: -10; height: 1px; width: 1px; top: -100px; left: -100px;"><img id="im_popupFixed" class="ad-inserter adsense ad-img ad-index" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/images/ads.png" width="1" height="1" alt="pixel"></div>
<script async id="ai-adb-ads" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/js/ads.js?ver=2.7.4-1632451699"></script>
<script async id="ai-adb-sponsors" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/js/sponsors.js?ver=2.7.4-1632451700"></script>
<script async id="ai-adb-advertising" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/js/advertising.js?ver=2.7.4-1632451699"></script>
<script async id="ai-adb-adverts" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/js/adverts.js?ver=2.7.4-1632451699"></script>
<script async id="ai-adb-banner" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/js/banner.js?ver=2.7.4"></script>
<script async id="ai-adb-300x250" src="https://highlandscurrent.org/wp-content/plugins/ad-inserter-pro/js/300x250.js?ver=2.7.4"></script>


<script>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</script>
</body>
</html>
